From fa59134e06b7da6003ccf3b88f47228f8e3c95af Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Fri, 12 Nov 2010 21:59:24 +0000
Subject: ghostscript: update to latest

---
 abs/core/ghostscript/PKGBUILD               | 34 ++++++++++-------------------
 abs/core/ghostscript/ghostscript-fPIC.patch | 11 ----------
 2 files changed, 11 insertions(+), 34 deletions(-)

diff --git a/abs/core/ghostscript/PKGBUILD b/abs/core/ghostscript/PKGBUILD
index f4139ff..c479bdc 100644
--- a/abs/core/ghostscript/PKGBUILD
+++ b/abs/core/ghostscript/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 73021 2010-03-21 21:20:23Z andyrtr $
+# $Id: PKGBUILD 94631 2010-10-08 20:42:27Z andyrtr $
 # Maintainer: AndyRTR <andyrtr@archlinux.org>
 
 pkgname=ghostscript
-pkgver=8.71
-pkgrel=3
+pkgver=9.00
+pkgrel=1
 pkgdesc="An interpreter for the PostScript language"
 arch=('i686' 'x86_64')
 license=('GPL3' 'custom')
@@ -17,34 +17,19 @@ provides=('ghostscript-lprng')
 url="http://www.ghostscript.com/"
 source=(http://ghostscript.com/releases/ghostscript-${pkgver}.tar.xz
 	ghostscript-fPIC.patch
-	ghostscript-system-jasper.patch
-	libpng14.patch
-	ghostscript-pdf2dsc.patch
-	svn_r10890.patch)
+	ghostscript-system-jasper.patch)
 options=('!libtool' '!makeflags')
-md5sums=('5005d68f7395c2bfc4b05c1a60d9b6ba'
-         '1a8fcacf0005214db823225c870f093d'
-         '03e27cd02471ab3b642c344fa06b623e'
-         'be94ee357986f7f63d1b470da5bdc99e'
-         'f88f3764fc11e3ae2a86b17d2502da2f'
-         'fe0888a74d7870af234ad53a2f74380a')
+md5sums=('1ca5f245677f78f573e6490bdb40702f'
+         '766d44c47c693f96941b658e360c1277'
+         '03e27cd02471ab3b642c344fa06b623e')
 
 build() {
   cd ${srcdir}/ghostscript-${pkgver}
   # force it to use system-libs
   rm -rf jpeg libpng zlib jasper expat
 
-  patch -Np1 -i ${srcdir}/libpng14.patch || return 1
-
   # fix build with systems jasper
   patch -Np1 -i ${srcdir}/ghostscript-system-jasper.patch || return 1
-  
-  # fix PDF viewing with gv - from Fedora
-  patch -Np1 -i ${srcdir}/ghostscript-pdf2dsc.patch || return 1
-  
-  # fix segfaults - http://bugs.archlinux.org/task/18339
-  patch -Np1 -i ${srcdir}/svn_r10890.patch || return 1
-
 
   if [ "$CARCH" = "x86_64" ]; then
     patch -Np1 -i ${srcdir}/ghostscript-fPIC.patch || return 1
@@ -64,7 +49,10 @@ build() {
 	      --with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts \
 	      --disable-compile-inits # needed for linking with system-zlib
   make || return 1
-  make -j1 DESTDIR=${pkgdir} \
+}
+package() {
+        cd ${srcdir}/ghostscript-${pkgver}
+        make -j1 DESTDIR=${pkgdir} \
 	cups_serverroot=${pkgdir}/etc/cups \
 	cups_serverbin=${pkgdir}/usr/lib/cups install soinstall
 
diff --git a/abs/core/ghostscript/ghostscript-fPIC.patch b/abs/core/ghostscript/ghostscript-fPIC.patch
index f5b1b30..6f89996 100644
--- a/abs/core/ghostscript/ghostscript-fPIC.patch
+++ b/abs/core/ghostscript/ghostscript-fPIC.patch
@@ -18,14 +18,3 @@
  
  ###### Create a pseudo-"feature" for the entire graphics library.
  
---- ghostscript-8.60-r8112/base/devs.mak.fPIC	2007-07-10 17:05:00.000000000 +0100
-+++ ghostscript-8.60-r8112/base/devs.mak	2007-07-10 17:05:07.000000000 +0100
-@@ -464,7 +464,7 @@
- 	$(GLCCSHARED) $(XINCLUDE) $(GLO_)gdevx.$(OBJ) $(C_) $(GLSRC)gdevx.c
- 
- $(GLOBJ)gdevxcmp.$(OBJ) : $(GLSRC)gdevxcmp.c $(GDEVX) $(math__h)
--	$(GLCC) $(XINCLUDE) $(GLO_)gdevxcmp.$(OBJ) $(C_) $(GLSRC)gdevxcmp.c
-+	$(GLCCSHARED) $(XINCLUDE) $(GLO_)gdevxcmp.$(OBJ) $(C_) $(GLSRC)gdevxcmp.c
- 
- $(GLOBJ)gdevxini.$(OBJ) : $(GLSRC)gdevxini.c $(GDEVX) $(memory__h)\
-  $(gserrors_h) $(gsparamx_h) $(gxdevmem_h) $(gdevbbox_h)
-- 
cgit v0.12