From 6bd43445bf5c8570859f946d1ac1850819d68299 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 6 Aug 2012 21:28:28 -0500
Subject: gobject-introspection 1.32.1

---
 abs/core/gobject-introspection/PKGBUILD | 30 ++++++++++++++----------------
 1 file changed, 14 insertions(+), 16 deletions(-)

diff --git a/abs/core/gobject-introspection/PKGBUILD b/abs/core/gobject-introspection/PKGBUILD
index ce2809c..972a8a9 100644
--- a/abs/core/gobject-introspection/PKGBUILD
+++ b/abs/core/gobject-introspection/PKGBUILD
@@ -1,31 +1,29 @@
-# $Id: PKGBUILD 97051 2010-10-26 08:54:52Z ibiru $
+# $Id: PKGBUILD 157399 2012-04-28 09:26:41Z allan $
 # Maintainer: Jan de Groot <jgc@archlinux.org>
+
 pkgname=gobject-introspection
-pkgver=0.9.12
-pkgrel=1
+pkgver=1.32.1
+pkgrel=2
 pkgdesc="Introspection system for GObject-based libraries"
 url="http://live.gnome.org/GObjectInstrospection"
 arch=('x86_64' 'i686')
 license=('LGPL' 'GPL')
-depends=('libffi>=3.0.9' 'glib2>=2.26.0' 'python2')
+depends=('glib2' 'python2')
 makedepends=('cairo')
-conflicts=('gir-repository')
-replaces=('gir-repository')
 options=('!libtool')
-source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/0.9/${pkgname}-${pkgver}.tar.bz2)
-sha256sums=('9c0060d66d14a060057a1fc005be73675a1b8a00d4968ce8e78ff2d6b9f84e81')
+source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz)
+sha256sums=('44f3fb933f76e4728818cc360cb5f9e2edcbdf9bc8a8f9aded99b3e3ef5cb858')
 
 build() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-  ./configure --prefix=/usr --disable-static
-  make || return 1
+  cd "$pkgname-$pkgver"
+  PYTHON=/usr/bin/python2 ./configure --prefix=/usr --disable-static
+  make
 }
 
 package() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-  make DESTDIR="${pkgdir}" install || return 1
+  cd "$pkgname-$pkgver"
+  make DESTDIR="$pkgdir" install
 
-  sed -i "s|#!/usr/bin/env python|#!/usr/bin/env python2|" \
-    "${pkgdir}"/usr/lib/gobject-introspection/giscanner/*.py
+  sed -i '1s|#!/usr/bin/env python$|&2|' \
+    "$pkgdir"/usr/lib/gobject-introspection/giscanner/*.py
 }
-
-- 
cgit v0.12