From 9624d2106fa1bbd153b4e9dc23df51ab82091e1e Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 12 Dec 2013 16:19:14 -0600
Subject: xymon: add description for some modules. refs #945

---
 abs/core/xymon/PKGBUILD         | 11 ++++++++---
 abs/core/xymon/hobbit_notify.sh |  2 +-
 2 files changed, 9 insertions(+), 4 deletions(-)

diff --git a/abs/core/xymon/PKGBUILD b/abs/core/xymon/PKGBUILD
index e880b98..8163f32 100755
--- a/abs/core/xymon/PKGBUILD
+++ b/abs/core/xymon/PKGBUILD
@@ -1,7 +1,7 @@
 pkgbase=xymon
 pkgname=(xymonserver xymonclient)
 pkgver=4.3.5
-pkgrel=54
+pkgrel=55
 pkgdesc="Hobbit is a system for monitoring servers and networks. "
 license="GPL"
 arch=('i686' 'x86_64')
@@ -74,7 +74,7 @@ package_xymonserver(){
 
       install -D  -m644 $startdir/src/logrotate-server.xymon $startdir/pkg/xymonserver/etc/logrotate.d/xymon-server
 
-# fix env for mythtb bindingds
+      # fix env for mythtb bindingds
       echo "MYTHCONFDIR=/usr/share/mythtv" >> $startdir/pkg/xymonserver/home/xymon/etc/xymonserver.cfg
 
 
@@ -95,6 +95,11 @@ package_xymonserver(){
       #make dir for login alerts
       mkdir $startdir/pkg/xymonserver/home/xymon/var/login_alerts
 
+      #add custom module descriptions
+      COLDOC=$pkgdir/home/xymon/etc/columndoc.csv
+      echo "myth_mtc;The <b>myth_mtc</b> column shows the status of the MythTV maintenance script.;" >> $COLDOC
+      echo "orphan;The <b>orphan</b> column shows the status of the find_orphans.py script.;" >> $COLDOC
+
       #fix permissions
       chmod 775 $startdir/pkg/xymonserver/data/srv/httpd/htdocs/
       chmod 775 $startdir/pkg/xymonserver/data/srv/httpd/htdocs/xymon/
@@ -142,7 +147,7 @@ md5sums=('31923ec126fe1c264fceb459d2175161'
          '0c808fa12672289f86b0651545381308'
          '0469d775db9fdd18ea95dd41937ada82'
          '0757294eec13771f8e63da23cf066796'
-         '6baa410da1dfb86435191f4805186ea7'
+         '270e13da6cbc9d49079d994edaa71e64'
          '4bc37b700146e4f4206a729c835903b0'
          '9af2ad60ac4c3cb653754618f603e311'
          'b8eb10070f2ad6a245d3da15091694ba'
diff --git a/abs/core/xymon/hobbit_notify.sh b/abs/core/xymon/hobbit_notify.sh
index 742b3db..26b789f 100644
--- a/abs/core/xymon/hobbit_notify.sh
+++ b/abs/core/xymon/hobbit_notify.sh
@@ -71,7 +71,7 @@ case x$BBSVCNAME in
 
  *)
     #catch all for everything else
-    msg_func_out "Condition $BBCOLORLEVEL\n$BBHOSTNAME  $BBSVCNAME\n Please check the system health webpage|alert"
+    msg_func_out "Condition $BBCOLORLEVEL $BBSVCNAME on $BBHOSTNAME\nSee the system health webpage.|alert"
     ;;
 esac
 
-- 
cgit v0.12