From a231d03ceb599df23f2affcfa3457368103a7643 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 24 May 2018 19:59:31 +0000
Subject: linhes-theme: add spinbox entry dialog

---
 abs/core/linhes-theme/PKGBUILD       |  4 +-
 abs/core/linhes-theme/base.xml.patch | 85 ++++++++++++++++++++++++++++++++++--
 2 files changed, 83 insertions(+), 6 deletions(-)

diff --git a/abs/core/linhes-theme/PKGBUILD b/abs/core/linhes-theme/PKGBUILD
index 9db52b4..b230947 100755
--- a/abs/core/linhes-theme/PKGBUILD
+++ b/abs/core/linhes-theme/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=linhes-theme
 pkgver=8.5.1
-pkgrel=6
+pkgrel=7
 pkgdesc="Default LinHES MythTV theme"
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -99,7 +99,7 @@ package() {
 }
 md5sums=('2dca856c2a4d1f959473512c94e43b60'
          '3fc2c8838a9e331a2d19c114760a5acb'
-         '027739567b8dd634a09af7c86276c9e3'
+         '391f8e5d43ca846b04a5e8119dccc8cf'
          'd1d54968a2297924673d9653f707df33'
          '25ff929dc4aca3b2a0bd38d9ded5a6b8'
          '26a6db272dee225b9e4dc282f1494e51'
diff --git a/abs/core/linhes-theme/base.xml.patch b/abs/core/linhes-theme/base.xml.patch
index b113f5f..1357b37 100644
--- a/abs/core/linhes-theme/base.xml.patch
+++ b/abs/core/linhes-theme/base.xml.patch
@@ -1,5 +1,5 @@
 --- base.xml.orig	2018-04-17 14:44:34.438582684 +0000
-+++ base.xml	2018-04-17 14:41:40.151269060 +0000
++++ base.xml	2018-05-24 19:32:20.152603456 +0000
 @@ -3,55 +3,55 @@
  <mythuitheme>
  
@@ -706,7 +706,84 @@
              </statetype>
          </buttonlist>
  
-@@ -2819,7 +2897,7 @@
+@@ -2813,13 +2891,84 @@
+         </button>
+     </window>
+ 
++    <!-- Popup dialog to enter into a spin box -->
++    <window name="SpinBoxEntryDialog">
++        <area>-1,-1,587,178</area>
++
++        <animation trigger="AboutToShow">
++            <section>
++                <alpha start="0" end="255" easingcurve="OutQuart"/>
++                <zoom start="0" end="100" easingcurve="OutQuart"/>
++            </section>
++        </animation>
++
++        <animation trigger="AboutToHide">
++            <section>
++                <alpha start="255" end="0" easingcurve="InQuart"/>
++                <zoom start="100" end="0" easingcurve="InQuart"/>
++            </section>
++        </animation>
++
++        <shape name="spinbox-entry-backdrop" from="base_popup_backdrop">
++            <area>0,0,587,178</area>
++        </shape>
++
++        <shape name="spinbox-entry-backdrop-line" from="base_backdrop_line">
++            <area>1,1,585,176</area>
++        </shape>
++
++        <shape name="spinbox-entry-dialog-top-line" from="base_highlight_line">
++            <area>2,2,583,2</area>
++        </shape>
++
++        <shape name="spinbox-entry-dialog-bottom-line" from="base_highlight_line">
++            <area>2,174,583,2</area>
++        </shape>
++
++        <shape name="spinbox-entry-dialog-left-line" from="base_highlight_vertical_line">
++            <area>2,4,2,170</area>
++        </shape>
++
++        <shape name="spinbox-entry-dialog-right-line" from="base_highlight_vertical_line">
++            <area>583,4,2,170</area>
++        </shape>
++<!--
++        <textarea name="title" from="basetextarea">
++            <area>10,14,567,36</area>
++            <font>basesmall</font>
++            <align>allcenter</align>
++            <value>Enter a value:</value>
++        </textarea>
++-->
++        <textarea name="rules" from="basetextarea">
++            <area>10,14,567,36</area>
++            <font>basesmall</font>
++            <align>allcenter</align>
++            <template>Enter %LOW% to %HIGH% in increments of %STEP%:</template>
++        </textarea>
++
++        <textedit name="entry" from="base_textedit">
++            <area>50,62,487,40</area>
++        </textedit>
++<!--
++        <button name="cancel" from="base_button">
++            <area>50,124,150,35</area>
++            <value>Cancel</value>
++        </button>
++-->
++        <button name="ok" from="base_button">
++            <area>218,124,150,35</area>
++            <value>OK</value>
++        </button>
++    </window>
++
+     <window name="MythFileBrowser">
+         <area>0,0,1280,720</area>
+ 
          <group name="fanart-group" from="base_fanart_group" />
  
          <textarea name="heading" from="base_heading">
@@ -715,7 +792,7 @@
          </textarea>
  
          <shape name="fullpath-backdrop" from="base_backdrop">
-@@ -2836,87 +2914,85 @@
+@@ -2836,87 +2985,85 @@
          </shape>
  
          <shape name="file-browser-preview-backdrop" from="base_backdrop">
@@ -824,7 +901,7 @@
              <statetype name="buttonitem">
                  <state name="active">
                      <area>0,0,599,54</area>
-@@ -3029,52 +3105,53 @@
+@@ -3029,52 +3176,53 @@
          </buttonlist>
  
          <textedit name="location" from="base_textedit">
-- 
cgit v0.12