From 3a21f86ce044101bec01db95777c0476f7868d92 Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sat, 6 Jun 2009 12:25:01 -0700
Subject: Default fuppes.cfg file.

---
 abs/extra-testing/fuppes-svn/fuppes.cfg | 216 ++++++++++++++++++++++++++++++++
 1 file changed, 216 insertions(+)
 create mode 100644 abs/extra-testing/fuppes-svn/fuppes.cfg

diff --git a/abs/extra-testing/fuppes-svn/fuppes.cfg b/abs/extra-testing/fuppes-svn/fuppes.cfg
new file mode 100644
index 0000000..beb81cf
--- /dev/null
+++ b/abs/extra-testing/fuppes-svn/fuppes.cfg
@@ -0,0 +1,216 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<fuppes_config version="0.7.2.3">
+  <shared_objects>
+    <!--<dir>/mnt/music</dir>-->
+    <!--<itunes>/Users/.../iTunes.xml</itunes>-->
+    <dir>/myth/tv</dir>
+    <dir>/myth/video</dir>
+    <dir>/myth/music</dir>
+    <dir>/myth/gallery</dir>
+    <dir>/myth/pretty</dir>
+  </shared_objects>
+  <network>
+    <!--empty = automatic detection-->
+    <interface>192.168.1.253</interface>
+    <!--empty or 0 = random port-->
+    <http_port>81</http_port>
+    <!--list of ip addresses allowed to access fuppes. if empty all ips are allowed-->
+    <allowed_ips>
+      <!--<ip>192.168.0.1</ip>-->
+    </allowed_ips>
+  </network>
+  <content_directory>
+    <!--a list of possible charsets can be found under:
+      http://www.gnu.org/software/libiconv/-->
+    <local_charset>UTF-8</local_charset>
+    <!--libs used for metadata extraction when building the database. [true|false]-->
+    <use_imagemagick>true</use_imagemagick>
+    <use_taglib>true</use_taglib>
+    <use_libavformat>true</use_libavformat>
+  </content_directory>
+  <global_settings>
+    <temp_dir/>
+    <!--uuid is written to and read from <config-dir>/uuid.txt if set to true-->
+    <use_fixed_uuid>false</use_fixed_uuid>
+  </global_settings>
+  <device_settings>
+    <!--"default" settings are inhertied by specific devices and can be overwritten-->
+    <!--do NOT remove the "default" device settings-->
+    <!--all new file types have to be added to the default settings-->
+    <!--adding new file types just to a specific device will have no affect-->
+    <device name="default">
+      <!--specify the maximum length for file names (0 or empty = unlimited)-->
+      <max_file_name_length>0</max_file_name_length>
+      <!--[file|container]-->
+      <playlist_style>file</playlist_style>
+      <show_childcount_in_title>false</show_childcount_in_title>
+      <enable_dlna>false</enable_dlna>
+      <transcoding_release_delay>4</transcoding_release_delay>
+      <file_settings>
+        <!--audio files-->
+        <file ext="mp3">
+          <type>AUDIO_ITEM</type>
+          <mime_type>audio/mpeg</mime_type>
+          <dlna>MP3</dlna>
+        </file>
+        <file ext="ogg">
+          <type>AUDIO_ITEM</type>
+          <mime_type>application/octet-stream</mime_type>
+          <transcode enabled="true">
+            <ext>mp3</ext>
+            <mime_type>audio/mpeg</mime_type>
+            <dlna>MP3</dlna>
+            <http_encoding>chunked</http_encoding>
+            <decoder>vorbis</decoder>
+            <encoder>lame</encoder>
+            <bitrate>192</bitrate>
+            <samplerate>44100</samplerate>
+          </transcode>
+        </file>
+        <file ext="mpc">
+          <type>AUDIO_ITEM</type>
+          <mime_type>application/octet-stream</mime_type>
+          <transcode enabled="true">
+            <ext>mp3</ext>
+            <mime_type>audio/mpeg</mime_type>
+            <dlna>MP3</dlna>
+            <http_encoding>chunked</http_encoding>
+            <decoder>musepack</decoder>
+            <encoder>lame</encoder>
+            <bitrate>192</bitrate>
+            <samplerate>44100</samplerate>
+          </transcode>
+        </file>
+        <file ext="wav">
+          <type>AUDIO_ITEM</type>
+          <mime_type>audio/x-wav</mime_type>
+        </file>
+        <file ext="flac">
+          <type>AUDIO_ITEM</type>
+          <mime_type>audio/x-flac</mime_type>
+          <transcode enabled="true">
+            <ext>mp3</ext>
+            <mime_type>audio/mpeg</mime_type>
+            <dlna>MP3</dlna>
+            <http_encoding>chunked</http_encoding>
+            <decoder>flac</decoder>
+            <encoder>lame</encoder>
+            <bitrate>192</bitrate>
+            <samplerate>44100</samplerate>
+          </transcode>
+        </file>
+        <file ext="wma">
+          <type>AUDIO_ITEM</type>
+          <mime_type>audio/x-ms-wma</mime_type>
+          <dlna>WMAFULL</dlna>
+        </file>
+        <!--image files-->
+        <file ext="jpg">
+          <ext>jpeg</ext>
+          <type>IMAGE_ITEM</type>
+          <mime_type>image/jpeg</mime_type>
+          <convert enabled="false">
+            <!--<dcraw enabled="true">-q 0</dcraw>-->
+            <ext>png</ext>
+            <mime_type>image/png</mime_type>
+            <height>0</height>
+            <width>0</width>
+            <!--set "greater" to "true" if you only want to resize images greater than "height" or "width"-->
+            <greater>false</greater>
+            <!--set "less" to "true" if you only want to resize images less than "height" or "width"-->
+            <less>false</less>
+            <!--set "less" and "greater" to "false" if you always want to resize-->
+          </convert>
+        </file>
+        <file ext="bmp">
+          <type>IMAGE_ITEM</type>
+          <mime_type>image/bmp</mime_type>
+        </file>
+        <file ext="png">
+          <type>IMAGE_ITEM</type>
+          <mime_type>image/png</mime_type>
+        </file>
+        <file ext="gif">
+          <type>IMAGE_ITEM</type>
+          <mime_type>image/gif</mime_type>
+        </file>
+        <!--video files-->
+        <file ext="mpg">
+          <ext>mpeg</ext>
+          <type>VIDEO_ITEM</type>
+          <mime_type>video/mpeg</mime_type>
+        </file>
+        <file ext="mp4">
+          <type>VIDEO_ITEM</type>
+          <mime_type>video/mp4</mime_type>
+        </file>
+        <file ext="avi">
+          <type>VIDEO_ITEM</type>
+          <mime_type>video/x-msvideo</mime_type>
+        </file>
+        <file ext="wmv">
+          <type>VIDEO_ITEM</type>
+          <mime_type>video/x-ms-wmv</mime_type>
+        </file>
+        <file ext="vob">
+          <type>VIDEO_ITEM</type>
+          <mime_type>video/x-ms-vob</mime_type>
+        </file>
+        <file ext="vdr">
+          <type>VIDEO_ITEM</type>
+          <mime_type>video/x-extension-vdr</mime_type>
+          <transcode enabled="true">
+            <ext>vob</ext>
+            <mime_type>video/x-ms-vob</mime_type>
+          </transcode>
+        </file>
+        <file ext="flv">
+          <type>VIDEO_ITEM</type>
+          <mime_type>application/x-flash-video</mime_type>
+        </file>
+        <file ext="asf">
+          <type>VIDEO_ITEM</type>
+          <mime_type>video/x-ms-asf</mime_type>
+        </file>
+        <!--playlists-->
+        <file ext="pls">
+          <type>PLAYLIST</type>
+          <mime_type>audio/x-scpls</mime_type>
+        </file>
+        <file ext="m3u">
+          <type>PLAYLIST</type>
+          <mime_type>audio/x-mpegurl</mime_type>
+        </file>
+      </file_settings>
+    </device>
+    <!--For other device settings take a look at http://fuppes.ulrich-voelkel.de/wiki/index.php/Category:Device-->
+    <!--If you have more than one device it is a good idea to set the ip address as some devices may have conflicting "user agents".-->
+    <!--It is safe to remove unneeded devices-->
+    <device name="PS3" enabled="false">
+      <user_agent>UPnP/1.0 DLNADOC/1.00</user_agent>
+      <user_agent>PLAYSTATION3</user_agent>
+      <!--<ip></ip>-->
+      <enable_dlna>true</enable_dlna>
+      <transcoding_release_delay>50</transcoding_release_delay>
+      <file_settings>
+        <file ext="ogg">
+          <type>AUDIO_ITEM_MUSIC_TRACK</type>
+          <transcode enabled="true">
+            <http_encoding>stream</http_encoding>
+          </transcode>
+        </file>
+      </file_settings>
+    </device>
+    <device name="Xbox 360" virtual="Xbox 360" enabled="false">
+      <user_agent>Xbox/2.0.\d+.\d+ UPnP/1.0 Xbox/2.0.\d+.\d+</user_agent>
+      <user_agent>Xenon</user_agent>
+      <xbox360>true</xbox360>
+      <show_empty_resolution>true</show_empty_resolution>
+      <description_values>
+        <friendly_name>%s %v : 1 : Windows Media Connect</friendly_name>
+        <model_name>Windows Media Connect compatible (%s)</model_name>
+        <model_number>2.0</model_number>
+      </description_values>
+    </device>
+  </device_settings>
+</fuppes_config>
-- 
cgit v0.12