From b83ca22d5c05065f7c9e69b93fddc64b46625691 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 29 Nov 2010 19:12:27 +0000
Subject: mythsmolt: updated for .24 myth and python2

---
 abs/core/mythsmolt/PKGBUILD            | 27 +++++++++++++++++++++++
 abs/core/mythsmolt/mythsmolt.patch     |  8 +++++++
 abs/core/mythsmolt/smolt_init_login.sh | 39 ++++++++++++++++++++++++++++++++++
 3 files changed, 74 insertions(+)
 create mode 100644 abs/core/mythsmolt/PKGBUILD
 create mode 100644 abs/core/mythsmolt/mythsmolt.patch
 create mode 100644 abs/core/mythsmolt/smolt_init_login.sh

diff --git a/abs/core/mythsmolt/PKGBUILD b/abs/core/mythsmolt/PKGBUILD
new file mode 100644
index 0000000..f7ba9f8
--- /dev/null
+++ b/abs/core/mythsmolt/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=mythsmolt
+pkgver=0.24
+pkgrel=3
+pkgdesc="mythsmolt, a hardware profileing tool"
+arch=('i686' 'x86_64')
+url="http://www.mythvantage.com"
+license=('GPL')
+depends=("mythtv>=${pkgver}" urlgrabber python-simplejson python-pycurl)
+#source=("http://jmeyer.us/download/mythsmolt.tar.gz" 'smolt_init_login.sh' 'mythsmolt.patch')
+source=("http://jmeyer.us/download/mythsmolt.tar.gz" 'smolt_init_login.sh' )
+
+groups=('mythtv-extras')
+
+build() {
+   cd $startdir/src/mythsmolt
+#   patch -p1 < ../mythsmolt.patch || return 1
+   ./configure.sh
+   make || return 1
+   make INSTALL_ROOT=$startdir/pkg install
+   install -D -m 755 $srcdir/smolt_init_login.sh $pkgdir/etc/profile.d/smolt_init_login.sh
+}
+md5sums=('ffe0728d314dc03550691e2fe1c153b9'
+         '57a3416d90e59abbd5062436583c17e1')
+md5sums=('ffe0728d314dc03550691e2fe1c153b9'
+         '57a3416d90e59abbd5062436583c17e1')
+md5sums=('17d740c348301ab47ac557ad7402115b'
+         '57a3416d90e59abbd5062436583c17e1')
diff --git a/abs/core/mythsmolt/mythsmolt.patch b/abs/core/mythsmolt/mythsmolt.patch
new file mode 100644
index 0000000..4767865
--- /dev/null
+++ b/abs/core/mythsmolt/mythsmolt.patch
@@ -0,0 +1,8 @@
+diff -ruaN mythsmolt.orig/settings.pro mythsmolt/settings.pro
+--- mythsmolt.orig/settings.pro	2010-01-06 15:49:59.000000000 +0000
++++ mythsmolt/settings.pro	2010-05-28 03:30:59.000000000 +0000
+@@ -1,3 +1,3 @@
+ 
+-LIBVERSION = 0.24
++LIBVERSION = 0.24
+ 
diff --git a/abs/core/mythsmolt/smolt_init_login.sh b/abs/core/mythsmolt/smolt_init_login.sh
new file mode 100644
index 0000000..0b76305
--- /dev/null
+++ b/abs/core/mythsmolt/smolt_init_login.sh
@@ -0,0 +1,39 @@
+if [ $UID = 0  -o  $UID = 1000 ]
+then
+    INIT=`ps -p 1 -o comm=`
+    if [ x$INIT = xrunit ]
+    then
+        if [[ -f /home/mythtv/.configure  &&  $- = *i* ]]
+        then
+            if  [ ! -z "$PS1" ]
+            then
+                if  [ $0 = "-bash" ]
+                then
+                    if [ ! -e /home/mythtv/.mythtv/MythSmolt/hw-uuid ]
+                    then
+                        echo ""
+                        echo "####################################################"
+                        echo "It appears you have not yet run smolt"
+                        echo "Please take the time to submit your hardware profile"
+                        echo ""
+                        echo "press any key to continue:"
+                        echo "####################################################"
+                        read a
+                        mkdir -p /home/mythtv/.mythtv/MythSmolt
+                        chown -R mythtv:users /home/mythtv/.mythtv/MythSmolt
+
+                        if [ $UID = 0 ]
+                        then
+                            su   mythtv -c "/usr/share/mythtv/mythsmolt/scripts/sendProfile.py" &&   su mythtv -c "touch  /home/mythtv/.mythtv/MythSmolt/hw-uuid"
+                        else
+                            /usr/share/mythtv/mythsmolt/scripts/sendProfile.py &&  touch  /home/mythtv/.mythtv/MythSmolt/hw-uuid
+                        fi
+                    fi
+                fi
+            fi
+        fi
+    fi
+fi
+
+
+
-- 
cgit v0.12