From a74c5d1b977315093275839e819308a40e69774b Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Wed, 10 Nov 2010 03:47:18 +0000
Subject: libbluray-git: initial include

---
 abs/extra/libbluray-git/PKGBUILD | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
 create mode 100644 abs/extra/libbluray-git/PKGBUILD

diff --git a/abs/extra/libbluray-git/PKGBUILD b/abs/extra/libbluray-git/PKGBUILD
new file mode 100644
index 0000000..c83dce3
--- /dev/null
+++ b/abs/extra/libbluray-git/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andrew Cook <ariscop@gmail.com>
+
+pkgname=libbluray-git
+pkgver=20101110
+pkgrel=1
+pkgdesc="Blu-Ray access library"
+arch=('i686' 'x86_64')
+depends=('doxygen')
+license=('LGPL')
+url="http://www.videolan.org/developers/libbluray.html"
+makedepends=('git')
+source=()
+md5sums=()
+provides=('libbluray')
+conflicts=('libbluray')
+
+_gitroot="git://git.videolan.org/libbluray.git"
+_gitname="libbluray"
+
+build() {
+    msg "Connecting to GIT server..."
+
+    if [ -d ${srcdir}/$_gitname ] ; then
+        cd $_gitname && git pull origin
+        msg "The local files are updated."
+    else
+        git clone $_gitroot
+    fi
+    
+    msg "GIT checkout done or server timeout"
+    msg "Starting make..."
+
+    cd ${srcdir}/libbluray
+    ./bootstrap
+    ./configure --prefix=/
+    make || return 1
+    make DESTDIR=${pkgdir}/usr install || return 1    
+}
-- 
cgit v0.12