From fba7ea15ad46f8655bf17ab4c1cc5a8228d39e1b Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Sat, 29 Nov 2008 20:10:25 -0800
Subject: Modified live-shutdown to preload commands so an eject will occur.

---
 abs/core-testing/linhes-live/PKGBUILD             |  2 +-
 abs/core-testing/linhes-live/etc/live-shutdown    | 18 ++++++++++++------
 abs/core-testing/linhes-live/etc/rc.shutdown-live |  3 ++-
 3 files changed, 15 insertions(+), 8 deletions(-)

diff --git a/abs/core-testing/linhes-live/PKGBUILD b/abs/core-testing/linhes-live/PKGBUILD
index 1c7fa71..2052781 100644
--- a/abs/core-testing/linhes-live/PKGBUILD
+++ b/abs/core-testing/linhes-live/PKGBUILD
@@ -2,7 +2,7 @@
 # 2008.09.25
 pkgname=linhes-live
 pkgver=5.3.3
-pkgrel=5
+pkgrel=6
 
 pkgdesc="LinHes compulsory components for the Live System."
 url="http://KnoppMyth.net"
diff --git a/abs/core-testing/linhes-live/etc/live-shutdown b/abs/core-testing/linhes-live/etc/live-shutdown
index 807ec47..459d4f2 100644
--- a/abs/core-testing/linhes-live/etc/live-shutdown
+++ b/abs/core-testing/linhes-live/etc/live-shutdown
@@ -9,12 +9,12 @@ f_saveclock ()
 f_swapoff ()
 {
     ############################# Include session saving functions
-    . /opt/linhes-live/session-save/shutdown2
-    if [ -f /tmp/checkse ]; then
-        . /tmp/checkse
-    else
-        checkse
-    fi
+#    . /opt/linhes-live/session-save/shutdown2
+#    if [ -f /tmp/checkse ]; then
+#        . /tmp/checkse
+#    else
+#        checkse
+#    fi
 
     if [ -n "${saving}" ] && ! session_save; then
         echo
@@ -46,5 +46,11 @@ f_remountro ()
         read junk
     fi
 }
+#Preloads these commands so we can eject the CD.
+#
+eject --help >/dev/null 2>&1
+halt --help >/dev/null 2>&1
+poweroff --help >/dev/null 2>&1
+reboot --help >/dev/null 2>&1
 
 # End
diff --git a/abs/core-testing/linhes-live/etc/rc.shutdown-live b/abs/core-testing/linhes-live/etc/rc.shutdown-live
index 7fa97e6..896bae2 100755
--- a/abs/core-testing/linhes-live/etc/rc.shutdown-live
+++ b/abs/core-testing/linhes-live/etc/rc.shutdown-live
@@ -149,7 +149,8 @@ fi
 
 #F Remount / ro
 f_remountro
-
+#Eject the CD
+eject
 # Power off or reboot
 if [ "$RUNLEVEL" = "0" ]; then
     printsep
-- 
cgit v0.12