From 3bf0a84f2d236f0d87f77823310c9df98d04d537 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 7 Aug 2012 11:07:58 -0500
Subject: libusb-compat 0.1.4

---
 abs/core/libusb-compat/PKGBUILD                 | 28 +++++++++++++++----------
 abs/core/libusb-compat/libusb-0.1-libusbx.patch | 17 +++++++++++++++
 2 files changed, 34 insertions(+), 11 deletions(-)
 create mode 100644 abs/core/libusb-compat/libusb-0.1-libusbx.patch

diff --git a/abs/core/libusb-compat/PKGBUILD b/abs/core/libusb-compat/PKGBUILD
index b2b16ce..76b8f05 100644
--- a/abs/core/libusb-compat/PKGBUILD
+++ b/abs/core/libusb-compat/PKGBUILD
@@ -1,26 +1,32 @@
-# $Id: PKGBUILD 101197 2010-11-28 15:10:38Z tpowa $
-# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
+# $Id: PKGBUILD 162998 2012-07-05 06:50:21Z tpowa $
+# Maintainer:
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
 # Contributor: arjan <arjan@archlinux.org>
 
 pkgname=libusb-compat
-pkgver=0.1.3
-pkgrel=1
+pkgver=0.1.4
+pkgrel=2
 pkgdesc="Library to enable user space application programs to communicate with USB devices"
 arch=('i686' 'x86_64')
-depends=('libusb' 'sh')
 url="http://libusb.sourceforge.net/"
 license=('LGPL')
-source=(http://downloads.sourceforge.net/libusb/libusb-compat-0.1/$pkgname-$pkgver/${pkgname}-${pkgver}.tar.bz2)
+depends=('libusb' 'sh')
 options=('!libtool')
-md5sums=('570ac2ea085b80d1f74ddc7c6a93c0eb')
+source=("http://downloads.sourceforge.net/${pkgname%-*}/${pkgname}-${pkgver%.*}/$pkgname-$pkgver/${pkgname}-${pkgver}.tar.bz2"
+        "libusb-0.1-libusbx.patch")   
+md5sums=('2ca521fffadd0c28fdf174e6ec73865b'
+         '1612c3982f307da1332d6db57b16742b')
 
 build() {
-  cd ${srcdir}/${pkgname}-${pkgver}
-  ./configure --prefix=/usr 
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  # http://libusb.org/ticket/138 can be removed with libusbx 1.0.13
+  patch -Np0 -i ../libusb-0.1-libusbx.patch
+  ./configure --prefix=/usr --disable-static
   make
 }
 
 package() {
-  cd ${srcdir}/${pkgname}-${pkgver}
-  make DESTDIR=${pkgdir} install
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make DESTDIR="${pkgdir}" install
 }
+
diff --git a/abs/core/libusb-compat/libusb-0.1-libusbx.patch b/abs/core/libusb-compat/libusb-0.1-libusbx.patch
new file mode 100644
index 0000000..6156365
--- /dev/null
+++ b/abs/core/libusb-compat/libusb-0.1-libusbx.patch
@@ -0,0 +1,17 @@
+http://bugs.gentoo.org/423135
+
+--- libusb/core.c
++++ libusb/core.c
+@@ -32,12 +32,6 @@
+ static libusb_context *ctx = NULL;
+ static int usb_debug = 0;
+ 
+-enum usbi_log_level {
+-	LOG_LEVEL_DEBUG,
+-	LOG_LEVEL_INFO,
+-	LOG_LEVEL_WARNING,
+-	LOG_LEVEL_ERROR,
+-};
+ 
+ #ifdef ENABLE_LOGGING
+ #define _usbi_log(level, fmt...) usbi_log(level, __FUNCTION__, fmt)
-- 
cgit v0.12