From d63f7845391e1c843f713b3fbdcaaf111cabeb50 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 31 May 2018 22:54:21 +0000
Subject: libproxy: update to 0.4.15

---
 abs/extra/libproxy/PKGBUILD    | 31 +++++++++++++++++++------------
 abs/extra/libproxy/__changelog |  1 +
 2 files changed, 20 insertions(+), 12 deletions(-)

diff --git a/abs/extra/libproxy/PKGBUILD b/abs/extra/libproxy/PKGBUILD
index 70a1362..6fc9798 100644
--- a/abs/extra/libproxy/PKGBUILD
+++ b/abs/extra/libproxy/PKGBUILD
@@ -2,22 +2,28 @@
 # Maintainer: Jan de Groot <jgc@archlinux.org>
 
 pkgname=libproxy
-pkgver=0.4.11
-pkgrel=4
+pkgver=0.4.15
+pkgrel=6
 pkgdesc="A library that provides automatic proxy configuration management"
-arch=(i686 x86_64)
+arch=(x86_64)
 license=('LGPL')
 depends=('gcc-libs')
 optdepends=('perl: Perl bindings'
-            'python2: Python bindings'
+            'python2: Python 2.x bindings'
+            'python: Python 3.x bindings'
             'glib2: gsettings configuration module')
-makedepends=('cmake' 'python2' 'perl')
-url="http://libproxy.googlecode.com"
-source=(http://libproxy.googlecode.com/files/${pkgname}-${pkgver}.tar.gz)
-md5sums=('3cd1ae2a4abecf44b3f24d6639d2cd84')
+makedepends=('cmake' 'python' 'python2' 'perl')
+url="http://libproxy.github.io/libproxy/"
+source=(https://github.com/libproxy/libproxy/archive/${pkgver}.tar.gz)
+sha256sums=('18f58b0a0043b6881774187427ead158d310127fc46a1c668ad6d207fb28b4e0')
+
+prepare() {
+  if [ ! -d build ]; then
+    mkdir build
+  fi
+}
 
 build() {
-  mkdir build
   cd build
   cmake ../${pkgname}-${pkgver} \
     -DCMAKE_INSTALL_PREFIX=/usr \
@@ -25,11 +31,12 @@ build() {
     -DCMAKE_SKIP_RPATH=ON \
     -DPERL_VENDORINSTALL=yes \
     -DCMAKE_BUILD_TYPE=Release \
-    -DWITH_WEBKIT=OFF \
+    -DWITH_WEBKIT3=OFF \
+    -DWITH_MOZJS=OFF \
     -DCMAKE_CXX_FLAGS="${CXXFLAGS}" \
     -DCMAKE_C_FLAGS="${CFLAGS}" \
-    -DWITH_KDE4=OFF \
-    -DPYTHON_EXECUTABLE:FILEPATH=/usr/bin/python2
+    -DPYTHON2_EXECUTABLE:FILEPATH=/usr/bin/python2 \
+    -DBIPR=0
   make
 }
 
diff --git a/abs/extra/libproxy/__changelog b/abs/extra/libproxy/__changelog
index 178dc00..5b9c04b 100644
--- a/abs/extra/libproxy/__changelog
+++ b/abs/extra/libproxy/__changelog
@@ -1 +1,2 @@
 PKGBUILD: remove networkmanager from makedepends and depends
+PKGBUILD: remove webkit2gtk and disable WEBKIT3
-- 
cgit v0.12