From e6e06e9055ca7dd75c2542678e5cdf0713dee03b Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 7 Aug 2012 10:03:09 -0500
Subject: libmpc: 0.9

---
 abs/core/libmpc/PKGBUILD                           | 29 ++++++----
 .../libmpc-0.9-configure_cflags_egrep_issue.patch  | 63 ++++++++++++++++++++++
 abs/core/libmpc/libmpc.install                     |  2 +-
 3 files changed, 84 insertions(+), 10 deletions(-)
 create mode 100644 abs/core/libmpc/libmpc-0.9-configure_cflags_egrep_issue.patch

diff --git a/abs/core/libmpc/PKGBUILD b/abs/core/libmpc/PKGBUILD
index 9aad761..f482d41 100644
--- a/abs/core/libmpc/PKGBUILD
+++ b/abs/core/libmpc/PKGBUILD
@@ -1,28 +1,39 @@
-# $Id: PKGBUILD 82441 2010-06-11 06:42:48Z allan $
+# $Id: PKGBUILD 135910 2011-08-20 07:14:03Z allan $
 # Maintainer: Allan McRae <allan@archlinux.org>
 
 pkgname=libmpc
-pkgver=0.8.2
+pkgver=0.9
 pkgrel=2
 pkgdesc="Library for the arithmetic of complex numbers with arbitrarily high precision"
 arch=('i686' 'x86_64')
-url="http://www.multiprecision.org"
+url="http://www.multiprecision.org/"
 license=('LGPL')
 depends=('mpfr>=3.0.0')
 options=('!libtool')
 install=libmpc.install
-source=(http://www.multiprecision.org/mpc/download/mpc-${pkgver/_/-}.tar.gz)
-md5sums=('e98267ebd5648a39f881d66797122fb6')
+source=(http://www.multiprecision.org/mpc/download/mpc-${pkgver/_/-}.tar.gz
+        libmpc-0.9-configure_cflags_egrep_issue.patch)
+md5sums=('0d6acab8d214bd7d1fbbc593e83dd00d'
+         '35d5bb02dc6c1153e581b7c34a738a08')
 
 build() {
-  cd $srcdir/mpc-$pkgver
+  cd "${srcdir}/mpc-${pkgver}"
+
+  # http://lists.gforge.inria.fr/pipermail/mpc-discuss/2011-February/000805.html
+  patch -Np1 -i $srcdir/libmpc-0.9-configure_cflags_egrep_issue.patch
+  autoreconf
+  
   ./configure --prefix=/usr
   make
+}
+
+check() {
+  cd "${srcdir}/mpc-${pkgver}"
   make check
 }
 
 package() {
-  cd $srcdir/mpc-$pkgver
-  make DESTDIR=$pkgdir/ install
-  mv -f $pkgdir/usr/share/info/{mpc,libmpc}.info
+  cd "${srcdir}/mpc-${pkgver}"
+  make DESTDIR="${pkgdir}" install
+  mv ${pkgdir}/usr/share/info/{mpc,libmpc}.info
 }
diff --git a/abs/core/libmpc/libmpc-0.9-configure_cflags_egrep_issue.patch b/abs/core/libmpc/libmpc-0.9-configure_cflags_egrep_issue.patch
new file mode 100644
index 0000000..3bf3247
--- /dev/null
+++ b/abs/core/libmpc/libmpc-0.9-configure_cflags_egrep_issue.patch
@@ -0,0 +1,63 @@
+--- trunk/configure.ac	2011/02/21 12:18:31	932
++++ trunk/configure.ac	2011/02/21 16:41:09	936
+@@ -33,7 +33,7 @@
+ AC_CANONICAL_HOST
+ AC_CONFIG_MACRO_DIR([m4])
+ 
+-dnl Extra arguments to configure
++# Extra arguments to configure
+ AC_ARG_WITH([mpfr_include],
+             [AC_HELP_STRING([--with-mpfr-include=DIR],
+                             [MPFR include directory])],
+@@ -85,18 +85,19 @@
+              )
+ 
+ 
+-dnl Setup CC and CFLAGS
++# Setup CC and CFLAGS
++AC_PROG_CC
++AC_LANG(C)
+ 
+-dnl Check for user specification of CC or CFLAGS
++# Set up LibTool
++AC_PROG_LIBTOOL
++
++# Check for user specification of CC or CFLAGS
+ if test -n "$CFLAGS" || test -n "$CC" ; then
+    user_redefine_cc=yes
+ fi
+ 
+-# Check for programs
+-AC_PROG_CC
+-AC_LANG(C)
+-
+-dnl Check GMP Header
++# Check GMP Header
+ AC_MSG_CHECKING(for gmp.h)
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
+ #include "gmp.h"
+@@ -105,22 +106,19 @@
+  AC_MSG_ERROR([gmp.h can't be found, or is unusable.])
+ ])
+ 
+-dnl Check for GMP CFLAGS in gmp.h
++# Check for GMP CFLAGS in gmp.h
+ if test -z "$user_redefine_cc" ; then
+    MPC_GMP_CC_CFLAGS
+ fi
+ 
+ 
+-dnl Configs for Windows DLLs
++# Configs for Windows DLLs
+ case $host in
+   *-*-cygwin* | *-*-mingw* | *-*-pw32* | *-*-os2*)
+      MPC_WINDOWS
+ esac
+ 
+ 
+-dnl Finally set up LibTool
+-AC_PROG_LIBTOOL
+-
+ # Checks for header files.
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS([complex.h locale.h inttypes.h stdint.h limits.h unistd.h sys/time.h])
diff --git a/abs/core/libmpc/libmpc.install b/abs/core/libmpc/libmpc.install
index bb20831..b0718c7 100644
--- a/abs/core/libmpc/libmpc.install
+++ b/abs/core/libmpc/libmpc.install
@@ -1,4 +1,4 @@
-infodir=/usr/share/info
+infodir=usr/share/info
 filelist=(libmpc.info)
 
 post_install() {
-- 
cgit v0.12