From 18268716a294e50b1bd58485b0787b6e9a078c84 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 3 Feb 2015 21:34:26 +0000
Subject: python-pybluez: update to 0.20

---
 abs/core/python_modules/python-pybluez/PKGBUILD    | 33 +++++++++++++---------
 abs/core/python_modules/python-pybluez/__changelog |  1 +
 2 files changed, 21 insertions(+), 13 deletions(-)
 create mode 100644 abs/core/python_modules/python-pybluez/__changelog

diff --git a/abs/core/python_modules/python-pybluez/PKGBUILD b/abs/core/python_modules/python-pybluez/PKGBUILD
index f667d66..e48f941 100644
--- a/abs/core/python_modules/python-pybluez/PKGBUILD
+++ b/abs/core/python_modules/python-pybluez/PKGBUILD
@@ -1,24 +1,31 @@
-# $Id: PKGBUILD 26298 2010-09-14 17:18:19Z schuay $
+# $Id: PKGBUILD 66132 2012-02-23 01:40:38Z spupykin $
 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
 # Contributor: cs-cam - me.at.camdaniel.com
 
-pkgname=python-pybluez
-pkgver=0.18
-pkgrel=3
+pkgbase=python-pybluez
+pkgname=(python2-pybluez)
+pkgver=0.20
+pkgrel=2
 pkgdesc="Python wrapper for the BlueZ Bluetooth stack"
 arch=('i686' 'x86_64')
 url="http://code.google.com/p/pybluez/"
 license=('GPL')
-provides=('pybluez')
-conflicts=('pybluez')
-replaces=('pybluez')
-depends=('python2' 'bluez')
-source=(http://pybluez.googlecode.com/files/PyBluez-$pkgver.tar.gz)
-md5sums=('be8c8ce615c3189fda1aaf3d568314b2')
+makedepends=('python2' 'bluez-libs')
+source=(http://pybluez.googlecode.com/files/PyBluez-$pkgver.zip)
+md5sums=('1e7fad332d50f089bbce69070c877ef6')
+
+#package_python-pybluez() {
+#  depends=('python' 'bluez-libs')
+
+#  cd $srcdir/PyBluez-$pkgver
+#  python setup.py install --root=$pkgdir
+#  ln -s bluetooth/_bluetooth.so $pkgdir/usr/lib/python3.3/site-packages/_bluetooth.so
+#}
+
+package_python2-pybluez() {
+  depends=('python2' 'bluez-libs')
 
-build() {
   cd $srcdir/PyBluez-$pkgver
   python2 setup.py install --root=$pkgdir
-  ln -s bluetooth/_bluetooth.so $pkgdir/usr/lib/python2.6/site-packages/_bluetooth.so
+#  ln -s bluetooth/_bluetooth.so $pkgdir/usr/lib/python2.7/site-packages/_bluetooth.so
 }
-
diff --git a/abs/core/python_modules/python-pybluez/__changelog b/abs/core/python_modules/python-pybluez/__changelog
new file mode 100644
index 0000000..488d3cf
--- /dev/null
+++ b/abs/core/python_modules/python-pybluez/__changelog
@@ -0,0 +1 @@
+PKGBUILD: rm py 3 stuff
-- 
cgit v0.12