From 9baa95eca8bfcd11346b03b9eaa1ddf25b42493b Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 4 Oct 2020 14:02:07 +0000
Subject: python-six: update to 1.15.0

---
 abs/core/python_modules/python-six/PKGBUILD | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

diff --git a/abs/core/python_modules/python-six/PKGBUILD b/abs/core/python_modules/python-six/PKGBUILD
index 56ca2de..185fc39 100644
--- a/abs/core/python_modules/python-six/PKGBUILD
+++ b/abs/core/python_modules/python-six/PKGBUILD
@@ -1,20 +1,19 @@
-# $Id$
 # Maintainer: Felix Yan <felixonmars@archlinux.org>
 # Contributor: Jelle van der Waa <jelle@vdwaa.nl>
 # Contributer: Allan McRae <allan@archlinux.org>
 
 pkgbase=python-six
 pkgname=('python2-six' 'python-six')
-pkgver=1.11.0
+pkgver=1.15.0
 pkgrel=1
 pkgdesc="Python 2 and 3 compatibility utilities"
 arch=('any')
-url="http://pypi.python.org/pypi/six/"
+url="https://pypi.python.org/pypi/six/"
 license=('MIT')
 makedepends=('python-setuptools' 'python2-setuptools')
-checkdepends=('python-pytest-runner' 'python2-pytest-runner' 'tk')
+checkdepends=('python-pytest' 'python2-pytest' 'tk')
 source=("https://pypi.io/packages/source/s/six/six-$pkgver.tar.gz")
-sha512sums=('33f246a2e987141e17e5edad9d3537cf3aba0cbdd0bc2a907ea52ce0d674b1474f29c3dd5cc26605fd960396054b189ca5f501708333cad234c223131483fe24')
+sha512sums=('eb840ac17f433f1fc4af56de75cfbfe0b54e6a737bb23c453bf09a4a13d768d153e46064880dc763f4c5cc2785b78ea6d3d3b4a41fed181cb9064837e3f699a9')
 
 build() {
   cp -a six-$pkgver{,-py2}
@@ -22,10 +21,10 @@ build() {
 
 check() {
   cd "$srcdir"/six-$pkgver
-  python setup.py pytest
+  python -m pytest
 
   cd "$srcdir"/six-$pkgver-py2
-  python2 setup.py pytest
+  python2 -m pytest
 }
 
 package_python-six() {
-- 
cgit v0.12