From 0dece954c5408214dcfb22934c84eb6d14360a77 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 8 Aug 2013 16:07:28 -0500
Subject: supplemental-web: Move menu frame to be on the side.

Many other changes to make appearance more consistant. closes #904
---
 abs/core/supplemental-web/PKGBUILD                |  2 +-
 abs/core/supplemental-web/contents/alt_index.html |  2 +-
 abs/core/supplemental-web/contents/calllog.shtml  | 11 ++----
 abs/core/supplemental-web/contents/cardmap.shtml  |  9 +++--
 abs/core/supplemental-web/contents/count.py       | 16 ++++++--
 abs/core/supplemental-web/contents/docs.html      | 45 +++++++++++-----------
 abs/core/supplemental-web/contents/exports.shtml  | 18 ++++-----
 abs/core/supplemental-web/contents/frame.css      | 10 +++--
 abs/core/supplemental-web/contents/header.html    | 46 ++++++++++++++---------
 abs/core/supplemental-web/contents/links.html     | 16 ++++----
 abs/core/supplemental-web/contents/skeleton.css   | 14 ++++---
 11 files changed, 105 insertions(+), 84 deletions(-)

diff --git a/abs/core/supplemental-web/PKGBUILD b/abs/core/supplemental-web/PKGBUILD
index 2a4a3df..d259255 100644
--- a/abs/core/supplemental-web/PKGBUILD
+++ b/abs/core/supplemental-web/PKGBUILD
@@ -1,7 +1,7 @@
 pkgbase=supplemental-web
 pkgname=('supplemental-web' 'supplemental-web-slave')
 pkgver=8.0
-pkgrel=2
+pkgrel=3
 arch=('i686' 'x86_64')
 
 backup=('extra.cfg.txt')
diff --git a/abs/core/supplemental-web/contents/alt_index.html b/abs/core/supplemental-web/contents/alt_index.html
index e6a89b4..93ab1a0 100644
--- a/abs/core/supplemental-web/contents/alt_index.html
+++ b/abs/core/supplemental-web/contents/alt_index.html
@@ -2,7 +2,7 @@
 <html>
 	<head><title>LinHES: The Linux Home Entertainment System</title>
 	</head>
-	<frameset rows="230, 80%" frameborder="no" border="3" bordercolor="#000000">
+	<frameset cols="230, 100%" frameborder="no" border="0" bordercolor="#000000">
 	<frame src="header.html" scrolling=no  name="menuframe" />
 		      <frame src="home.shtml" name="content" />
 		      <noframes>
diff --git a/abs/core/supplemental-web/contents/calllog.shtml b/abs/core/supplemental-web/contents/calllog.shtml
index 5eb5783..5b64dc3 100644
--- a/abs/core/supplemental-web/contents/calllog.shtml
+++ b/abs/core/supplemental-web/contents/calllog.shtml
@@ -4,16 +4,13 @@
 </head>
 
 <body>
-<p> Phone Call Log </p>
-
-<!--<div id="mainContainer">
-		<div id="header"><p></p></div>
-		<div id="content">
-		<p>Phone Call Log</p>-->
+        <div id="header">
+                <h1>Phone Call Log</h1>
+                <br>
+        </div>
 
 	<!--#exec cmd="/data/srv/httpd/htdocs/calllog.py" -->
 
-
 </br>
 </br>
 
diff --git a/abs/core/supplemental-web/contents/cardmap.shtml b/abs/core/supplemental-web/contents/cardmap.shtml
index 89013c0..a5688dd 100755
--- a/abs/core/supplemental-web/contents/cardmap.shtml
+++ b/abs/core/supplemental-web/contents/cardmap.shtml
@@ -3,9 +3,12 @@
         <style type="text/css">@import "/frame.css";</style>
     </head>
     <body>
-        <h1> List of detected cards and static device path. </h1>
-        <br>
-        <!--#exec cmd=" MYTHCONFDIR=/usr/share/mythtv /data/srv/httpd/htdocs/list_cardmap.py" -->
+	<div id="header">
+		<h1>Tuners</h1>
+		<h2>Detected Cards and Static Device Paths</h2>
+		<br>
+	</div>
+        	<!--#exec cmd=" MYTHCONFDIR=/usr/share/mythtv /data/srv/httpd/htdocs/list_cardmap.py" -->
     </body>
 </html>
 
diff --git a/abs/core/supplemental-web/contents/count.py b/abs/core/supplemental-web/contents/count.py
index 2889af1..9f3530f 100644
--- a/abs/core/supplemental-web/contents/count.py
+++ b/abs/core/supplemental-web/contents/count.py
@@ -8,6 +8,11 @@ import socket
 
 
 def main(argv):
+    #get LinHES version
+    verfile = open('/etc/LinHES-release', 'r')
+    verLH = verfile.read()
+    verfile.close()
+
     grandtotal=0
     grandtotal_current=0
     db = MySQLdb.connect(host="localhost", user="mythtv", passwd="mythtv", db="mythconverg")
@@ -39,17 +44,20 @@ def main(argv):
     days_current = hours_current / 24.0
 
     print '<div id="header">'
-
+    print "<h3>Welcome to</h3>"
+    print "<h1>" , verLH , "</h1>"
+    print "<h3>on " , socket.gethostname() , "</h3>"
+    print "</br>"
     print "<table>"
     print "    <tr>"
-    print "	  <td> Currently there are " ,  len(result_current) , " recorded programs.  With a viewing time of  %.2f days or  %.2f  hours. </td>" %(days_current,hours_current)
+    print "	  <td>Currently there are " , len(result_current) , " recorded programs, with a viewing time of %.2f days or %.2f hours.</td>" %(days_current,hours_current)
     print "    </tr>"
     print "</table>"
     print "</br> "
 
     print "<table>"
     print "	<tr>"
-    print "  		<td> Overall there have been " ,  len(result) , "shows recorded. With viewing time of %.2f days or %.2f hours </td>"%(days,hours)
+    print "  		<td>Overall there have been " , len(result) , "shows recorded, with a viewing time of %.2f days or %.2f hours.</td>"%(days,hours)
     print "	</tr>"
     print "</table>"
     print '</div>'
@@ -69,7 +77,7 @@ def main(argv):
        # print "%40s %26s %10s" %(row[0],row[2],row[1])
     print "</table>"
     print "</div>"
-#Top categorys
+#Top categories
 
     print '<div id="column"></div>'
     print '<table class="sample">'
diff --git a/abs/core/supplemental-web/contents/docs.html b/abs/core/supplemental-web/contents/docs.html
index 9afebb8..dc3a936 100644
--- a/abs/core/supplemental-web/contents/docs.html
+++ b/abs/core/supplemental-web/contents/docs.html
@@ -4,53 +4,54 @@
 </head>
 
 <body>
-Package Management
-</br>
+<div id="header">
+<h1>Documentation</h1>
+<br>
+</div>
 
+<h3>Package Management</h3>
 <div id="navcontainer">
 <ul id="navlist">
-        <li>pacman -Sy  to refresh  pkg database</li>
-        <li>pacman -Ss  $keyword   to search pkg database</li>
-        <li>pacman -Su  to update all install packages</li>
-        <li>pacman -S   $pkg   to update one pkg</li>
-        <li>pacman -h   for a list of pacman operations .</li>
-        <li>pacman -S --help   for a full list of options associated with the -S command.</li>
+        <li>pacman -Sy = to refresh pkg database</li>
+        <li>pacman -Ss $keyword = to search pkg database</li>
+        <li>pacman -Su = to update all install packages</li>
+        <li>pacman -S $pkg = to update one pkg</li>
+        <li>pacman -h = for a list of pacman operations</li>
+        <li>pacman -S --help = for a full list of options associated with the -S command</li>
 </ul>
 </div>
 <br>
-Starting and stopping services.
-<br>
 
+<h3>Starting and Stopping Services</h3>
 <div id="navcontainer">
 <ul id="navlist">
-    <li>sv {stop,start,restart} frontend. This will start/stop the entire X proccess that runs mythfrontend</li>
+    <li>sv {stop,start,restart} frontend = This will start/stop the entire X proccess that runs mythfrontend</li>
     <li>sv {stop,start,restart} mysql</li>
     <li>sv {stop,start,restart} mythbackend</li>
     <li>sv {stop,start,restart} remotes</li>
 </ul>
 <br>
 </div>
+
+<h3>Other Notes</h3>
 <div id="navcontainer">
-    Other Random notes
-<br>
 <ul id="navlist">
     <li>To keep a host from showing up in the network map, add it to:
         /home/xymon/server/ext/ignoreclient.py
     </li>
+    <li>To stop xymon from running a check on a function remove "func" from bb-hosts</li>
     <li>remove  "func" from bb-hosts to stop hobbit from running a func check on it </li>
-    <li>if /tmp/nomfe is present then mythfrontend will not restart </li>
-
-    <li>adding pkg names to /etc/pkgname.blacklist will stop MythVantage from autoinstalling a package.</li>
+    <li>If /tmp/nomfe is present then mythfrontend will not restart</li>
+    <li>Adding pkg names to /etc/pkgname.blacklist will stop MythVantage from auto installing a package</li>
 </div>
 <br>
-<div id="navcontainer">
-    Menu Navigation
-<br>
 
+<h3>MythFrontend Menu Navigation</h3>
+<div id="navcontainer">
 <ul id="navlist">
-    <li> <A HREF="images/classic-menugraph.png">Classic menu</A> </li>
-    <li> <A HREF="images/menu_diagram_color.png">Standard menu</A> </li>
-    <li> <A HREF="images/dvr_menugraph.png">DVR menu</A> </li>
+    <li> <A HREF="images/classic-menugraph.png">Classic Menu</A> </li>
+    <li> <A HREF="images/menu_diagram_color.png">Standard Menu</A> </li>
+    <li> <A HREF="images/dvr_menugraph.png">DVR Menu</A> </li>
 
 </body>
 </html>
diff --git a/abs/core/supplemental-web/contents/exports.shtml b/abs/core/supplemental-web/contents/exports.shtml
index 9a26dc9..7aaba33 100755
--- a/abs/core/supplemental-web/contents/exports.shtml
+++ b/abs/core/supplemental-web/contents/exports.shtml
@@ -5,16 +5,14 @@
 
 <body>
 <div id="mainContainer">
-<!--		<div id="header"><p></p></div>
-		<div id="content">
-		<p></p>-->
-
-	<!--#exec cmd="/data/srv/httpd/htdocs/list_exports.py" -->
-
-
-</br>
-</br>
-
+	<div id="header">
+		<h1>File Shares</h1>
+		<br>
+	</div>
+	<div id="content">
+		<!--#exec cmd="/data/srv/httpd/htdocs/list_exports.py" -->
+	</div>
+</div>
 </body>
 </html>
 
diff --git a/abs/core/supplemental-web/contents/frame.css b/abs/core/supplemental-web/contents/frame.css
index 42877dd..94e1747 100644
--- a/abs/core/supplemental-web/contents/frame.css
+++ b/abs/core/supplemental-web/contents/frame.css
@@ -5,7 +5,8 @@
 	border: 0;
 }
 body {
-    background: url("page_background.jpg") repeat-y #9FA9B3;
+/*    background: url("page_background.jpg") repeat-y #9FA9B3; */
+     background-color: #191c26;
 
 //background-color: #ebb81c;
 //background-image: -webkit-gradient(linear, left top, left bottom, from(#ebb81c), to(#0072bc)); /* Saf4+, Chrome */
@@ -44,10 +45,11 @@ body {
 	width: 770px;
 	margin: 0 auto; /* We are going to center this design */
 	text-align: left; /* Since we used text-align: center in the body to be sure some older IE versions are going to center our design, we now align the text left */
+	display: inline-block;
 }
 #header {
-	background: #000;
 	color: #fff;
+	text-align: center;	
 }
 #content {
 	float: left; /* Our content is going to be left aligned */
@@ -82,7 +84,7 @@ body {
 	clear: both; /* We have to clear our floats */
 	width: 760px; /* We need to set the width on the footer since it's outside the mainContainer, and therefor isn't controlled by it */
 	margin: 0 auto; /* We need to center the footer also */
-	background: black;
+/*	background: black; */
 	color: gold;
     	text-align: center;
     	font-size: 10px;
@@ -191,7 +193,7 @@ a:link
 #	background-color: #FDB14F;
 	text-decoration: underline ;
 
-    	 margin-left:10px;
+#    	 margin-left:10px;
 
 }
 
diff --git a/abs/core/supplemental-web/contents/header.html b/abs/core/supplemental-web/contents/header.html
index f84b4c8..608059c 100644
--- a/abs/core/supplemental-web/contents/header.html
+++ b/abs/core/supplemental-web/contents/header.html
@@ -6,25 +6,26 @@
 <script type="text/javascript">
 function r()
 {
-	current_hostname=parent.location.hostname
-	top.frames["content"].location.href = ( "http://" + current_hostname + ":6544" ) ;
-
+    current_hostname=parent.location.hostname
+    top.frames["content"].location.href = ( "http://" + current_hostname + ":6544" ) ;
 }
 
 function express()
 {
     current_hostname=parent.location.hostname
     top.frames["content"].location.href = ( "http://" + current_hostname + ":6565" ) ;
-
-    }
+}
 
 function remyth()
 {
     current_hostname=parent.location.hostname
     top.frames["content"].location.href = ( "http://" + current_hostname + ":8088" ) ;
+}
 
-    }
-
+function beStatus()
+{
+    document.getElementById('modify-me').href = "http://" + window.location.hostname + ":6544";
+}
 
 </script>
 </head>
@@ -32,7 +33,7 @@ function remyth()
 <BODY BGCOLOR=#ebb81c>
 
 <div id='header'></div>
-<img id='header_img' src="linhes_header.png" alt="Alt Text" title="Image Title"/>
+<img id='header_img' src="linhes_header.png" alt="LinHES" title="LinHES"/>
 
 <base target="content" />
 <ul id="nav">
@@ -40,16 +41,18 @@ function remyth()
 
 <li><a href="xymon" >System &#187;</a>
     <ul>
-        <li><a href="/cardmap.shtml"  >List static dev nodes for tuners </a></li>
-        <li><a href="/exports.shtml"  >List file shares </a></li>
-        <li><a href="/xymon"  >System Health</a></li>
-        <li><a href="/logs/">System Logs</a></li>
+        <li><a href="/xymon"  >Health</a></li>
+        <li><a href="/logs/"  >Logs</a></li>
+        <li><a href="/exports.shtml"  >File Shares</a></li>
+        <li><a href="/cardmap.shtml"  >Tuners</a></li>
     </ul>
 </li>
 
-<li><a href="mythweb/">Utilities &#187;</a>
+<li><a href="mythweb/">MythTV &#187;</a>
     <ul>
         <li><a href="mythweb/">MythWeb</a></li>
+<!--        <li><a onClick=r() >MythBackend Status</a></li> -->
+        <li><body onload="beStatus()"><a id="modify-me">MythBackend Status</a></body></li>
         <li><a href="mythexport/setup.cgi">MythExport</a></li>
         <li><a href="mythexpress.html">MythExpress</a></li>
         <li><a href="remyth.html" >ReMyth</a></li>
@@ -58,17 +61,24 @@ function remyth()
 
 <li><a href="/calllog.shtml">Surveillance &#187;</a>
     <ul>
-        <li><a href="/calllog.shtml">Phone Call Log</a></li>
+        <li><a href="/calllog.shtml">Call Log</a></li>
         <li><a href="/zm">ZoneMinder</a></li>
     </ul>
 </li>
 
-
 <li><a href="docs.html"  >Documentation</a></li>
-<li><a   onClick=r() >Myth Backend Status</a></li>
-
-<li><a href="links.html"  >Links</a></li>
 
+<li><a href="links.html"  >Links &#187;</a>
+    <ul>
+        <li><a href="http://linhes.org/wiki"  >LinHES Wiki</a></li>
+        <li><a href="http://forums.linhes.org"  >LinHES Forums</a></li>
+        <li><a href="http://linhes.org/projects/linhes/issues"  >LinHES Bug Tracker </a></li>
+        <li><a href="http://linhes.org/projects/linhes/wiki/Official_and_3rd_party_add-ons" >LinHES Add-Ons</a></li>
+        <li><a href="http://www.mythtv.org"  >MythTV</a></li>
+        <li><a href="http://smolt.mythtv.org"  >MythTV Smolt Server</a></li>
+        <li><a href="http://www.schedulesdirect.org"  >Schedules Direct</a></li>
+    </ul>
+</li>
 
 </body>
 </html>
diff --git a/abs/core/supplemental-web/contents/links.html b/abs/core/supplemental-web/contents/links.html
index e14141a..65b5231 100644
--- a/abs/core/supplemental-web/contents/links.html
+++ b/abs/core/supplemental-web/contents/links.html
@@ -4,19 +4,19 @@
 </head>
 
 <body>
-Other Links
+<h1>Links</h1>
 </br>
 
 <div id="navcontainer">
 <ul id="navlist">
 	<!--        <li><a href="/mvpmc.shtml"  >Media MVP setup</a> (dhcp server must be enabled) </li> -->
-        <li><a href="http://www.linhes.org"  >linhes.org </a>Bugtracker</li>
-        <li><a href="http://linhes.org/wiki"  >Wiki </a></li>
-        <li><a href="http://forums.linhes.org"  >Online User Forums</a></li>
-        <li><a href="http://linhes.org/projects/linhes/wiki/Official_and_3rd_party_add-ons" > Official & 3rd party addons</a></li>
-        <li><a href="http://www.mythtv.org"  >mythtv.org</a></li>
-        <li><a href="http://smolt.mythtv.org"  >mythtv smolt server</a></li>
-        <li><a href="http://www.schedulesdirect.org"  >Schedules Direct guide data for North America</a></li>
+        <li><a href="http://linhes.org/wiki"  >LinHES Wiki</a></li>
+        <li><a href="http://forums.linhes.org"  >LinHES Forums</a></li>
+        <li><a href="http://linhes.org/projects/linhes/issues"  >LinHES Bug Tracker </a></li>
+        <li><a href="http://linhes.org/projects/linhes/wiki/Official_and_3rd_party_add-ons" >LinHES Add-Ons</a></li>
+        <li><a href="http://www.mythtv.org"  >MythTV</a></li>
+        <li><a href="http://smolt.mythtv.org"  >MythTV Smolt Server</a></li>
+        <li><a href="http://www.schedulesdirect.org"  >Schedules Direct</a></li>
 
 
 
diff --git a/abs/core/supplemental-web/contents/skeleton.css b/abs/core/supplemental-web/contents/skeleton.css
index b13aa20..1f84e7e 100644
--- a/abs/core/supplemental-web/contents/skeleton.css
+++ b/abs/core/supplemental-web/contents/skeleton.css
@@ -7,7 +7,7 @@ Copyright (c) 2005-2007 Stu Nicholls. All rights reserved.
 This stylesheet and the associated (x)html may be modified in any
 way to fit your requirements.
 =================================================================== */
-#header_img {margin:5px auto;display:block;}
+#header_img {margin:5px auto;display:block;width:100%}
 
 #nav,
 #nav ul {padding:0 0 5px 0; margin:0; list-style:none;
@@ -18,9 +18,11 @@ way to fit your requirements.
          border-width:1px 2px 2px 1px; background:#fff;
          position:relative; z-index:200;}
 
-#nav {height:30px; padding:0;background-color:#0072bc;}
+#nav {height:auto; width:calc(100% - 2px);
+      padding:0; background-color:#0072bc;
+      display: inline-block;}
 
-#nav li {float:left;}
+#nav li {float:left; width:100%;}
 #nav li li {float:none; background:#fff;}
 /* a hack for IE5.x and IE6 */
 * html #nav li li {float:left;}
@@ -31,11 +33,11 @@ way to fit your requirements.
 #nav li a {display:block; float:left;
            color:#FFFFFF; margin:0 25px 0 10px;
            height:25px; line-height:25px;
-           text-decoration:none; white-space:nowrap;
+           text-decoration:none; white-space:normal;
 }
 
 /*item in white box*/
-#nav li li a {height:20px; line-height:20px; float:none;
+#nav li li a {height:auto; line-height:20px; float:none;
               background-color:#0072bc;
               margin:0 0 0 0;
               border:1px solid #000;
@@ -47,7 +49,7 @@ way to fit your requirements.
 #nav li:hover {position:relative; z-index:300; }
 
 /*white box*/
-#nav li:hover ul {left:0; bottom:21px; top:auto; background-color:#0072bc; color:}
+#nav li:hover ul {left:4em; top:0px; right:-10px; background-color:#0072bc;}
 
 /* another hack for IE5.5 and IE6 */
 * html #nav li:hover ul {left:10px;}
-- 
cgit v0.12