From 73e217800ce2ebd6e64ae54db7f54c386f047cff Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 5 Feb 2014 22:08:53 +0000
Subject: poweroff-scripts: shutdown.script: fix wall syntax to use stdin.

---
 abs/core/poweroff-scripts/PKGBUILD        | 6 +++---
 abs/core/poweroff-scripts/shutdown.script | 4 ++--
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/abs/core/poweroff-scripts/PKGBUILD b/abs/core/poweroff-scripts/PKGBUILD
index 9bcfee1..ff32494 100644
--- a/abs/core/poweroff-scripts/PKGBUILD
+++ b/abs/core/poweroff-scripts/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=poweroff-scripts
 pkgver=1.1
-pkgrel=3
+pkgrel=4
 pkgdesc="replacement scripts to work with sysvinit and runit"
 license=('GPL')
 depends=('sysvinit>=2.88' 'runit>=2.1.1-6')
@@ -12,7 +12,7 @@ install=poweroff-scripts.install
 source=(halt.script reboot.script poweroff.script shutdown.script)
 arch=('i686' 'x86_64')
 
-build() {
+package() {
   install -d $pkgdir/sbin/
   install -m0755 $srcdir/reboot.script $pkgdir/sbin/reboot
   install -m0755 $srcdir/halt.script  $pkgdir/sbin/halt
@@ -24,4 +24,4 @@ build() {
 md5sums=('68ac5d7d5784e9559c9752d94a4943d5'
          '3e042113f8715bc5bfd365d2486d0108'
          '3ec5f3013dcbd60b6b957d17ba220585'
-         '16bb393e9ae7b5fa744ca91970f350cc')
+         '1dccfcd2283d4ed193511535b0b220fc')
diff --git a/abs/core/poweroff-scripts/shutdown.script b/abs/core/poweroff-scripts/shutdown.script
index 31881e8..978f7a2 100644
--- a/abs/core/poweroff-scripts/shutdown.script
+++ b/abs/core/poweroff-scripts/shutdown.script
@@ -29,14 +29,14 @@ then
 
 	if [ x$reboot = x1 ]
 	then
-         wall "System will reboot in $delay seconds"
+         echo "System will reboot in $delay seconds" | wall
                 sleep $delay
                /sbin/runit-init 6
 	fi
 
 	if [ x$halt = x1 ]
 	then
-                wall "System will poweroff  in $delay seconds"
+                echo "System will poweroff  in $delay seconds" | wall
                 sleep $delay
                /sbin/runit-init 0
 	fi
-- 
cgit v0.12