From 69dc5c6d3d597a39c359220d00192b5166e6ed63 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 31 Jan 2019 21:04:32 +0000
Subject: source-highlight: rebuild

---
 abs/extra/source-highlight/PKGBUILD                        | 14 ++++++++++----
 .../source-highlight/fix-zsh-highlighting-hangups.patch    | 13 +++++++++++++
 2 files changed, 23 insertions(+), 4 deletions(-)
 create mode 100644 abs/extra/source-highlight/fix-zsh-highlighting-hangups.patch

diff --git a/abs/extra/source-highlight/PKGBUILD b/abs/extra/source-highlight/PKGBUILD
index 6c1ae0c..250ab53 100644
--- a/abs/extra/source-highlight/PKGBUILD
+++ b/abs/extra/source-highlight/PKGBUILD
@@ -1,18 +1,24 @@
-# $Id$
 # Maintainer: Giovanni Scafora <giovanni@archlinux.org>
 # Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
 
 pkgname=source-highlight
 pkgver=3.1.8
-pkgrel=14
+pkgrel=18
 pkgdesc="Convert source code to syntax highlighted document"
 arch=('x86_64')
 url="http://www.gnu.org/software/src-highlite/"
 license=('GPL')
 depends=('bash' 'boost-libs')
 makedepends=('ctags' 'boost')
-source=("ftp://ftp.gnu.org/gnu/src-highlite/${pkgname}-${pkgver}.tar.gz")
-md5sums=('3243470706ef5fefdc3e43b5306a4e41')
+source=("ftp://ftp.gnu.org/gnu/src-highlite/${pkgname}-${pkgver}.tar.gz"
+        "fix-zsh-highlighting-hangups.patch")
+md5sums=('3243470706ef5fefdc3e43b5306a4e41'
+         '5b6129bca6fcd0ea252fa31bf7a988fa')
+
+prepare() {
+  cd ${pkgname}-${pkgver}
+  patch -Np1 -i "${srcdir}/fix-zsh-highlighting-hangups.patch"
+}
 
 build() {
   cd ${pkgname}-${pkgver}
diff --git a/abs/extra/source-highlight/fix-zsh-highlighting-hangups.patch b/abs/extra/source-highlight/fix-zsh-highlighting-hangups.patch
new file mode 100644
index 0000000..200c9f8
--- /dev/null
+++ b/abs/extra/source-highlight/fix-zsh-highlighting-hangups.patch
@@ -0,0 +1,13 @@
+diff --git a/src/zsh.lang b/src/zsh.lang
+index 69542a7..a0bac36 100644
+--- a/src/zsh.lang
++++ b/src/zsh.lang
+@@ -35,7 +35,7 @@ keyword = "alias|always|autoload|bg|bindkey|break|builtin",
+           "unlimit|unset|unsetopt|until|vared|wait|whence",
+           "where|which|while|zcompile|zformat|zftp|zle",
+           "zmodload|zparseopts|zprof|zpty|zregexparse",
+-          "zsocket|zstyle|ztcp|"
++          "zsocket|zstyle|ztcp"
+ 
+ variable = '\$\{([^[:blank:]]+)\}'
+ variable = '\$\(([^[:blank:]]+)\)'
-- 
cgit v0.12