From 21f6e3ae122aeafee741a796bb949dc96188babe Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 23 Feb 2018 21:45:00 +0000
Subject: python-six: update to 1.11.0

---
 abs/core/python_modules/python-six/PKGBUILD    | 18 +++++++++---------
 abs/core/python_modules/python-six/__changelog |  1 -
 2 files changed, 9 insertions(+), 10 deletions(-)
 delete mode 100644 abs/core/python_modules/python-six/__changelog

diff --git a/abs/core/python_modules/python-six/PKGBUILD b/abs/core/python_modules/python-six/PKGBUILD
index 33093f7..56ca2de 100644
--- a/abs/core/python_modules/python-six/PKGBUILD
+++ b/abs/core/python_modules/python-six/PKGBUILD
@@ -4,28 +4,28 @@
 # Contributer: Allan McRae <allan@archlinux.org>
 
 pkgbase=python-six
-pkgname=('python2-six')
-pkgver=1.10.0
-pkgrel=3
+pkgname=('python2-six' 'python-six')
+pkgver=1.11.0
+pkgrel=1
 pkgdesc="Python 2 and 3 compatibility utilities"
 arch=('any')
 url="http://pypi.python.org/pypi/six/"
 license=('MIT')
-makedepends=('python2-setuptools')
-checkdepends=('python2-pytest' 'tk')
+makedepends=('python-setuptools' 'python2-setuptools')
+checkdepends=('python-pytest-runner' 'python2-pytest-runner' 'tk')
 source=("https://pypi.io/packages/source/s/six/six-$pkgver.tar.gz")
-md5sums=('34eed507548117b2ab523ab14b2f8b55')
+sha512sums=('33f246a2e987141e17e5edad9d3537cf3aba0cbdd0bc2a907ea52ce0d674b1474f29c3dd5cc26605fd960396054b189ca5f501708333cad234c223131483fe24')
 
 build() {
   cp -a six-$pkgver{,-py2}
 }
 
 check() {
-#  cd "$srcdir"/six-$pkgver
-#  py.test
+  cd "$srcdir"/six-$pkgver
+  python setup.py pytest
 
   cd "$srcdir"/six-$pkgver-py2
-  py.test2
+  python2 setup.py pytest
 }
 
 package_python-six() {
diff --git a/abs/core/python_modules/python-six/__changelog b/abs/core/python_modules/python-six/__changelog
deleted file mode 100644
index 488d3cf..0000000
--- a/abs/core/python_modules/python-six/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-PKGBUILD: rm py 3 stuff
-- 
cgit v0.12