From 52d8517cf54914022afb3e169157a442aec08dd3 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 1 Mar 2018 18:22:19 +0000
Subject: python-requests: update to 2.18.4

---
 abs/core/python_modules/python-requests/PKGBUILD   | 25 +++++++++++-----------
 .../python_modules/python-requests/__changelog     |  2 --
 2 files changed, 13 insertions(+), 14 deletions(-)
 delete mode 100644 abs/core/python_modules/python-requests/__changelog

diff --git a/abs/core/python_modules/python-requests/PKGBUILD b/abs/core/python_modules/python-requests/PKGBUILD
index d5e1fb4..e791c7b 100644
--- a/abs/core/python_modules/python-requests/PKGBUILD
+++ b/abs/core/python_modules/python-requests/PKGBUILD
@@ -3,25 +3,26 @@
 # Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
 
 pkgbase=python-requests
-pkgname=('python2-requests')
-pkgver=2.18.1
+pkgname=('python-requests' 'python2-requests')
+pkgver=2.18.4
 pkgrel=1
 pkgdesc="Python HTTP for Humans"
 arch=('any')
 url="http://python-requests.org"
 license=('Apache')
-makedepends=('python2-setuptools' 'python2-chardet'
-             'python2-urllib3' 'python2-idna')
-checkdepends=('python2-pytest-httpbin'
-              'python2-pytest-mock' 'python2-pysocks')
+makedepends=('python-setuptools' 'python2-setuptools' 'python-chardet' 'python2-chardet'
+             'python-urllib3' 'python2-urllib3' 'python-idna' 'python2-idna')
+checkdepends=('python-pytest-httpbin' 'python2-pytest-httpbin' 'python-pytest-mock'
+              'python2-pytest-mock' 'python-pysocks' 'python2-pysocks')
 source=("$pkgbase-$pkgver.tar.gz::https://github.com/kennethreitz/requests/archive/v$pkgver.tar.gz"
         certs.patch)
-sha512sums=('a80e0487b4b729e69522817bc2eec2a9c5f1df34df385581b3e937c2409e0fcb4e1f9b4794b198c8b8a57fc05b1bc513fc70d41b324ae251de0fa9bc7c9e6947'
+sha512sums=('8ca20fe18d13b8c62977be0c51617f2ae8618d3d002ad4dc554362828855db7359274efbff0cd13e8c5699508913e91205cffcf306221a70321e74ac10b2d4d7'
             '424a3bb01b23409284f6c9cd2bc22d92df31b85cfd96e1d1b16b5d68adeca670dfed4fff7977d8b10980102b0f780eacc465431021fcd661f3a17168a02a39a3')
 
 prepare() {
   cd "$srcdir"/requests-$pkgver
-  sed -i '/certifi/d' setup.py
+  sed -e '/certifi/d' \
+      -i setup.py
   patch -p1 -i "$srcdir"/certs.patch
 
   cd "$srcdir"
@@ -30,16 +31,16 @@ prepare() {
 }
 
 build() {
-#  cd "$srcdir"/requests-$pkgver
-#  python setup.py build
+  cd "$srcdir"/requests-$pkgver
+  python setup.py build
 
   cd "$srcdir"/requests-$pkgver-py2
   python2 setup.py build
 }
 
 check() {
-#  cd "$srcdir"/requests-$pkgver
-#  py.test tests
+  cd "$srcdir"/requests-$pkgver
+  py.test tests
 
   cd "$srcdir"/requests-$pkgver-py2
   py.test2 tests
diff --git a/abs/core/python_modules/python-requests/__changelog b/abs/core/python_modules/python-requests/__changelog
deleted file mode 100644
index 4f818ef..0000000
--- a/abs/core/python_modules/python-requests/__changelog
+++ /dev/null
@@ -1,2 +0,0 @@
-PKGBUILD: don't build py 3 stuff
-
-- 
cgit v0.12