From e0a8bb8a23e91b8d8382d4ede5d0aa286840db45 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 4 Oct 2020 14:09:52 +0000
Subject: python-setuptools: update to 50.3.0

---
 abs/core/python_modules/python-setuptools/PKGBUILD | 90 ++++++++++------------
 1 file changed, 42 insertions(+), 48 deletions(-)

diff --git a/abs/core/python_modules/python-setuptools/PKGBUILD b/abs/core/python_modules/python-setuptools/PKGBUILD
index c90e33c..32ac764 100644
--- a/abs/core/python_modules/python-setuptools/PKGBUILD
+++ b/abs/core/python_modules/python-setuptools/PKGBUILD
@@ -1,26 +1,47 @@
-# $Id$
 # Maintainer: Angel Velasquez <angvp@archlinux.org>
 # Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Eli Schwartz <eschwartz@archlinux.org>
 
-pkgbase=python-setuptools
-pkgname=('python-setuptools' 'python2-setuptools')
-pkgver=39.0.1
+pkgname=python-setuptools
+pkgver=50.3.0
 pkgrel=1
 epoch=1
 pkgdesc="Easily download, build, install, upgrade, and uninstall Python packages"
 arch=('any')
 license=('PSF')
-url="http://pypi.python.org/pypi/setuptools"
-makedepends=('python-packaging' 'python2-packaging' 'python-appdirs' 'python2-appdirs')
-checkdepends=('python-pytest-runner' 'python2-pytest-runner' 'python-pytest-flake8'
-              'python2-pytest-flake8' 'python-mock' 'python2-mock' 'python-pytest-fixture-config'
-              'python2-pytest-fixture-config' 'python-pytest-virtualenv' 'python2-pytest-virtualenv'
-              'python-wheel' 'python2-wheel' 'python-pip' 'python2-pip' 'git')
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/pypa/setuptools/archive/v$pkgver.tar.gz")
-sha512sums=('34df8f10e89825975c82059c759690a2cc1486fc84c71a76875b92c2452529fbdd628e11e3043e479ea3f031af18b37a37b86d2a8d2505c300188eccdc109332')
+url="https://pypi.org/project/setuptools/"
+depends=('python-appdirs' 'python-packaging' 'python-ordered-set')
+makedepends=('git')
+checkdepends=('python-jaraco.envs' 'python-mock' 'python-pip' 'python-pytest-fixture-config'
+              'python-pytest-flake8' 'python-pytest-virtualenv' 'python-wheel' 'python-paver'
+              'python-pytest-cov')
+provides=('python-distribute')
+replaces=('python-distribute')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/pypa/setuptools/archive/v$pkgver.tar.gz")
+sha512sums=('d4c9191049faa187516634f54a33ce63a547e960800f7855561811f2fff41c9aa32049a0dc755baf0992bd15f02ed89d5e6caa829a35da4440056de03f921502')
+
+export SETUPTOOLS_INSTALL_WINDOWS_SPECIFIC_FILES=0
 
 prepare() {
-  rm -r setuptools-$pkgver/{pkg_resources,setuptools}/_vendor
+  rm -r setuptools-$pkgver/{pkg_resources,setuptools}/{extern,_vendor}
+
+  # Upstream devendoring logic is badly broken, see:
+  # https://bugs.archlinux.org/task/58670
+  # https://github.com/pypa/pip/issues/5429
+  # https://github.com/pypa/setuptools/issues/1383
+  # The simplest fix is to simply rewrite import paths to use the canonical
+  # location in the first place
+  for _module in setuptools pkg_resources '' ; do
+      find setuptools-$pkgver -name \*.py -exec sed -i \
+          -e 's/from '$_module.extern' import/import/' \
+          -e 's/from '$_module.extern'./from /' \
+          -e 's/import '$_module.extern'./import /' \
+          -e "s/__import__('$_module.extern./__import__('/" \
+          {} +
+    done
+
+  # Fix for flake8
+  sed -i 's/import six, ordered_set/import six\nimport ordered_set/' setuptools-$pkgver/setuptools/command/sdist.py
 
   # Remove post-release tag since we are using stable tags
   sed -e '/tag_build = .post/d' \
@@ -28,34 +49,24 @@ prepare() {
       -i setuptools-$pkgver/setup.cfg
 
   # 'Clean' installation is expected to fail since we removed bundled packages
-  sed -i '/^def test_clean_env_install/i import pytest\n\n@pytest.mark.xfail' setuptools-$pkgver/setuptools/tests/test_virtualenv.py
+  sed -i '/^def test_clean_env_install/i @pytest.mark.xfail' setuptools-$pkgver/setuptools/tests/test_virtualenv.py
 
   # Tests failed. Importing an unbundled new setuptools in a virtualenv does not work, but this won't
   # affect normal virtualenv usage (which don't have to import the unbundled setuptools in *current*
   # dir.
   sed -e '/^def test_pip_upgrade_from_source/i @pytest.mark.xfail' \
       -e '/^def test_test_command_install_requirements/i @pytest.mark.xfail' \
+      -e '/^def test_no_missing_dependencies/i @pytest.mark.xfail' \
       -i setuptools-$pkgver/setuptools/tests/test_virtualenv.py
-
-  cp -a setuptools-$pkgver{,-py2}
-
+  
   cd "$srcdir"/setuptools-$pkgver
   sed -i -e "s|^#\!.*/usr/bin/env python|#!/usr/bin/env python3|" setuptools/command/easy_install.py
-
-  cd "$srcdir"/setuptools-$pkgver-py2
-  sed -i -e "s|^#\!.*/usr/bin/env python|#!/usr/bin/env python2|" setuptools/command/easy_install.py
-
-  export SETUPTOOLS_INSTALL_WINDOWS_SPECIFIC_FILES=0
 }
 
 build() {
-  cd "$srcdir"/setuptools-$pkgver
+  cd setuptools-$pkgver
   python bootstrap.py
   python setup.py build
-
-  cd "$srcdir"/setuptools-$pkgver-py2
-  python2 bootstrap.py
-  python2 setup.py build
 }
 
 check() { (
@@ -65,28 +76,11 @@ check() { (
   # https://github.com/pypa/setuptools/pull/810
   export PYTHONDONTWRITEBYTECODE=1
 
-  cd "$srcdir"/setuptools-$pkgver
-  python setup.py pytest
-
-  cd "$srcdir"/setuptools-$pkgver-py2
-  python2 setup.py pytest
+  cd setuptools-$pkgver
+  python -m pytest --deselect setuptools/tests/test_distutils_adoption.py
 )}
 
-package_python-setuptools() {
-  depends=('python-packaging' 'python-appdirs')
-  provides=('python-distribute')
-  replaces=('python-distribute')
-
-  cd "$srcdir"/setuptools-$pkgver
+package() {
+  cd setuptools-$pkgver
   python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
 }
-
-package_python2-setuptools() {
-  depends=('python2-packaging' 'python2-appdirs')
-  provides=('python2-distribute')
-  replaces=('python2-distribute')
-
-  cd "$srcdir"/setuptools-$pkgver-py2
-  python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
-  rm "$pkgdir"/usr/bin/easy_install
-}
-- 
cgit v0.12