From 629d75f0af7313a2cd2d47d0fa61ce731997479e Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 15 Nov 2020 22:06:36 +0000
Subject: python-pytz: 2020.4

---
 ...e-system-zoneinfo-from-the-tzdata-package.patch | 69 ++++++++++++++++++++++
 abs/core/python_modules/python-pytz/PKGBUILD       | 40 +++++++------
 2 files changed, 90 insertions(+), 19 deletions(-)
 create mode 100644 abs/core/python_modules/python-pytz/0001-Use-the-system-zoneinfo-from-the-tzdata-package.patch

diff --git a/abs/core/python_modules/python-pytz/0001-Use-the-system-zoneinfo-from-the-tzdata-package.patch b/abs/core/python_modules/python-pytz/0001-Use-the-system-zoneinfo-from-the-tzdata-package.patch
new file mode 100644
index 0000000..ba7e388
--- /dev/null
+++ b/abs/core/python_modules/python-pytz/0001-Use-the-system-zoneinfo-from-the-tzdata-package.patch
@@ -0,0 +1,69 @@
+From 74baf31e5505d03a71df49894d57e1011e771eb9 Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz@archlinux.org>
+Date: Mon, 4 May 2020 15:26:01 -0400
+Subject: [PATCH] Use the system zoneinfo from the tzdata package.
+
+We don't need to ship these vendored blobs as our system copy works
+quite well.
+
+Signed-off-by: Eli Schwartz <eschwartz@archlinux.org>
+---
+ src/pytz/__init__.py | 13 +------------
+ src/pytz/tzfile.py   |  2 +-
+ src/setup.py         |  2 --
+ 3 files changed, 2 insertions(+), 15 deletions(-)
+
+diff --git a/src/pytz/__init__.py b/src/pytz/__init__.py
+index c25a1d1..3cc59ef 100644
+--- a/src/pytz/__init__.py
++++ b/src/pytz/__init__.py
+@@ -92,19 +92,8 @@ def open_resource(name):
+     if zoneinfo_dir is not None:
+         filename = os.path.join(zoneinfo_dir, *name_parts)
+     else:
+-        filename = os.path.join(os.path.dirname(__file__),
++        filename = os.path.join('/usr', 'share',
+                                 'zoneinfo', *name_parts)
+-        if not os.path.exists(filename):
+-            # http://bugs.launchpad.net/bugs/383171 - we avoid using this
+-            # unless absolutely necessary to help when a broken version of
+-            # pkg_resources is installed.
+-            try:
+-                from pkg_resources import resource_stream
+-            except ImportError:
+-                resource_stream = None
+-
+-            if resource_stream is not None:
+-                return resource_stream(__name__, 'zoneinfo/' + name)
+     return open(filename, 'rb')
+ 
+ 
+diff --git a/src/pytz/tzfile.py b/src/pytz/tzfile.py
+index 25117f3..98eba05 100644
+--- a/src/pytz/tzfile.py
++++ b/src/pytz/tzfile.py
+@@ -126,7 +126,7 @@ def build_tzinfo(zone, fp):
+ if __name__ == '__main__':
+     import os.path
+     from pprint import pprint
+-    base = os.path.join(os.path.dirname(__file__), 'zoneinfo')
++    base = os.path.join('/usr', 'share', 'zoneinfo')
+     tz = build_tzinfo('Australia/Melbourne',
+                       open(os.path.join(base, 'Australia', 'Melbourne'), 'rb'))
+     tz = build_tzinfo('US/Eastern',
+diff --git a/src/setup.py b/src/setup.py
+index fa9a592..675618c 100644
+--- a/src/setup.py
++++ b/src/setup.py
+@@ -22,8 +22,6 @@ for dirpath, dirnames, filenames in os.walk(os.path.join('pytz', 'zoneinfo')):
+                      for filename in filenames])
+ package_data = {'pytz': resources}
+ 
+-assert len(resources) > 10, 'zoneinfo files not found!'
+-
+ setup(
+     name='pytz',
+     version=pytz.VERSION,
+-- 
+2.26.2
+
diff --git a/abs/core/python_modules/python-pytz/PKGBUILD b/abs/core/python_modules/python-pytz/PKGBUILD
index fca20e0..7eb49b7 100644
--- a/abs/core/python_modules/python-pytz/PKGBUILD
+++ b/abs/core/python_modules/python-pytz/PKGBUILD
@@ -4,23 +4,31 @@
 # Contributor: William Rea <sillywilly@gmail.com>
 
 pkgname=('python-pytz' 'python2-pytz')
-pkgver=2018.3
-pkgrel=1
+pkgver=2020.4
+pkgrel=3
 arch=('any')
-url="http://pypi.python.org/pypi/pytz"
+url="https://pypi.python.org/pypi/pytz"
 license=("MIT")
 makedepends=('python' 'python2')
-source=("https://pypi.io/packages/source/p/pytz/pytz-${pkgver}.tar.gz")
-md5sums=('abb07c09c79f78d7c04f222a550c99ef')
+source=("https://pypi.io/packages/source/p/pytz/pytz-${pkgver}.tar.gz"
+        "0001-Use-the-system-zoneinfo-from-the-tzdata-package.patch")
+sha512sums=('dcbe763bc6e48c52df855fe03a8109dc0656a0e851324c0468f4307e8aff60e577fe0c9f0b062319e90d2f639b96e98edf8346064705e244143386c863a0aa7c'
+            '3cbd497313c3049a2ae04298118aefb6dfa9ec4626078c665c95c13a78ae944b33a68813aea0c53b02b0532b64221cca4a0cd2153bd91b3760916bc3c0f6df8f')
 validpgpkeys=('C7ECC365AB6F255E1EB9BA1701FA998FBAC6374A')
 
+prepare() {
+    cd pytz-$pkgver
+
+    patch -p2 -i ../0001-Use-the-system-zoneinfo-from-the-tzdata-package.patch
+    rm -r pytz/zoneinfo/
+}
+
 build(){
-    cd $srcdir
     cp -rf pytz-$pkgver pytz2-$pkgver
 }
 
 check(){
-    cd $srcdir/pytz-$pkgver/pytz/tests
+    cd pytz-$pkgver/pytz/tests
 
     python3 test_tzinfo.py
     python2 test_tzinfo.py
@@ -30,14 +38,11 @@ package_python-pytz(){
     depends=('python')
     pkgdesc="Cross platform time zone library for Python"
 
-    cd $srcdir/pytz-$pkgver
+    cd pytz-$pkgver
 
-    # Fix locale https://github.com/ipython/ipython/issues/2057
-    export LC_ALL=en_US.UTF-8
+    python3 setup.py install --root="$pkgdir"/
 
-    python3 setup.py install --root=$pkgdir/
-
-    install -D LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+    install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
 }
 
 
@@ -45,12 +50,9 @@ package_python2-pytz(){
     depends=('python2')
     pkgdesc="Cross platform time zone library for Python"
 
-    cd $srcdir/pytz2-$pkgver
-
-    # python 2 fix
-#    sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' pytz/tzfile.py
+    cd pytz2-$pkgver
 
-    python2 setup.py install --root="$pkgdir/"
+    python2 setup.py install --root="$pkgdir"/
 
-    install -D LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+    install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
 }
-- 
cgit v0.12