From 27e651943fd737d6d09629e9cebe878054f64ac4 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 15 Nov 2020 21:39:33 +0000
Subject: python-beautifulsoup4: 4.9.3

---
 abs/core/python_modules/python-beautifulsoup4/PKGBUILD | 17 ++++++++---------
 1 file changed, 8 insertions(+), 9 deletions(-)

diff --git a/abs/core/python_modules/python-beautifulsoup4/PKGBUILD b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
index 5ed3781..e3d2f56 100644
--- a/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
+++ b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
@@ -1,20 +1,19 @@
-# $Id$
 # Maintainer: Felix Yan <felixonmars@archlinux.org>
 # Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
 # Contributor: Giovanni Scafora <giovanni@archlinux.org>
 
 pkgbase=python-beautifulsoup4
 pkgname=('python-beautifulsoup4' 'python2-beautifulsoup4')
-pkgver=4.6.0
-pkgrel=2
+pkgver=4.9.3
+pkgrel=3
 pkgdesc="A Python HTML/XML parser designed for quick turnaround projects like screen-scraping"
 arch=('any')
-url="http://www.crummy.com/software/BeautifulSoup/index.html"
+url="https://www.crummy.com/software/BeautifulSoup/index.html"
 license=('PSF')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools' 'python2-setuptools' 'python-soupsieve' 'python2-soupsieve')
 checkdepends=('python-pytest' 'python2-pytest')
-source=("http://www.crummy.com/software/BeautifulSoup/bs4/download/${pkgver%.*}/${pkgbase#*-}-$pkgver.tar.gz")
-sha512sums=('1a7eee4218e58cc3852e71fe4f0892f673bb46a851941264766a38eff8ef05d612d88b4641fcb478ce8f66ac50dc987ca039923c4bbb11867c74813289f7e578')
+source=("https://pypi.io/packages/source/b/beautifulsoup4/beautifulsoup4-$pkgver.tar.gz")
+sha512sums=('e3cb6258bd7c51f12128fa8ee5948fb3566163ae233fac2dda21bab7772ab8dbb384d920b0ea138ef9921307b48f89cee3a9bf6111dfc8903d917ee7af365f34')
 
 prepare() {
   cp -a beautifulsoup4-$pkgver{,-py2}
@@ -37,7 +36,7 @@ check() {
 }
 
 package_python-beautifulsoup4() {
-  depends=('python')
+  depends=('python-soupsieve')
   optdepends=('python-chardet: to autodetect character encodings'
               'python-lxml: alternative HTML parser'
               'python-html5lib: alternative HTML parser')
@@ -47,7 +46,7 @@ package_python-beautifulsoup4() {
 }
 
 package_python2-beautifulsoup4() {
-  depends=('python2')
+  depends=('python2-soupsieve')
   optdepends=('python2-chardet: to autodetect character encodings'
               'python2-lxml: alternative HTML parser'
               'python2-html5lib: alternative HTML parser')
-- 
cgit v0.12