From 042a26e265af43b06672ad7fd773dcffce32ef39 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 21 Mar 2018 17:36:40 +0000
Subject: LinHES-system: myth2mkv: change Handbrake option that was removed

---
 abs/core/LinHES-system/PKGBUILD | 4 ++--
 abs/core/LinHES-system/myth2mkv | 8 ++++----
 2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 5ecc711..adfaef6 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
 pkgname=LinHES-system
 pkgver=8.5.1
-pkgrel=2
+pkgrel=3
 arch=('i686' 'x86_64')
 install=system.install
 pkgdesc="Everything that makes LinHES an automated system"
@@ -132,7 +132,7 @@ md5sums=('c6e6b83a1f4c35ef4501e277657ab2ac'
          'a94fe6d980f4b810f2e2ae5352084b39'
          '0d1632ea63d8145c173c6aecf0b007f0'
          'ff689f2e9572a78d88384b2e5774f579'
-         '28f29578e5b3ba84fdf2aa57cf475bcf'
+         'a811c5c01cc127ef403a24c941e03c66'
          '4a1fda884dcd7d65fb2690fbdbd92a83'
          '29f451783db3220b612e00c29e3ded73'
          '7fe42dfc99af42a45440c9c3954c3c19'
diff --git a/abs/core/LinHES-system/myth2mkv b/abs/core/LinHES-system/myth2mkv
index 1352476..51a0c9b 100644
--- a/abs/core/LinHES-system/myth2mkv
+++ b/abs/core/LinHES-system/myth2mkv
@@ -93,7 +93,7 @@ fi
 check_background_progress()
 # check handbrake progress in background
 {
-while [ `tail -2 ${STATUSFILE} | grep -c "^HandBrake has exited"` = 0 ]
+while [ ! -f ${HB_RETURN_CODE} ]
 do
     sleep 15
     check_myth_jobcmds
@@ -197,19 +197,19 @@ if [[ ${QUALITY} = HP ]] ; then
   if [[ -n ${CROP} ]] ; then
     CROP="--crop ${CROP}"
   else
-    CROP="--crop 0:0:0:0 --strict-anamorphic"
+    CROP="--crop 0:0:0:0 --auto-anamorphic"
   fi
   HB_OPTS="-o ${TMPFILE} -e x264 ${TUNING} -q 20.0 -a 1,1 -E copy:ac3,faac -B 160,160 -6 dpl2,auto -R Auto,Auto -D 0.0,0.0 --audio-copy-mask aac,ac3,dtshd,dts,mp3 --audio-fallback ffac3 -f mkv --decomb --loose-anamorphic --modulus 2 -m --x264-preset medium --h264-profile high --h264-level 4.1 ${CROP} -s 1"
 elif [[ ${QUALITY} = HQ ]] ; then
   if [[ -n ${CROP} ]] ; then
     CROP="--crop ${CROP}"
   else
-    CROP="--crop 0:0:0:0 --strict-anamorphic"
+    CROP="--crop 0:0:0:0 --auto-anamorphic"
   fi
   HB_OPTS="-o ${TMPFILE} -f mkv -m -e x264 ${TUNING} -x b-adapt=2:rc-lookahead=50 -b 5000 -2 -T ${WIDTH} ${HEIGHT} -r ${FPS} --cfr ${CROP} ${DEINT} -a 1 -E copy -s 1"
 else
   if [[ ${CROP} = "--crop 0:0:0:0" ]] ; then
-    CROP="${CROP} --strict-anamorphic"
+    CROP="${CROP} --auto-anamorphic"
   fi
   if [[ ${QUALITY} = LQ ]] ; then
     HB_OPTS="-o ${TMPFILE} -f mkv -m -e x264 ${TUNING} -b 1250 ${WIDTH} ${HEIGHT} -r ${FPS} --pfr ${CROP} ${DEINT} -a 1 -E lame -B 128 -Q 8 -6 stereo -s 1"
-- 
cgit v0.12