From fa6a68637286986ee0c0bdbe58fae8c13466983f Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 16 Aug 2014 12:51:04 -0500
Subject: lcdproc: .5.6 refs #961

---
 abs/extra/lcdproc/PKGBUILD     | 37 +++++++++++++++++--------------------
 abs/extra/lcdproc/lcdd         | 38 --------------------------------------
 abs/extra/lcdproc/lcdd.service | 11 +++++++++++
 3 files changed, 28 insertions(+), 58 deletions(-)
 delete mode 100755 abs/extra/lcdproc/lcdd
 create mode 100644 abs/extra/lcdproc/lcdd.service

diff --git a/abs/extra/lcdproc/PKGBUILD b/abs/extra/lcdproc/PKGBUILD
index 21aa4e8..3106af2 100644
--- a/abs/extra/lcdproc/PKGBUILD
+++ b/abs/extra/lcdproc/PKGBUILD
@@ -1,31 +1,30 @@
+# $Id: PKGBUILD 102962 2013-12-25 04:58:31Z bgyorgy $
 # Maintainer: BlackEagle <ike DOT devolder AT gmail DOT com>
 # Contributor: Bernhard Walle <bernhard.walle@gmx.de>
+
 pkgname=lcdproc
 pkgver=0.5.6
-pkgrel=1
+pkgrel=4
 pkgdesc="Utility to drive one or more LCD (and LCD-like) devices"
+arch=('i686' 'x86_64')
 url="http://lcdproc.omnipotent.net/"
-license="GPL"
-depends=('libusb-compat')
-optdepends=(
-	'perl: needed for some lcdproc tools'
-)
-backup=(
-	'etc/LCDd.conf'
+license=('GPL')
+depends=('libftdi-compat')
+optdepends=('perl: needed for some lcdproc tools')
+backup=('etc/LCDd.conf'
 	'etc/lcdexec.conf'
 	'etc/lcdproc.conf'
-	'etc/lcdvc.conf'
-)
-arch=('i686' 'x86_64')
-source=(
-	"http://switch.dl.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver-pre1.tar.gz"
-	'lcdd'
-)
+	'etc/lcdvc.conf')
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+	'lcdd.service')
+sha256sums=('bd2f43c30ff43b30f43110abe6b4a5bc8e0267cb9f57fa97cc5e5ef9488b984a'
+            '0acdc0fb9668e6d5e023349874301153a16935e1ad757d550c426a9a7ac64638')
 
 build() {
-	cd "$pkgname-$pkgver-pre1"
+	cd "$pkgname-$pkgver"
 	./configure \
 		--prefix=/usr \
+		--sbindir=/usr/bin \
 		--sysconfdir=/etc \
 		--enable-libusb \
 		--enable-lcdproc-menus \
@@ -35,10 +34,8 @@ build() {
 }
 
 package() {
-	cd "$pkgname-$pkgver-pre1"
+	cd "$pkgname-$pkgver"
 	make DESTDIR="$pkgdir" install
 	sed -e "s/server\/drivers\//\/usr\/lib\/lcdproc\//g" -i "$pkgdir/etc/LCDd.conf"
-	install -Dm755 "$srcdir/lcdd" "$pkgdir/etc/rc.d/lcdd"
+	install -Dm644 "$srcdir/lcdd.service" "$pkgdir/usr/lib/systemd/system/lcdd.service"
 }
-md5sums=('2175376ebefc18280b494e5f0a68329b'
-         '56f52dcccd6e129a9cf84cd1a0452d56')
diff --git a/abs/extra/lcdproc/lcdd b/abs/extra/lcdproc/lcdd
deleted file mode 100755
index a124c00..0000000
--- a/abs/extra/lcdproc/lcdd
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-PID=`pidof -o %PPID /usr/sbin/LCDd`
-case "$1" in
-  start)
-    stat_busy "Starting LCDd daemon"
-    [ -z "$PID" ] && /usr/sbin/LCDd -c /etc/LCDd.conf
-    if [ $? -gt 0 ]; then
-      stat_fail
-    else
-      echo $PID > /var/run/lcdd.pid
-      add_daemon lcdd
-      stat_done
-    fi
-    ;;
-  stop)
-    stat_busy "Stopping LCDd daemon"
-    [ ! -z "$PID" ]  && kill $PID &> /dev/null
-    if [ $? -gt 0 ]; then
-      stat_fail
-    else
-      rm /var/run/lcdd.pid
-      rm_daemon lcdd
-      stat_done
-    fi
-    ;;
-  restart)
-    $0 stop
-    sleep 1
-    $0 start
-    ;;
-  *)
-    echo "usage: $0 {start|stop|restart}"  
-esac
-exit 0
diff --git a/abs/extra/lcdproc/lcdd.service b/abs/extra/lcdproc/lcdd.service
new file mode 100644
index 0000000..6b0072d
--- /dev/null
+++ b/abs/extra/lcdproc/lcdd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=LCD display driver
+After=syslog.target
+
+[Service]
+Type=forking
+ExecStart=/usr/bin/LCDd -c /etc/LCDd.conf
+ControlGroup=cpu:/
+
+[Install]
+WantedBy=multi-user.target
-- 
cgit v0.12