From 20c8e1fbc7a627e09539ea1334188a71be0b9726 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sun, 9 Jun 2019 17:13:34 +0000
Subject: python-pyrfc3339: initial inclusion, dep of python-acme

---
 .../python_modules/python-pyrfc3339/LICENSE.txt    | 19 ++++++++
 abs/core/python_modules/python-pyrfc3339/PKGBUILD  | 52 ++++++++++++++++++++++
 2 files changed, 71 insertions(+)
 create mode 100644 abs/core/python_modules/python-pyrfc3339/LICENSE.txt
 create mode 100644 abs/core/python_modules/python-pyrfc3339/PKGBUILD

diff --git a/abs/core/python_modules/python-pyrfc3339/LICENSE.txt b/abs/core/python_modules/python-pyrfc3339/LICENSE.txt
new file mode 100644
index 0000000..1daa66c
--- /dev/null
+++ b/abs/core/python_modules/python-pyrfc3339/LICENSE.txt
@@ -0,0 +1,19 @@
+Copyright (c) 2010 Kurt Raschke
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/abs/core/python_modules/python-pyrfc3339/PKGBUILD b/abs/core/python_modules/python-pyrfc3339/PKGBUILD
new file mode 100644
index 0000000..e6127ec
--- /dev/null
+++ b/abs/core/python_modules/python-pyrfc3339/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
+
+pkgname=(python-pyrfc3339 python2-pyrfc3339)
+pkgver=1.1
+pkgrel=2
+pkgdesc="Parses and generates RFC 3339-compliant timestamps using Python datetime.datetime objects."
+arch=('any')
+license=('MIT')
+url="https://pypi.python.org/pypi/pyRFC3339"
+makedepends=('python-setuptools' 'python2-setuptools' 'python-pytz' 'python2-pytz')
+checkdepends=('python-nose' 'python2-nose')
+source=("https://pypi.python.org/packages/source/p/pyRFC3339/pyRFC3339-${pkgver}.tar.gz"
+        LICENSE.txt)
+sha512sums=('958b7761fab590aa42bb57a955c5d834441f717796a452b60df21663099dcf2fc046afe60f8157fd0f1edfd95c5e9c9c5349ab10ca4078d210fc63d848496a2f'
+            '73c58b87e14593ee283cc323a93820c18a00e9af4e5027687fc8f6cd5735c98f341c6ac1aa90c040d0899766cabb976a85201b171874b4b81934ff02a9728f2d')
+
+prepare() {
+  cp -a pyRFC3339-$pkgver{,-py2}
+}
+
+build() {
+  cd "$srcdir/pyRFC3339-$pkgver"
+  python setup.py build
+
+  cd "$srcdir/pyRFC3339-$pkgver-py2"
+  python2 setup.py build
+}
+
+check() {
+  cd "$srcdir/pyRFC3339-$pkgver"
+  python setup.py test
+
+  cd "$srcdir/pyRFC3339-$pkgver-py2"
+  python2 setup.py test
+}
+
+package_python-pyrfc3339() {
+  depends=('python-pytz')
+
+  cd "$srcdir/pyRFC3339-$pkgver"
+  python setup.py install --root="$pkgdir/" --optimize=1
+  install -D -m644 ../LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}
+
+package_python2-pyrfc3339() {
+  depends=('python2-pytz')
+
+  cd "$srcdir/pyRFC3339-$pkgver-py2"
+  python2 setup.py install --root="$pkgdir/" --optimize=1
+  install -D -m644 ../LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}
-- 
cgit v0.12