From 0bde051b0b1f70333f75a50f1214dca0d27b75da Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 16 Sep 2015 21:52:11 +0000
Subject: shellinabox: update to 2.19

---
 abs/extra/shellinabox/PKGBUILD             | 41 ++++++++++--------------------
 abs/extra/shellinabox/__changelog          |  3 +++
 abs/extra/shellinabox/shellinaboxd.conf.d  |  5 ----
 abs/extra/shellinabox/shellinaboxd.rc.d    | 38 ---------------------------
 abs/extra/shellinabox/shellinaboxd.service | 17 -------------
 5 files changed, 16 insertions(+), 88 deletions(-)
 delete mode 100644 abs/extra/shellinabox/shellinaboxd.conf.d
 delete mode 100644 abs/extra/shellinabox/shellinaboxd.rc.d
 delete mode 100644 abs/extra/shellinabox/shellinaboxd.service

diff --git a/abs/extra/shellinabox/PKGBUILD b/abs/extra/shellinabox/PKGBUILD
index af3b4be..fc9a679 100644
--- a/abs/extra/shellinabox/PKGBUILD
+++ b/abs/extra/shellinabox/PKGBUILD
@@ -1,53 +1,38 @@
-# Contributor: Brian Moore <archlinux@cptl.org>
 pkgname=shellinabox
-pkgver=2.14
-pkgrel=6
-pkgdesc="A web-based ssh client."
+pkgver=2.19
+pkgrel=1
+_pkghash=master
+pkgdesc="Implementation of a web server that can export arbitrary command line tools to a web based terminal emulator"
 arch=('i686' 'x86_64')
 url="http://shellinabox.com/"
 license=('GPL2')
-depends=('runit-scripts>=8.0-2')
-optdepends=('openssh: SSL support')
-makedepends=(openssh)
+depends=('runit-scripts>=8.0-2' 'openssh')
 install=shellinaboxd.install
-backup=('etc/conf.d/shellinaboxd')
-source=("http://shellinabox.googlecode.com/files/$pkgname-$pkgver.tar.gz" "shellinaboxd.rc.d" "shellinaboxd.conf.d" "shellinaboxd.service"
-        "shellinaboxd.include" "shellinaboxd.gen_light_conf.d")
-
-prepare() {
-	cd "$srcdir/$pkgname-$pkgver"
-	sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" configure
-}
+source=("https://github.com/shellinabox/shellinabox/archive/${_pkghash}.tar.gz"
+        "shellinaboxd.include"
+        "shellinaboxd.gen_light_conf.d")
 
 build() {
-  cd "$srcdir/$pkgname-$pkgver"
+  cd "$srcdir/$pkgname-${_pkghash}"
 
   #change default to show onscreen keyboard
-  sed -i "s/this.softKeyboard         = false;/this.softKeyboard         = true;/g" ./shellinabox/vt100.js
   sed -i "s/this.softKeyboard         = false;/this.softKeyboard         = true;/g" ./shellinabox/vt100.jspp
 
+  autoreconf -i
+  export CPPFLAGS="${CPPFLAGS/-D_FORTIFY_SOURCE=2/}"
   ./configure  --prefix=/usr
-
   make 
 }
 package() {
-  cd "$srcdir/$pkgname-$pkgver"
+  cd "$srcdir/$pkgname-${_pkghash}"
   make DESTDIR=$pkgdir install || return 1
 
-  install -Dm755 $srcdir/shellinaboxd.rc.d $pkgdir/etc/rc.d/shellinaboxd
-  install -D -m644 $srcdir/shellinaboxd.service $pkgdir/usr/lib/systemd/system/shellinaboxd.service
-  install -Dm644 $srcdir/shellinaboxd.conf.d $pkgdir/etc/conf.d/shellinaboxd
-  install -dm700 -o nobody $pkgdir/var/lib/shellinabox
-
   #install conf files for lighttpd
   mkdir -p ${pkgdir}/etc/lighttpd
   install -D -m 644 ${srcdir}/shellinaboxd.include ${pkgdir}/etc/lighttpd/
   #gen_light_conf
   install -D -m 744 ${srcdir}/shellinaboxd.gen_light_conf.d ${pkgdir}/etc/gen_light_conf.d/shellinaboxd.conf
 }
-md5sums=('6c63b52edcebc56ee73a108e7211d174'
-         'feea22575089cc7eb4925b1daff88b8c'
-         '77e487f36da2abe51251500f4a1e024f'
-         'be649866d06ba497d88bb14f3e58f862'
+md5sums=('7b7d178a2ec5b63f2b31b2869aa7b755'
          'dd46ab61bfafdb56ea705a876963550e'
          'aadd1edf4110aca2d16d806791e90019')
diff --git a/abs/extra/shellinabox/__changelog b/abs/extra/shellinabox/__changelog
index d0d35bb..9022771 100644
--- a/abs/extra/shellinabox/__changelog
+++ b/abs/extra/shellinabox/__changelog
@@ -1,3 +1,6 @@
+9/16/2015
+PKGBUILD: AUR changed so this no longer is similar
+
 #8/13/2013
 initial inclusion from AUR v2.14-3
 add dep of runit-scripts to PKGBUILD
diff --git a/abs/extra/shellinabox/shellinaboxd.conf.d b/abs/extra/shellinabox/shellinaboxd.conf.d
deleted file mode 100644
index 646bab7..0000000
--- a/abs/extra/shellinabox/shellinaboxd.conf.d
+++ /dev/null
@@ -1,5 +0,0 @@
-#
-# Parameters to be passed to shellinaboxd
-#
-SHELLINABOXD_ARGS="-t -b"
-
diff --git a/abs/extra/shellinabox/shellinaboxd.rc.d b/abs/extra/shellinabox/shellinaboxd.rc.d
deleted file mode 100644
index 3399945..0000000
--- a/abs/extra/shellinabox/shellinaboxd.rc.d
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/bin/bash
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-SHELLINABOXD_ARGS=
-[ -f /etc/conf.d/shellinaboxd ] && . /etc/conf.d/shellinaboxd
-
-PID=`pidof -o %PPID /usr/bin/shellinaboxd`
-case "$1" in
- start)
-   stat_busy "Starting SHELLINABOXD"
-   [ -z "$PID" ] && /usr/bin/shellinaboxd ${SHELLINABOXD_ARGS}
-   if [ $? -gt 0 ]; then
-     stat_fail
-   else
-     add_daemon shellinaboxd
-     stat_done
-   fi
-   ;;
- stop)
-   stat_busy "Stopping SHELLINABOXD"
-   [ ! -z "$PID" ]  && kill $PID &> /dev/null
-   if [ $? -gt 0 ]; then
-     stat_fail
-   else
-     rm_daemon shellinboxd
-     stat_done
-   fi
-   ;;
- restart)
-   $0 stop
-   $0 start
-   ;;
- *)
-   echo "usage: $0 {start|stop|restart}"  
-esac
-exit 0
-
diff --git a/abs/extra/shellinabox/shellinaboxd.service b/abs/extra/shellinabox/shellinaboxd.service
deleted file mode 100644
index d92065b..0000000
--- a/abs/extra/shellinabox/shellinaboxd.service
+++ /dev/null
@@ -1,17 +0,0 @@
-[Unit]
-Description=Serve a login-terminal over http on  port 4200.
-Required=sshd.service
-After=sshd.service
-
-[Service]
-User=root
-Type=forking
-EnvironmentFile=/etc/conf.d/shellinaboxd
-ExecStart=/usr/bin/shellinaboxd  $SHELLINABOXD_ARGS
-ExecReload=/bin/kill -HUP $MAINPID
-KillMode=process
-Restart=on-abort
-
-[Install]
-WantedBy=multi-user.target
-
-- 
cgit v0.12