From 1554ecd8c6978862d012c4fe35295e660161aed1 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 31 May 2018 17:59:08 +0000
Subject: perl-astro-suntime: update to 0.06

---
 abs/core/perl_modules/perl-astro-suntime/PKGBUILD | 49 +++++++++++++++++++++++
 1 file changed, 49 insertions(+)
 create mode 100644 abs/core/perl_modules/perl-astro-suntime/PKGBUILD

diff --git a/abs/core/perl_modules/perl-astro-suntime/PKGBUILD b/abs/core/perl_modules/perl-astro-suntime/PKGBUILD
new file mode 100644
index 0000000..76a5cfe
--- /dev/null
+++ b/abs/core/perl_modules/perl-astro-suntime/PKGBUILD
@@ -0,0 +1,49 @@
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator  : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-astro-suntime'
+pkgver='0.06'
+pkgrel='1'
+pkgdesc="Get Sun Rise and Set Times for any location on the globe"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-time-parsedate')
+makedepends=()
+url='https://metacpan.org/release/Astro-SunTime'
+source=("http://search.cpan.org/CPAN/authors/id/R/RO/ROBF/Astro-SunTime-$pkgver.tar.gz")
+_distdir="Astro-SunTime-$pkgver"
+
+build() {
+  ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""                 \
+      PERL_AUTOINSTALL=--skipdeps                            \
+      PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'"     \
+      PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+      MODULEBUILDRC=/dev/null
+
+    cd "$srcdir/$_distdir"
+    /usr/bin/perl Makefile.PL
+    make
+  )
+}
+
+check() {
+  cd "$srcdir/$_distdir"
+  ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+    make test
+  )
+}
+
+package() {
+  cd "$srcdir/$_distdir"
+  make install
+
+  find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et:
+md5sums=('42cb8c94de8a111ed652196925c22a45')
-- 
cgit v0.12