From d93f46c09f1b7c11522382a38506590fef280db2 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Fri, 6 Feb 2015 19:35:28 +0000
Subject: python-parted: update to 3.10.1

---
 abs/core/python_modules/python-parted/PKGBUILD    | 39 ++++++++++++++++-------
 abs/core/python_modules/python-parted/__changelog |  1 +
 2 files changed, 28 insertions(+), 12 deletions(-)
 create mode 100644 abs/core/python_modules/python-parted/__changelog

diff --git a/abs/core/python_modules/python-parted/PKGBUILD b/abs/core/python_modules/python-parted/PKGBUILD
index 4374e09..0e2aa3c 100644
--- a/abs/core/python_modules/python-parted/PKGBUILD
+++ b/abs/core/python_modules/python-parted/PKGBUILD
@@ -1,17 +1,32 @@
+# Maintainer: Nikos Skalkotos <skalkoto at gmail dot com>
+# Contributor: Achilleas Pipinellis <axilleas archlinux info>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: kfgz <kfgz at interia pl>
+# Contributor: Gökmen Görgen <gkmngrgn at gmail dot com>
+# Contributor: Baurzhan Muftakhidinov <baurthefirst (at) gmail (dot) com>
+
+_pkgname=pyparted
 pkgname=python-parted
-__pkgname=pyparted
-pkgver=3.8
-pkgrel=1
-pkgdesc="Python bindings for libparted"
+pkgver=3.10.1
+pkgrel=2
+pkgdesc="Python module for GNU parted"
+url="https://github.com/dcantrell/pyparted"
 arch=('i686' 'x86_64')
-license=('LGPL' 'MPL')
-depends=('python2' 'parted>=3.1' 'python-decorator')
-options=('!libtool')
-source=(https://fedorahosted.org/releases/p/y/pyparted/pyparted-${pkgver}.tar.gz)
-url="https://fedorahosted.org/pyparted/"
+license=('GPL2')
+depends=('python2' 'parted>=3.0')
+makedepends=('pkg-config')
+conflicts=('pyparted-git')
+replaces=('pyparted')
+source=("https://github.com/dcantrell/${_pkgname}/archive/${_pkgname}-${pkgver}.tar.gz")
 
 build() {
-  cd "${srcdir}/${__pkgname}-${pkgver}"
-  python2 setup.py install --prefix=/usr --root="${pkgdir}"
+  cd "${srcdir}/${_pkgname}-${_pkgname}-${pkgver}"
+  python2 setup.py build
+}
+
+package() {
+  cd "${srcdir}/${_pkgname}-${_pkgname}-${pkgver}"
+  python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
 }
-md5sums=('e9cd0c94c71ac17755f71a8e1561eac2')
+sha512sums=('d2842ba919808ccb757f6852e17c725b7db6e94db31548366fbdf2376960f8cf6ce239cb33282b4eca02f20a94f85bd58e8fc1d40834670c9684f5903c3515e5')
+
diff --git a/abs/core/python_modules/python-parted/__changelog b/abs/core/python_modules/python-parted/__changelog
new file mode 100644
index 0000000..3cf54c1
--- /dev/null
+++ b/abs/core/python_modules/python-parted/__changelog
@@ -0,0 +1 @@
+From AUR python2-pyparted
-- 
cgit v0.12