From 999d8e68e11f9676c491540601ae0a191e1fab49 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 6 Aug 2012 17:29:02 -0500
Subject: avahi 0.6.31

---
 abs/core/avahi/ChangeLog               |  17 ------
 abs/core/avahi/PKGBUILD                | 104 ++++++++++++++++-----------------
 abs/core/avahi/__changelog             |   2 +-
 abs/core/avahi/avahi-daemon-dbus.patch |  11 ----
 abs/core/avahi/avahi.install           |  21 -------
 abs/core/avahi/install                 |  21 +++++++
 abs/core/avahi/introspection.patch     |  18 ------
 abs/core/avahi/rc.d.patch              |  11 ++++
 8 files changed, 85 insertions(+), 120 deletions(-)
 delete mode 100644 abs/core/avahi/ChangeLog
 delete mode 100644 abs/core/avahi/avahi-daemon-dbus.patch
 delete mode 100644 abs/core/avahi/avahi.install
 create mode 100644 abs/core/avahi/install
 delete mode 100644 abs/core/avahi/introspection.patch
 create mode 100644 abs/core/avahi/rc.d.patch

diff --git a/abs/core/avahi/ChangeLog b/abs/core/avahi/ChangeLog
deleted file mode 100644
index 57984a3..0000000
--- a/abs/core/avahi/ChangeLog
+++ /dev/null
@@ -1,17 +0,0 @@
-
-2009-04-23  Douglas Soares de Andrade  <douglas@archlinux.org>
-
-	* Updated for i686: 0.6.25
-
-2009-03-21  Eric Belanger  <eric@archlinux.org>
-
-	* Added optdepends for avahi-discover (close FS#11250)
-
-2009-01-04  Douglas Soares de Andrade  <douglas@archlinux.org>
-
-	* Updated for i686: 0.6.24
-
-2008-07-22  Douglas Soares de Andrade  <douglas@archlinux.org>
-
-	* Updated for i686: 0.6.23
-
diff --git a/abs/core/avahi/PKGBUILD b/abs/core/avahi/PKGBUILD
index 3ab5c8b..424bf2c 100644
--- a/abs/core/avahi/PKGBUILD
+++ b/abs/core/avahi/PKGBUILD
@@ -1,15 +1,18 @@
-# $Id: PKGBUILD 94183 2010-10-05 07:08:54Z bisson $
+# $Id: PKGBUILD 156451 2012-04-18 12:14:05Z bisson $
 # Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
 
 pkgname=avahi
-pkgver=0.6.27
-pkgrel=8
-pkgdesc='A multicast/unicast DNS-SD framework'
-arch=('i686' 'x86_64')
+pkgver=0.6.31
+pkgrel=3
+pkgdesc='Multicast/unicast DNS-SD framework'
 url='http://www.avahi.org/'
 license=('LGPL')
+arch=('i686' 'x86_64')
+options=('!libtool' '!emptydirs')
 depends=('expat' 'libdaemon' 'glib2' 'dbus' 'libcap' 'gdbm')
-optdepends=('gtk2: avahi-discover-standalone'
+optdepends=('gtk3: avahi-discover-standalone, bshell, bssh, bvnc'
+            'gtk2: gtk2 bindings'
             'qt3: qt3 bindings'
             'qt: qt bindings'
             'pygtk: avahi-bookmarks, avahi-discover'
@@ -17,62 +20,59 @@ optdepends=('gtk2: avahi-discover-standalone'
             'mono: mono bindings'
             'dbus-python: avahi-discover'
             'nss-mdns: NSS support for mDNS')
-makedepends=('qt' 'pygtk' 'mono' 'intltool' 'dbus-python' 'gtk-sharp-2' 'gobject-introspection>=0.9.10')
-backup=(etc/avahi/avahi-daemon.conf etc/avahi/services/{sftp-,}ssh.service)
-install=avahi.install
+makedepends=('qt' 'qt3' 'pygtk' 'mono' 'intltool' 'dbus-python'
+             'gtk-sharp-2' 'gobject-introspection' 'gtk3')
+backup=('etc/avahi/hosts'
+        'etc/avahi/avahi-daemon.conf'
+        'etc/avahi/services/ssh.service'
+        'etc/avahi/services/sftp-ssh.service')
+source=("http://www.avahi.org/download/avahi-${pkgver}.tar.gz"
+        'gnome-nettool.png'
+        'rc.d.patch')
+sha1sums=('7e05bd78572c9088b03b1207a0ad5aba38490684'
+          'cf56387c88aed246b9f435efc182ef44de4d52f3'
+          '625ad7c131c0c1c383caeddef18fc7a32d8f3ab9')
+
 conflicts=('howl' 'mdnsresponder')
 provides=('howl' 'mdnsresponder')
-replaces=('howl' 'mdnsresponder')
-options=('!libtool')
-source=(http://www.avahi.org/download/avahi-${pkgver}.tar.gz
-        avahi-daemon-dbus.patch
-        gnome-nettool.png
-        introspection.patch)
-sha1sums=('e763bbeba92fd5b3ba3e2af5fc85aaf99b406c8b'
-          '41e9f23efa0b5a5f7b0f14a86cfb0677ece84c61'
-          'cf56387c88aed246b9f435efc182ef44de4d52f3'
-          '999d71add829ab9bb55262855dfe04126ac7975c')
+
+install=install
 
 build() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
+	cd "${srcdir}/${pkgname}-${pkgver}"
 
-  sed -i 's/netdev/network/g' avahi-daemon/avahi-dbus.conf
-  patch -Np0 -i "${srcdir}/avahi-daemon-dbus.patch"
-  patch -Np1 -i "${srcdir}/introspection.patch"
+	sed -i 's/netdev/network/g' avahi-daemon/avahi-dbus.conf
+	patch -p1 -i ../rc.d.patch
 
-  ./configure \
-    --prefix=/usr \
-    --sysconfdir=/etc \
-    --localstatedir=/var \
-    --disable-gtk3 \
-    --disable-qt3 \
-    --disable-monodoc \
-    --disable-doxygen-doc \
-    --disable-xmltoman \
-    --enable-compat-libdns_sd \
-    --enable-compat-howl \
-    --with-distro=archlinux \
-    --with-avahi-priv-access-group=network \
-    --with-autoipd-user=avahi \
-    --with-autoipd-group=avahi \
-    --with-systemdsystemunitdir=/lib/systemd/system # See FS#20999
+	# pygtk requires python2; make it explicit in case other python are installed: FS#21865
+	PYTHON=python2 \
+	PKG_CONFIG_PATH=/opt/qt/lib/pkgconfig \
+	./configure \
+		--prefix=/usr \
+		--sysconfdir=/etc \
+		--localstatedir=/var \
+		--disable-static \
+		--disable-monodoc \
+		--enable-compat-libdns_sd \
+		--enable-compat-howl \
+		--with-distro=archlinux \
+		--with-avahi-priv-access-group=network \
+		--with-autoipd-user=avahi \
+		--with-autoipd-group=avahi \
+		--with-systemdsystemunitdir=/usr/lib/systemd/system \
 
-  make || return 1
+	make
 }
 
 package() {
-  cd "${srcdir}/${pkgname}-${pkgver}"
-
-  make DESTDIR="${pkgdir}" install || return 1
-
-  # howl and mdnsresponder compatability
-  cd "${pkgdir}"/usr/include
-  ln -s avahi-compat-libdns_sd/dns_sd.h dns_sd.h
-  ln -s avahi-compat-howl howl
-  cd "${pkgdir}"/usr/lib/pkgconfig
-  ln -s avahi-compat-howl.pc howl.pc
+	cd "${srcdir}/${pkgname}-${pkgver}"
+	make DESTDIR="${pkgdir}" install
+	install -Dm644 ../gnome-nettool.png "${pkgdir}"/usr/share/pixmaps/gnome-nettool.png
 
-  sed -i '1c #!/usr/bin/python2' "$pkgdir"/usr/bin/avahi-{bookmarks,discover}
+	cd "${pkgdir}"
+	sed -i '1c #!/usr/bin/python2' usr/bin/avahi-{bookmarks,discover}
 
-  install -D -m 644 "${srcdir}"/gnome-nettool.png "${pkgdir}"/usr/share/pixmaps/gnome-nettool.png
+	# howl and mdnsresponder compatability
+	(cd usr/include; ln -s avahi-compat-libdns_sd/dns_sd.h dns_sd.h; ln -s avahi-compat-howl howl)
+	(cd usr/lib/pkgconfig; ln -s avahi-compat-howl.pc howl.pc)
 }
diff --git a/abs/core/avahi/__changelog b/abs/core/avahi/__changelog
index f8fec40..07b29bb 100644
--- a/abs/core/avahi/__changelog
+++ b/abs/core/avahi/__changelog
@@ -1 +1 @@
-disable qt3 in configure and remove make and optdepends on it.
+removed php
diff --git a/abs/core/avahi/avahi-daemon-dbus.patch b/abs/core/avahi/avahi-daemon-dbus.patch
deleted file mode 100644
index a168f03..0000000
--- a/abs/core/avahi/avahi-daemon-dbus.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- initscript/archlinux/avahi-daemon.in	2010-08-17 22:23:46.510293144 +0200
-+++ initscript/archlinux/avahi-daemon.in	2010-08-17 22:46:58.110163026 +0200
-@@ -33,6 +35,8 @@
- 
- case "$1" in
-     start)
-+        ck_daemon dbus && /etc/rc.d/dbus start
-+        modprobe capability &> /dev/null
-         stat_busy "Starting $DESC"
-         $DAEMON -D > /dev/null 2>&1
-         if [ $? -gt 0 ]; then
diff --git a/abs/core/avahi/avahi.install b/abs/core/avahi/avahi.install
deleted file mode 100644
index 7c75c3d..0000000
--- a/abs/core/avahi/avahi.install
+++ /dev/null
@@ -1,21 +0,0 @@
-post_install() {
-  getent group avahi &>/dev/null || groupadd -r -g 84 avahi >/dev/null
-  getent passwd avahi &>/dev/null || useradd -r -u 84 -g avahi -d / -s /bin/false -c avahi avahi >/dev/null
-
-  cat <<EOF
-==> The following daemons may be added to DAEMONS in /etc/rc.conf:
-==> avahi-daemon: the mdns responder, you probably want this.
-==>               dbus needs to be running when you start it.
-==> avahi-dnsconfd: daemon used for peer-to-peer automatic dns
-==>                 configuration on dhcp-less networks.
-
-==> To use some of the client applications you will have to install python.
-==> In addition, pygtk is required for the graphical ones and
-==> twisted for avahi-bookmarks.
-EOF
-}
-
-post_remove() {
-  getent passwd avahi &>/dev/null && userdel avahi >/dev/null
-  getent group avahi &>/dev/null && groupdel avahi >/dev/null
-}
diff --git a/abs/core/avahi/install b/abs/core/avahi/install
new file mode 100644
index 0000000..7c75c3d
--- /dev/null
+++ b/abs/core/avahi/install
@@ -0,0 +1,21 @@
+post_install() {
+  getent group avahi &>/dev/null || groupadd -r -g 84 avahi >/dev/null
+  getent passwd avahi &>/dev/null || useradd -r -u 84 -g avahi -d / -s /bin/false -c avahi avahi >/dev/null
+
+  cat <<EOF
+==> The following daemons may be added to DAEMONS in /etc/rc.conf:
+==> avahi-daemon: the mdns responder, you probably want this.
+==>               dbus needs to be running when you start it.
+==> avahi-dnsconfd: daemon used for peer-to-peer automatic dns
+==>                 configuration on dhcp-less networks.
+
+==> To use some of the client applications you will have to install python.
+==> In addition, pygtk is required for the graphical ones and
+==> twisted for avahi-bookmarks.
+EOF
+}
+
+post_remove() {
+  getent passwd avahi &>/dev/null && userdel avahi >/dev/null
+  getent group avahi &>/dev/null && groupdel avahi >/dev/null
+}
diff --git a/abs/core/avahi/introspection.patch b/abs/core/avahi/introspection.patch
deleted file mode 100644
index 88a7a73..0000000
--- a/abs/core/avahi/introspection.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -aur avahi-0.6.27/avahi-gobject/AvahiCore-0.6.gir avahi-0.6.27-introspection/avahi-gobject/AvahiCore-0.6.gir
---- avahi-0.6.27/avahi-gobject/AvahiCore-0.6.gir	2010-06-27 02:38:43.018291433 +0200
-+++ avahi-0.6.27-introspection/avahi-gobject/AvahiCore-0.6.gir	2010-09-30 16:16:41.260000339 +0200
-@@ -1,10 +1,12 @@
- <?xml version="1.0"?>
--<repository version="1.0"
-+<repository version="1.2"
-             xmlns="http://www.gtk.org/introspection/core/1.0"
-             xmlns:c="http://www.gtk.org/introspection/c/1.0"
-             xmlns:glib="http://www.gtk.org/introspection/glib/1.0">
-   <namespace name="AvahiCore" version="0.6" shared-library="avahi-core">
--    <alias name="IfIndex" target="int" c:type="AvahiIfIndex"/>
-+    <alias name="IfIndex" target="int">
-+      <type name="AvahiIfIndex" c:type="AvahiIfIndex"/>
-+    </alias>
-     <enumeration name="Protocol" c:type="AvahiProtocol">
-       <member name="inet"
-               value="0"
diff --git a/abs/core/avahi/rc.d.patch b/abs/core/avahi/rc.d.patch
new file mode 100644
index 0000000..fd73573
--- /dev/null
+++ b/abs/core/avahi/rc.d.patch
@@ -0,0 +1,11 @@
+diff -aur old/initscript/archlinux/avahi-daemon.in new/initscript/archlinux/avahi-daemon.in
+--- old/initscript/archlinux/avahi-daemon.in	2011-06-24 03:07:00.916170590 +0200
++++ new/initscript/archlinux/avahi-daemon.in	2011-06-24 03:16:32.220596377 +0200
+@@ -33,6 +33,7 @@
+ 
+ case "$1" in
+     start)
++        ck_daemon dbus && { echo -n "Start dbus first." >&2; stat_die; }
+         stat_busy "Starting $DESC"
+         $DAEMON -D > /dev/null 2>&1
+         if [ $? -gt 0 ]; then
-- 
cgit v0.12