From 13c5a3d4c1d8e6fd299222a5b12a1c31bf3ccd28 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Wed, 3 Feb 2010 18:25:22 -0600
Subject: pacman: update to 3.3.3 This was needed for the new samba.

---
 abs/core-testing/pacman/PKGBUILD       |  42 ++++++++++---
 abs/core-testing/pacman/makepkg.conf   | 107 +++++++++++++++++++++++++++++++++
 abs/core-testing/pacman/pacman.conf    |  13 ++--
 abs/core-testing/pacman/pacman.install |  15 ++---
 4 files changed, 157 insertions(+), 20 deletions(-)
 create mode 100644 abs/core-testing/pacman/makepkg.conf

diff --git a/abs/core-testing/pacman/PKGBUILD b/abs/core-testing/pacman/PKGBUILD
index ecb96c7..239abb8 100644
--- a/abs/core-testing/pacman/PKGBUILD
+++ b/abs/core-testing/pacman/PKGBUILD
@@ -1,36 +1,60 @@
-# $Id: PKGBUILD 23245 2009-01-07 02:10:32Z dan $
+# $Id: PKGBUILD 58635 2009-11-11 00:00:52Z dan $
 # Maintainer: Aaron Griffin <aaron@archlinux.org>
 # Maintainer: Dan McGee <dan@archlinux.org>
 
 pkgname=pacman
-pkgver=3.2.2
-pkgrel=1
+pkgver=3.3.3
+pkgrel=10
 pkgdesc="A library-based package manager with dependency support"
 arch=('i686' 'x86_64')
 url="http://www.archlinux.org/pacman/"
 license=('GPL')
 groups=('base')
-depends=('bash' 'libarchive>=2.6.0' 'libdownload>=1.3' 'pacman-mirrorlist')
+depends=('bash' 'libarchive>=2.7.1' 'libfetch>=2.25' 'pacman-mirrorlist')
 optdepends=('fakeroot: for makepkg usage as normal user'
             'python: for rankmirrors script usage')
-backup=(etc/pacman.conf etc/makepkg.conf etc/pacman.d/mirrorlist)
+backup=(etc/pacman.conf etc/makepkg.conf)
 install=pacman.install
 options=(!libtool)
 source=(ftp://ftp.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz
-        pacman.conf)
-md5sums=('8404fc38566bb52f8eee2ea483a41051'
-         '27271a59b9c9f748547ef4feae90bc5c')
+        pacman.conf
+        makepkg.conf)
+md5sums=('a8cef73d68e2a4c3a46fb46c33210719'
+         'abe70dabacee7036368c7afeb686eb10'
+         '52c7bc651b107d73f9902755b7594458')
 
 build() {
   cd $srcdir/$pkgname-$pkgver
   
   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
   make || return 1
+}
+
+package() {
+  cd $srcdir/$pkgname-$pkgver
   make DESTDIR=$pkgdir install || return 1
 
-  # install arch specific stuff
+  # install Arch specific stuff
   mkdir -p $pkgdir/etc
   install -m644 $srcdir/pacman.conf $pkgdir/etc/
+  install -m644 $srcdir/makepkg.conf $pkgdir/etc/
+  # set things correctly in the default conf file
+  case "$CARCH" in
+    i686)
+      mycarch="i686"
+      mychost="i686-pc-linux-gnu"
+      myflags="-march=i686 "
+      ;;
+    x86_64)
+      mycarch="x86_64"
+      mychost="x86_64-unknown-linux-gnu"
+      myflags="-march=x86-64 "
+      ;;
+  esac
+  sed -i $pkgdir/etc/makepkg.conf \
+    -e "s|@CARCH[@]|$mycarch|g" \
+    -e "s|@CHOST[@]|$mychost|g" \
+    -e "s|@CARCHFLAGS[@]|$myflags|g"
 
   # install completion files
   mkdir -p $pkgdir/etc/bash_completion.d/
diff --git a/abs/core-testing/pacman/makepkg.conf b/abs/core-testing/pacman/makepkg.conf
new file mode 100644
index 0000000..12cfebd
--- /dev/null
+++ b/abs/core-testing/pacman/makepkg.conf
@@ -0,0 +1,107 @@
+#
+# /etc/makepkg.conf
+#
+
+#########################################################################
+# SOURCE ACQUISITION
+#########################################################################
+#
+#-- The download utilities that makepkg should use to acquire sources
+#  Format: 'protocol::agent'
+DLAGENTS=('ftp::/usr/bin/wget -c --passive-ftp -t 3 --waitretry=3 -O %o %u'
+          'http::/usr/bin/wget -c -t 3 --waitretry=3 -O %o %u'
+          'https::/usr/bin/wget -c -t 3 --waitretry=3 --no-check-certificate -O %o %u'
+          'rsync::/usr/bin/rsync -z %u %o'
+          'scp::/usr/bin/scp -C %u %o')
+
+# Other common tools:
+# /usr/bin/snarf
+# /usr/bin/lftpget -c
+# /usr/bin/curl
+
+#########################################################################
+# ARCHITECTURE, COMPILE FLAGS
+#########################################################################
+#
+CARCH="@CARCH@"
+CHOST="@CHOST@"
+
+#-- Exclusive: will only run on @CARCH@
+# -march (or -mcpu) builds exclusively for an architecture
+# -mtune optimizes for an architecture, but builds for whole processor family
+CFLAGS="@CARCHFLAGS@-mtune=generic -O2 -pipe"
+CXXFLAGS="@CARCHFLAGS@-mtune=generic -O2 -pipe"
+LDFLAGS="-Wl,--hash-style=gnu -Wl,--as-needed"
+#-- Make Flags: change this for DistCC/SMP systems
+#MAKEFLAGS="-j2"
+
+#########################################################################
+# BUILD ENVIRONMENT
+#########################################################################
+#
+# Defaults: BUILDENV=(fakeroot !distcc color !ccache)
+#  A negated environment option will do the opposite of the comments below.
+#
+#-- fakeroot: Allow building packages as a non-root user
+#-- distcc:   Use the Distributed C/C++/ObjC compiler
+#-- color:    Colorize output messages
+#-- ccache:   Use ccache to cache compilation
+#
+BUILDENV=(fakeroot !distcc color !ccache)
+#
+#-- If using DistCC, your MAKEFLAGS will also need modification. In addition,
+#-- specify a space-delimited list of hosts running in the DistCC cluster.
+#DISTCC_HOSTS=""
+
+#########################################################################
+# GLOBAL PACKAGE OPTIONS
+#   These are default values for the options=() settings
+#########################################################################
+#
+# Default: OPTIONS=(strip docs libtool emptydirs zipman purge)
+#  A negated option will do the opposite of the comments below.
+#
+#-- strip:     Strip symbols from binaries/libraries in STRIP_DIRS
+#-- docs:      Save doc directories specified by DOC_DIRS
+#-- libtool:   Leave libtool (.la) files in packages
+#-- emptydirs: Leave empty directories in packages
+#-- zipman:    Compress manual (man and info) pages in MAN_DIRS with gzip
+#-- purge:     Remove files specified by PURGE_TARGETS
+#
+OPTIONS=(strip docs libtool emptydirs zipman purge)
+
+#-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
+INTEGRITY_CHECK=(md5)
+#-- Manual (man and info) directories to compress (if zipman is specified)
+MAN_DIRS=({usr{,/local}{,/share},opt/*}/{man,info})
+#-- Doc directories to remove (if !docs is specified)
+DOC_DIRS=(usr/{,local/}{,share/}{doc,gtk-doc} opt/*/{doc,gtk-doc})
+#-- Directories to be searched for the strip option (if strip is specified)
+STRIP_DIRS=(bin lib sbin usr/{bin,lib,sbin,local/{bin,lib,sbin}} opt/*/{bin,lib,sbin})
+#-- Files to be removed from all packages (if purge is specified)
+PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
+
+#########################################################################
+# PACKAGE OUTPUT
+#########################################################################
+#
+# Default: put built package and cached source in build directory
+#
+#-- Destination: specify a fixed directory where all packages will be placed
+#PKGDEST=/home/packages
+#-- Source cache: specify a fixed directory where source files will be cached
+#SRCDEST=/home/sources
+#-- Packager: name/email of the person or organization building packages
+#PACKAGER="John Doe <john@doe.com>"
+
+#########################################################################
+# EXTENSION DEFAULTS
+#########################################################################
+#
+# WARNING: Do NOT modify these variables unless you know what you are
+#          doing.
+#
+PKGEXT='.pkg.tar.gz'
+SRCEXT='.src.tar.gz'
+
+# vim: set ft=sh ts=2 sw=2 et:
diff --git a/abs/core-testing/pacman/pacman.conf b/abs/core-testing/pacman/pacman.conf
index 6fe3d29..de7e17d 100644
--- a/abs/core-testing/pacman/pacman.conf
+++ b/abs/core-testing/pacman/pacman.conf
@@ -28,7 +28,6 @@ SyncFirst   = pacman
 #NoExtract   =
 
 # Misc options (all disabled by default)
-#NoPassiveFtp
 #UseSyslog
 #ShowSize
 #UseDelta
@@ -52,10 +51,12 @@ SyncFirst   = pacman
 # uncommented to enable the repo.
 #
 
-# Testing is disabled by default.  To enable, uncomment the following
-# two lines.  You can add preferred servers immediately after the header,
-# and they will be used before the default mirrors.
+# The testing repositories are disabled by default. To enable, uncomment the
+# repo name header and Include lines. You can add preferred servers immediately
+# after the header, and they will be used before the default mirrors.
+
 #[testing]
+## Add your preferred servers here, they will be used first
 #Include = /etc/pacman.d/mirrorlist
 
 [core]
@@ -66,6 +67,10 @@ Include = /etc/pacman.d/mirrorlist
 # Add your preferred servers here, they will be used first
 Include = /etc/pacman.d/mirrorlist
 
+#[community-testing]
+## Add your preferred servers here, they will be used first
+#Include = /etc/pacman.d/mirrorlist
+
 [community]
 # Add your preferred servers here, they will be used first
 Include = /etc/pacman.d/mirrorlist
diff --git a/abs/core-testing/pacman/pacman.install b/abs/core-testing/pacman/pacman.install
index 46e4763..ed10f0d 100644
--- a/abs/core-testing/pacman/pacman.install
+++ b/abs/core-testing/pacman/pacman.install
@@ -1,10 +1,15 @@
+#!/bin/sh
 # arg 1:  the new package version
 # arg 2:  the old package version
 post_upgrade() {
 	# one time stuff for md5sum issue with older pacman versions
-	if [ "$(vercmp $2 3.0.2)" -lt 0 ]; then
-		_resetbackups
-	fi
+	if [  -f /usr/bin/vercmp ]
+	then
+		if  [ "$(vercmp $2 3.0.2)" -lt 0 ]
+		then
+        	 	_resetbackups
+		fi
+	fi	
 }
 
 _resetbackups() {
@@ -50,7 +55,3 @@ _resetbackups() {
         fi
     done
 }
-
-op=$1
-shift
-$op $*
-- 
cgit v0.12