From 50ea25a17ac72da857c9ca47118b4853216a630b Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Mon, 5 Oct 2015 22:21:46 +0000
Subject: xymon: hobbit_notify.sh: don't show memory criticals on OSD

---
 abs/core/xymon/PKGBUILD         |  4 ++--
 abs/core/xymon/hobbit_notify.sh | 14 +++++++++-----
 2 files changed, 11 insertions(+), 7 deletions(-)

diff --git a/abs/core/xymon/PKGBUILD b/abs/core/xymon/PKGBUILD
index b56c668..7197a24 100755
--- a/abs/core/xymon/PKGBUILD
+++ b/abs/core/xymon/PKGBUILD
@@ -1,7 +1,7 @@
 pkgbase=xymon
 pkgname=('xymonserver' 'xymonclient')
 pkgver=4.3.17
-pkgrel=19
+pkgrel=20
 pkgdesc="Xymon is a system for monitoring of hosts and networks"
 license="GPL"
 arch=('i686' 'x86_64')
@@ -176,7 +176,7 @@ md5sums=('d8d119a777e7b7204d1292fb27314312'
          '0c808fa12672289f86b0651545381308'
          '0469d775db9fdd18ea95dd41937ada82'
          '0757294eec13771f8e63da23cf066796'
-         '3126ef4e5e82f096cf5ecb4dce4e2306'
+         'b1d5592fa92ef71303621964e84c2b9e'
          '22d4c9065fd959efe82f121dcb511305'
          '9af2ad60ac4c3cb653754618f603e311'
          '313b11e7a22c3c08fb2afaadbfb46d87'
diff --git a/abs/core/xymon/hobbit_notify.sh b/abs/core/xymon/hobbit_notify.sh
index 9028fb0..39e4d43 100644
--- a/abs/core/xymon/hobbit_notify.sh
+++ b/abs/core/xymon/hobbit_notify.sh
@@ -66,19 +66,23 @@ case x$BBSVCNAME in
         yellow )
             msg_func_out "A disk on $BBHOSTNAME is almost full"
             ;;
-    esac
-    ;;
+  esac
+  ;;
+
+  xmemory)
+    #do nothing for memory
+  ;;
 
-   xfunc)
+  xfunc)
         if [ "x$hostname" = "x$BBHOSTNAME" ]
         then
-            msg_local_out "System can not communicate with itself (func) |alert"
+            msg_local_out "System can not communicate with itself (func)|alert"
         else
             msg_func_out "$hostname can not communicate with $BBHOSTNAME (func)|alert"
         fi
     ;;
 
- *)
+  *)
     #catch all for everything else
     msg_func_out "Condition $BBCOLORLEVEL $BBSVCNAME on $BBHOSTNAME\nSee the system health webpage.|alert"
     ;;
-- 
cgit v0.12