From ba384708e928b18cfa3b3dd648cee3194b266fcb Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Sun, 30 Jan 2011 21:22:29 -0800
Subject: dconf:initial inclusion. Dep of gnome-keyring.

---
 abs/extra/dconf/PKGBUILD      | 26 ++++++++++++++++++++++++++
 abs/extra/dconf/dconf.install | 11 +++++++++++
 2 files changed, 37 insertions(+)
 create mode 100644 abs/extra/dconf/PKGBUILD
 create mode 100644 abs/extra/dconf/dconf.install

diff --git a/abs/extra/dconf/PKGBUILD b/abs/extra/dconf/PKGBUILD
new file mode 100644
index 0000000..4d95f6b
--- /dev/null
+++ b/abs/extra/dconf/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id:
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+pkgname=dconf
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="A low-level configuration system."
+arch=(i686 x86_64)
+url="http://live.gnome.org/dconf"
+license=('LGPL2.1')
+depends=('glib2>=2.25.17')
+makedepends=('vala' 'gobject-introspection' 'gtk2')
+optdepends=('gtk2: for dconf-editor')
+install=dconf.install
+source=(http://download.gnome.org/sources/${pkgname}/0.5/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('0083d70e1b5e540d8d4b3f04fa5d17dff4c574136682fe3bdd9b5ecc196ec4f6')
+
+build() {
+  cd "$srcdir/$pkgname-$pkgver"
+
+  ./configure --prefix=/usr \
+    --libexecdir=/usr/lib/dconf
+  make
+  make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/dconf/dconf.install b/abs/extra/dconf/dconf.install
new file mode 100644
index 0000000..5a87df8
--- /dev/null
+++ b/abs/extra/dconf/dconf.install
@@ -0,0 +1,11 @@
+post_install() {
+    usr/bin/gio-querymodules usr/lib/gio/modules
+}
+
+post_upgrade(){
+    post_install
+}
+
+post_remove() {
+    post_install
+}
-- 
cgit v0.12