From f2394fa3f2984a3a4e74a19b2596f279ec3517ba Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Thu, 26 Apr 2012 14:37:18 -0700
Subject: sapphire:Bumped to latest version 3.5.

---
 abs/extra/sapphire/PKGBUILD | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/abs/extra/sapphire/PKGBUILD b/abs/extra/sapphire/PKGBUILD
index f6d872b..c82d2ab 100644
--- a/abs/extra/sapphire/PKGBUILD
+++ b/abs/extra/sapphire/PKGBUILD
@@ -2,7 +2,7 @@
 
 pkgname=sapphire
 _kernver=`uname -r`
-pkgver=3.4
+pkgver=3.5
 pkgrel=1
 pkgdesc="Kernel module for Sapphire remote"
 arch=('i686' 'x86_64')
@@ -30,5 +30,5 @@ package() {
   install -m 644 keymap.default ${pkgdir}/usr/share/doc/sapphire
   rm -fr ${pkgdir}/lib/modules/$_kernver/modules*
 }
-md5sums=('da5243f914aa3cecb8821dd12fe85933'
+md5sums=('b1c97f4328810f2dfbd6d8721d5950c5'
          '90fcf01a3b96eb49a69d20bca74167a2')
-- 
cgit v0.12


From 710498de3e1a0d6870e7461ca5a65415b1ea5398 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Thu, 26 Apr 2012 21:13:29 -0700
Subject: dolphin-emu:Version 3.0, initial inclusion.

---
 abs/extra/community/dolphin-emu/Dolphin_Logo.png   | Bin 0 -> 62052 bytes
 abs/extra/community/dolphin-emu/PKGBUILD           |  75 +++++++++++++++++++++
 .../community/dolphin-emu/dolphin-emu.desktop      |  11 +++
 abs/extra/community/dolphin-emu/unistd.diff        |  11 +++
 4 files changed, 97 insertions(+)
 create mode 100644 abs/extra/community/dolphin-emu/Dolphin_Logo.png
 create mode 100644 abs/extra/community/dolphin-emu/PKGBUILD
 create mode 100644 abs/extra/community/dolphin-emu/dolphin-emu.desktop
 create mode 100644 abs/extra/community/dolphin-emu/unistd.diff

diff --git a/abs/extra/community/dolphin-emu/Dolphin_Logo.png b/abs/extra/community/dolphin-emu/Dolphin_Logo.png
new file mode 100644
index 0000000..63450da
Binary files /dev/null and b/abs/extra/community/dolphin-emu/Dolphin_Logo.png differ
diff --git a/abs/extra/community/dolphin-emu/PKGBUILD b/abs/extra/community/dolphin-emu/PKGBUILD
new file mode 100644
index 0000000..a617981
--- /dev/null
+++ b/abs/extra/community/dolphin-emu/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: schuay <jakob.gruber@gmail.com>
+# Contributor: Jeremy Newton (Mystro256)
+# Special thanks to the contributors of dolphin-emu-svn: for the icon, desktop file and some lines from the PKGBUILD
+# Thanks to all that contributed! :)
+
+pkgname=dolphin-emu
+pkgver=3.0
+pkgrel=9
+epoch=1
+pkgdesc="A GameCube and Wii emulator (stable git branch)"
+arch=('i686' 'x86_64')
+url="http://www.dolphin-emulator.com/"
+license=('GPL2')
+
+makedepends=('git' 'cmake' 'glproto' 'opencl-headers')
+depends=('sdl' 'libxxf86vm' 'libao' 'wxgtk' 'wiiuse' 'nvidia-cg-toolkit' \
+         'glew' 'mesa' 'libgl' 'openal' 'portaudio' 'lzo2')
+
+# Cannot be BUILT with sfml later than 1.6
+# IF YOU NEED SFML>=1.7 FOR SOMETHING ELSE, TRY REMOVING THE CONFLICT
+# BELOW AND ONLY TEMPORARY UNINSTALLING SFML TO BUILD/INSTALL DOLPHIN
+conflicts=('dolphin-emu-git' 'sfml>=1.7' 'sfml-git')
+
+source=('dolphin-emu.desktop'
+        'unistd.diff'
+        'Dolphin_Logo.png')
+
+_gitroot=https://code.google.com/p/dolphin-emu/
+_gitname=dolphin-emu-3.0
+
+build() {
+  cd "$srcdir"
+  msg "Connecting to GIT server...."
+
+  if [[ -d "$_gitname" ]]; then
+    cd "$_gitname" && git pull origin 3.0
+    msg "The local files are updated."
+  else
+    git clone "$_gitroot" "$_gitname"
+  fi
+
+  msg "GIT checkout done or server timeout"
+  msg "Starting build..."
+
+  rm -rf "$srcdir/$_gitname-build"
+  git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+  cd "$srcdir/$_gitname-build"
+
+  msg "Checking out at stable 3.0 branch"
+  git checkout 3.0
+
+  msg "GIT checkout done or server timeout"
+
+  patch -Np2 < ${srcdir}/unistd.diff
+
+  mkdir build && cd build
+  export CXXFLAGS="$CXXFLAGS -fpermissive"
+  cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+  make
+}
+
+package() {
+  cd "${srcdir}/dolphin-emu-3.0-build/build"
+
+  make DESTDIR=${pkgdir} install
+
+  install -Dm644 "${srcdir}/dolphin-emu.desktop" "${pkgdir}/usr/share/applications/dolphin-emu.desktop"
+  install -Dm644 "${srcdir}/Dolphin_Logo.png" "${pkgdir}/usr/share/pixmaps/dolphin-emu.png"
+}
+
+# vim:set ts=2 sw=2 et:
+
+md5sums=('feed4580c2e6bfbc7f6c67dad861daae'
+         'a463b96d02462b5f6b0894f6ced821ab'
+         'd15c51f547b4bd47e510faac40bcc9d6')
diff --git a/abs/extra/community/dolphin-emu/dolphin-emu.desktop b/abs/extra/community/dolphin-emu/dolphin-emu.desktop
new file mode 100644
index 0000000..96317d1
--- /dev/null
+++ b/abs/extra/community/dolphin-emu/dolphin-emu.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Dolphin
+Categories=Game;Emulator;GTK;
+GenericName=GameCube and Wii Emulator
+Comment=An emulator for the GameCube and Wii consoles
+Exec=dolphin-emu
+Icon=dolphin-emu
+StartupNotify=false
+Name[en_US]=Dolphin
diff --git a/abs/extra/community/dolphin-emu/unistd.diff b/abs/extra/community/dolphin-emu/unistd.diff
new file mode 100644
index 0000000..2b39063
--- /dev/null
+++ b/abs/extra/community/dolphin-emu/unistd.diff
@@ -0,0 +1,11 @@
+--- src/dolphin-emu-3.0/Source/Core/Common/Src/CommonFuncs.h	2012-04-07 10:47:47.595151504 +0200
++++ src/dolphin-emu-3.0-build/Source/Core/Common/Src/CommonFuncs.h	2012-04-07 10:53:25.371113081 +0200
+@@ -18,6 +18,8 @@
+ #ifndef _COMMONFUNCS_H_
+ #define _COMMONFUNCS_H_
+ 
++#include <unistd.h>
++
+ #ifdef _WIN32
+ #define SLEEP(x) Sleep(x)
+ #else
-- 
cgit v0.12


From 4e861967375fbfd817baf86c52863ebf72d5b3ea Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Thu, 26 Apr 2012 21:13:59 -0700
Subject: nvidia-cg-toolkit:initial inclusion, dep of dolphin-emu.

---
 abs/extra/community/nvidia-cg-toolkit/PKGBUILD | 37 ++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
 create mode 100644 abs/extra/community/nvidia-cg-toolkit/PKGBUILD

diff --git a/abs/extra/community/nvidia-cg-toolkit/PKGBUILD b/abs/extra/community/nvidia-cg-toolkit/PKGBUILD
new file mode 100644
index 0000000..c3f896e
--- /dev/null
+++ b/abs/extra/community/nvidia-cg-toolkit/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id: PKGBUILD 64721 2012-02-18 02:42:09Z svenstaro $
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Adam Griffiths 
+# Contributor: Nick B <Shirakawasuna at gmail _dot_ com>
+pkgname=nvidia-cg-toolkit 
+pkgver=3.1
+_date="February2012"
+pkgrel=1
+pkgdesc="NVIDIA Cg libraries" 
+arch=('i686' 'x86_64')
+url="http://developer.nvidia.com/object/cg_toolkit.html" 
+license=('custom')
+depends=('glibc' 'mesa') 
+source=(http://developer.download.nvidia.com/cg/Cg_${pkgver}/Cg-${pkgver}_${_date}_${CARCH/i686/x86}.tgz)
+[ "$CARCH" = "i686" ] &&
+md5sums=('af5a3bd72b213b20bf33cf104c83012d')
+[ "$CARCH" = "x86_64" ] && 
+md5sums=('d50dc4e6c68bb93ccfd1a66c139dd6eb')
+
+build() {
+  return 0
+}
+
+package() { 
+  install -Dm755 ${srcdir}/usr/bin/cgc ${pkgdir}/usr/bin/cgc
+  install -dm755 ${pkgdir}/usr/include/Cg
+  install -m644 ${srcdir}/usr/include/Cg/* ${pkgdir}/usr/include/Cg
+  install -dm755 ${pkgdir}/usr/lib
+  [ "$CARCH" = "i686" ] && install -m644 ${srcdir}/usr/lib/* ${pkgdir}/usr/lib
+  [ "$CARCH" = "x86_64" ] && install -m644 ${srcdir}/usr/lib64/* ${pkgdir}/usr/lib
+  install -Dm644 ${srcdir}/usr//local/Cg/docs/license.txt ${pkgdir}/usr/share/licenses/nvidia-cg-toolkit/license.txt
+  cp -r ${srcdir}/usr/local/Cg ${pkgdir}/usr/share/
+  find $pkgdir/usr/share/ -type d -exec chmod -R 755 '{}' ';'
+  find $pkgdir/usr/share/ -type f -exec chmod -R 644 '{}' ';'
+}
+
+# vim: sw=2:ts=2 et:
-- 
cgit v0.12


From 7191fd41fade855ead562d652367e3841e1df04b Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Thu, 26 Apr 2012 21:14:14 -0700
Subject: openal:initial inclusion, dep of dolphin-emu.

---
 abs/extra/community/openal/PKGBUILD    | 29 +++++++++++++++++++++++++++++
 abs/extra/community/openal/__changelog |  2 ++
 2 files changed, 31 insertions(+)
 create mode 100644 abs/extra/community/openal/PKGBUILD
 create mode 100644 abs/extra/community/openal/__changelog

diff --git a/abs/extra/community/openal/PKGBUILD b/abs/extra/community/openal/PKGBUILD
new file mode 100644
index 0000000..6d6c669
--- /dev/null
+++ b/abs/extra/community/openal/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 149424 2012-02-07 16:51:11Z heftig $
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributer: Jason Chu <jchu@xentac.net>
+
+pkgname=openal
+pkgver=1.13
+pkgrel=4
+pkgdesc="A cross-platform 3D audio library"
+arch=(i686 x86_64)
+url="http://www.openal.org/"
+license=(LGPL)
+depends=(glibc)
+makedepends=(alsa-lib sdl pkgconfig cmake)
+options=('!libtool')
+source=(http://kcat.strangesoft.net/openal-releases/openal-soft-$pkgver.tar.bz2)
+md5sums=('58b7d2809790c70681b825644c5f3614')
+
+build() {
+  cd "$srcdir/$pkgname-soft-$pkgver/build"
+  cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release ..
+  make
+}
+
+package() {
+  cd "$srcdir/$pkgname-soft-$pkgver"
+  make -C build DESTDIR="$pkgdir/" install
+  install -Dm644 alsoftrc.sample "$pkgdir/etc/openal/alsoft.conf.sample"
+}
diff --git a/abs/extra/community/openal/__changelog b/abs/extra/community/openal/__changelog
new file mode 100644
index 0000000..7f47556
--- /dev/null
+++ b/abs/extra/community/openal/__changelog
@@ -0,0 +1,2 @@
+4/25/12 - chw - 
+Removed libpulse as a dep.
-- 
cgit v0.12


From ddd3cca11c55e087b67c54bb53ea8d4d0180c7ea Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Thu, 26 Apr 2012 21:14:26 -0700
Subject: opencl-headers:initial inclusion, dep of dolphin-emu.

---
 abs/extra/community/opencl-headers/LICENSE.txt | 20 ++++++++++
 abs/extra/community/opencl-headers/PKGBUILD    | 53 ++++++++++++++++++++++++++
 2 files changed, 73 insertions(+)
 create mode 100644 abs/extra/community/opencl-headers/LICENSE.txt
 create mode 100644 abs/extra/community/opencl-headers/PKGBUILD

diff --git a/abs/extra/community/opencl-headers/LICENSE.txt b/abs/extra/community/opencl-headers/LICENSE.txt
new file mode 100644
index 0000000..a89e4f5
--- /dev/null
+++ b/abs/extra/community/opencl-headers/LICENSE.txt
@@ -0,0 +1,20 @@
+ * Copyright (c) 2008-2010 The Khronos Group Inc.
+ *
+ * Permission is hereby granted, free of charge, to any person obtaining a
+ * copy of this software and/or associated documentation files (the
+ * "Materials"), to deal in the Materials without restriction, including
+ * without limitation the rights to use, copy, modify, merge, publish,
+ * distribute, sublicense, and/or sell copies of the Materials, and to
+ * permit persons to whom the Materials are furnished to do so, subject to
+ * the following conditions:
+ *
+ * The above copyright notice and this permission notice shall be included
+ * in all copies or substantial portions of the Materials.
+ *
+ * THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+ * IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+ * CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+ * TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ * MATERIALS OR THE USE OR OTHER DEALINGS IN THE MATERIALS.
diff --git a/abs/extra/community/opencl-headers/PKGBUILD b/abs/extra/community/opencl-headers/PKGBUILD
new file mode 100644
index 0000000..0a21ce2
--- /dev/null
+++ b/abs/extra/community/opencl-headers/PKGBUILD
@@ -0,0 +1,53 @@
+# $Id: PKGBUILD 60629 2011-12-15 19:18:50Z stephane $
+# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Sylvain HENRY <hsyl20@yahoo.fr>
+
+pkgname=opencl-headers
+pkgver=1.1.20110526
+_clbasever=1.1
+pkgrel=1
+epoch=1
+pkgdesc='OpenCL (Open Computing Language) header files'
+arch=('any')
+url='http://www.khronos.org/registry/cl/'
+license=('custom')
+optdepends=('libcl: OpenCL library')
+source=("ftp://ftp.archlinux.org/other/community/${pkgname}/${pkgname}-${pkgver}.src.tar.xz"
+        'LICENSE.txt')
+_headers=("http://www.khronos.org/registry/cl/api/${_clbasever}/cl_ext.h"
+          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl_gl_ext.h"
+          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl_gl.h"
+          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl.h"
+          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl.hpp"
+          "http://www.khronos.org/registry/cl/api/${_clbasever}/cl_platform.h"
+          "http://www.khronos.org/registry/cl/api/${_clbasever}/opencl.h")
+sha1sums=('b9deedbae4f87fa0987ca7b2347f68d608284a02'
+          '98abb35b2eca82d0fc19db6d28fcc7bd20be0655')
+
+# source PKGBUILD && mksource
+mksource() {
+   cd "${srcdir}"
+   _dirname=${pkgname}-${pkgver}
+   mkdir ${_dirname}
+
+   pushd ${_dirname}
+   for _h in ${_headers[@]}; do
+      wget ${_h}
+   done
+   popd
+
+   tar -cJv --exclude=CVS -f ${_dirname}.src.tar.xz ${_dirname}
+   rm -rf ${_dirname}
+}
+
+package() {
+   cd "${srcdir}/${pkgname}-${pkgver}"
+
+   install -dm755 "${pkgdir}"/usr/include/CL
+
+   for h in $(ls -1 *.h *.hpp); do
+      install -m 644 ${h} "${pkgdir}"/usr/include/CL/
+   done
+
+   install -D -m644 ../LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
-- 
cgit v0.12


From 78fb16866e4942bffa2d7db2c28a4d422236de0a Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Thu, 26 Apr 2012 21:14:34 -0700
Subject: portaudio:initial inclusion, dep of dolphin-emu.

---
 abs/extra/community/portaudio/PKGBUILD | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
 create mode 100644 abs/extra/community/portaudio/PKGBUILD

diff --git a/abs/extra/community/portaudio/PKGBUILD b/abs/extra/community/portaudio/PKGBUILD
new file mode 100644
index 0000000..1872b94
--- /dev/null
+++ b/abs/extra/community/portaudio/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 55258 2011-09-07 18:41:32Z ebelanger $
+# Based on 'portaudio' package - Eric Belanger <eric@archlinux.org>
+# Last/Most-Recent Contributor: Darwin Bautista <djclue917@gmail.com>
+# Maintainer: Bob Finch <w9ya@qrparci.net>
+
+pkgname=portaudio
+pkgver=19_20110326
+pkgrel=1
+pkgdesc="A free, cross-platform, open source, audio I/O library"
+arch=('i686' 'x86_64')
+url="http://www.portaudio.com/"
+license=('custom')
+depends=('jack')
+options=('!libtool')
+source=(http://www.portaudio.com/archives/pa_stable_v$pkgver.tgz)
+md5sums=('8f266ce03638419ef46e4efcb0fabde6')
+
+build() {
+  cd "$srcdir/$pkgname"
+  ./configure --prefix=/usr
+  make
+}
+
+package() {
+  cd "$srcdir/$pkgname"
+  make DESTDIR="$pkgdir" install
+  install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}
-- 
cgit v0.12