From 2c8209bf248d4c68d60a189919db9c29d5eceae7 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Wed, 23 Jun 2010 16:55:32 -0500
Subject: mythappletrailers: Update loading.sh to use osd_cat.cfg

---
 abs/extra-testing/mythappletrailers/PKGBUILD   |  7 ++++++-
 abs/extra-testing/mythappletrailers/loading.sh | 12 +++++++++++-
 2 files changed, 17 insertions(+), 2 deletions(-)

diff --git a/abs/extra-testing/mythappletrailers/PKGBUILD b/abs/extra-testing/mythappletrailers/PKGBUILD
index 0c65c73..c8399fc 100644
--- a/abs/extra-testing/mythappletrailers/PKGBUILD
+++ b/abs/extra-testing/mythappletrailers/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=mythappletrailers
 pkgver=0.04.3
-pkgrel=39
+pkgrel=40
 pkgdesc="Unofficial Add-on for MythTV to get Apple.com Movie Trailers."
 arch=('i686' 'x86_64')
 license=('GPL2')
@@ -28,3 +28,8 @@ build() {
   cp trailers $startdir/pkg/etc/cron.daily/
   install -m755 $srcdir/fix_aple_url.sh $pkgdir/usr/bin
 }
+md5sums=('336e68953d0e1e8a0c7a4990f8d43a2b'
+         'c7da92600afe2a3b1f564764500315a0'
+         '5fdd4aa17b9c1e77b272437ae42a1827'
+         'ece3c5f8a605b6e2270c6f7671705631'
+         'a2349f844e47fd95a672739177ca44ff')
diff --git a/abs/extra-testing/mythappletrailers/loading.sh b/abs/extra-testing/mythappletrailers/loading.sh
index d1ef680..e4e85fc 100755
--- a/abs/extra-testing/mythappletrailers/loading.sh
+++ b/abs/extra-testing/mythappletrailers/loading.sh
@@ -1,2 +1,12 @@
 #!/bin/bash
-echo -e "Loading . . . " | osd_cat -p middle -s 5 -f"-adobe-courier-bold-*-*-*-34-*-*-*-*-*" -d 10 -A centre
+
+. /etc/osd_cat.cfg || {
+    color=yellow
+    outline=2
+    outlinecolour=black
+    shadow=0
+    shadowcolour=black
+    font="-adobe-helvetica-bold-*-*-*-34-*-*-*-*-*-*-*"
+}
+
+echo -e "Loading . . . " | osd_cat --pos=middle --align=center --delay=10 --color=$color --outline=$outline --outlinecolour=$outlinecolour --shadow=$shadow --shadowcolour=$shadowcolour --font=$font
-- 
cgit v0.12