From 61d3814f3177b1eb381c98aed3a74500a1972d96 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Wed, 24 Nov 2010 02:46:55 +0000
Subject: sg3_utils: upgrade

---
 abs/core/sg3_utils/PKGBUILD     | 23 +++++++++++++++--------
 abs/core/sg3_utils/stdint.patch | 22 ++++++++++++++++++++++
 2 files changed, 37 insertions(+), 8 deletions(-)
 create mode 100644 abs/core/sg3_utils/stdint.patch

diff --git a/abs/core/sg3_utils/PKGBUILD b/abs/core/sg3_utils/PKGBUILD
index 1da9b0e..6fc92a2 100644
--- a/abs/core/sg3_utils/PKGBUILD
+++ b/abs/core/sg3_utils/PKGBUILD
@@ -1,18 +1,25 @@
+#$Id: PKGBUILD 82274 2010-06-09 19:35:19Z ibiru $
+# Maintainer: Daniel Isenmann <daniel@archlinux.org>
 pkgname=sg3_utils
-pkgver=1.27
+pkgver=1.29
 pkgrel=1
 pkgdesc="Generic SCSI utilities"
-arch=(i686 x86_64)
-url="http://sg.torque.net/sg/sg3_utils.html"
+arch=('i686' 'x86_64')
+url="http://sg.danny.cz/sg/sg3_utils.html"
 license=('GPL' 'custom:BSD')
 depends=('glibc')
 options=('!libtool')
-source=(http://www.mythvantage.com/src/${pkgname}-${pkgver}.tgz)
+source=(http://sg.danny.cz/sg/p/${pkgname}-${pkgver}.tgz)
+md5sums=('17b8f2bc1b32bd036515683cc87328ea')
 
 build() {
-  cd ${startdir}/src/${pkgname}-${pkgver}
-  ./configure --prefix=/usr 
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  ./configure --prefix=/usr || return 1
   make || return 1
-  make DESTDIR=${startdir}/pkg install
-  install -D -m644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/COPYING
+}
+package() {
+  cd "${srcdir}/${pkgname}-${pkgver}"
+  make DESTDIR="${pkgdir}" install || return 1
+  install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+  install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
 }
diff --git a/abs/core/sg3_utils/stdint.patch b/abs/core/sg3_utils/stdint.patch
new file mode 100644
index 0000000..8f8c5f5
--- /dev/null
+++ b/abs/core/sg3_utils/stdint.patch
@@ -0,0 +1,22 @@
+--- include/sg_cmds_basic.h	2008/06/26 23:27:40	1.1
++++ include/sg_cmds_basic.h	2008/06/26 23:28:06
+@@ -30,6 +30,8 @@
+  *
+  */
+ 
++#include <stdint.h>
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+--- include/sg_cmds_extra.h	2008/06/26 23:27:40	1.1
++++ include/sg_cmds_extra.h	2008/06/26 23:29:02
+@@ -30,6 +30,8 @@
+  *
+  */
+ 
++#include <stdint.h>
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
-- 
cgit v0.12