From 29c799f2e3d33f5469ff15b1c6d0242dc00dd179 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 21 Apr 2016 23:19:48 +0000
Subject: grub: grub.install: regen grub on install and update

add link /boot/grub/locale/en.mo to quiet error

grub.default: change to LinHES defaults
---
 abs/core/grub/PKGBUILD     | 26 +++++++++++++-------------
 abs/core/grub/__changelog  |  5 +++--
 abs/core/grub/grub.default |  8 ++++----
 abs/core/grub/grub.install | 21 ++++++++++++++-------
 4 files changed, 34 insertions(+), 26 deletions(-)

diff --git a/abs/core/grub/PKGBUILD b/abs/core/grub/PKGBUILD
index e7daa70..6e3535f 100644
--- a/abs/core/grub/PKGBUILD
+++ b/abs/core/grub/PKGBUILD
@@ -23,12 +23,12 @@ _UNIFONT_VER="6.3.20131217"
 pkgname="grub"
 pkgdesc="GNU GRand Unified Bootloader (2)"
 pkgver=2.02.beta2
-pkgrel=6
+pkgrel=7
 epoch=1
 url="https://www.gnu.org/software/grub/"
 arch=('x86_64' 'i686')
 license=('GPL3')
-backup=('boot/grub/grub.cfg' 'etc/default/grub' 'etc/grub.d/40_custom')
+backup=('boot/grub/grub.cfg' 'etc/grub.d/40_custom')
 install="${pkgname}.install"
 options=('!makeflags')
 
@@ -65,17 +65,6 @@ source=("grub-${_pkgver}::git+git://git.sv.gnu.org/grub.git#tag=${_GRUB_GIT_TAG}
         'grub.default'
         'grub.cfg')
 
-md5sums=('SKIP'
-         'SKIP'
-         '728b7439ac733a7c0d56049adec364c7'
-         'SKIP'
-         '9589ec46a04f9bb4d5da987340a4a324'
-         '945527e0de8d384166a4cf23439ae9ee'
-         'a678629bc82c4e70c48d28242036d1d7'
-         'e506ae4a9f9f7d1b765febfa84e10d48'
-         'be55eabc102f2c60b38ed35c203686d6'
-         'a03ffd56324520393bf574cefccb893d'
-         'c8b9511586d57d6f2524ae7898397a46')
 validpgpkeys=('95D2E9AB8740D8046387FD151A09227B1F435A33')  #Paul Hardy
 
 _pkgver() {
@@ -394,3 +383,14 @@ package() {
 	_package_grub-common_and_bios
 	
 }
+md5sums=('SKIP'
+         'SKIP'
+         '728b7439ac733a7c0d56049adec364c7'
+         'SKIP'
+         '9589ec46a04f9bb4d5da987340a4a324'
+         '945527e0de8d384166a4cf23439ae9ee'
+         'a678629bc82c4e70c48d28242036d1d7'
+         'e506ae4a9f9f7d1b765febfa84e10d48'
+         'be55eabc102f2c60b38ed35c203686d6'
+         'f01fdebe88709f263ed351747971f5f5'
+         'c8b9511586d57d6f2524ae7898397a46')
diff --git a/abs/core/grub/__changelog b/abs/core/grub/__changelog
index 608798d..e7a69e6 100644
--- a/abs/core/grub/__changelog
+++ b/abs/core/grub/__changelog
@@ -1,2 +1,3 @@
-PKGBUILD:
-- change dep python to python2
+PKGBUILD: change dep python to python2
+grub.default: set to LinHES colors and timeouts
+grub.install: add /boot/grub/locale/en.mo link to quiet error
diff --git a/abs/core/grub/grub.default b/abs/core/grub/grub.default
index fdd1fc3..85c9c8d 100644
--- a/abs/core/grub/grub.default
+++ b/abs/core/grub/grub.default
@@ -1,5 +1,5 @@
 GRUB_DEFAULT=0
-GRUB_TIMEOUT=5
+GRUB_TIMEOUT=0
 GRUB_DISTRIBUTOR="Arch"
 GRUB_CMDLINE_LINUX_DEFAULT="quiet"
 GRUB_CMDLINE_LINUX=""
@@ -8,7 +8,7 @@ GRUB_CMDLINE_LINUX=""
 GRUB_PRELOAD_MODULES="part_gpt part_msdos"
 
 # Uncomment to enable Hidden Menu, and optionally hide the timeout count
-#GRUB_HIDDEN_TIMEOUT=5
+GRUB_HIDDEN_TIMEOUT=3
 #GRUB_HIDDEN_TIMEOUT_QUIET=true
 
 # Uncomment to use basic console
@@ -34,8 +34,8 @@ GRUB_DISABLE_RECOVERY=true
 
 # Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
 # modes only.  Entries specified as foreground/background.
-#GRUB_COLOR_NORMAL="light-blue/black"
-#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"
+GRUB_COLOR_NORMAL="white/blue"
+GRUB_COLOR_HIGHLIGHT="black/yellow"
 
 # Uncomment one of them for the gfx desired, a image background or a gfxtheme
 #GRUB_BACKGROUND="/path/to/wallpaper"
diff --git a/abs/core/grub/grub.install b/abs/core/grub/grub.install
index 9188b35..40e3078 100644
--- a/abs/core/grub/grub.install
+++ b/abs/core/grub/grub.install
@@ -7,23 +7,30 @@ post_install() {
     install -D -m0644 /boot/grub/grub.cfg.pacsave /boot/grub/grub.cfg
   fi
 
+  post_upgrade
+}
+
+post_upgrade() {
   cat << 'EOM'
-Generating grub.cfg.example config file...
+Generating grub.cfg config file...
 This may fail on some machines running a custom kernel.
 EOM
   
-  grub-mkconfig -o /boot/grub/grub.cfg.example 2> /dev/null
+  grub-mkconfig -o /boot/grub/grub.cfg 2> /dev/null
   echo "done."
 
   for file in ${filelist[@]}; do
     install-info ${infodir}/${file}.gz ${infodir}/dir 2> /dev/null
   done
-}
 
-post_upgrade() {
-  for file in ${filelist[@]}; do
-    install-info ${infodir}/${file}.gz ${infodir}/dir 2> /dev/null
-  done
+  if [[ -d /boot/grub/locale ]] && [[ ! -a /boot/grub/locale/en.mo ]]; then
+  cat << 'EOM'
+Creating link /boot/grub/locale/en.mo ...
+EOM
+    cd /boot/grub/locale
+    ln -s "en@quot.mo" "en.mo"
+    echo "done."
+  fi
 }
 
 pre_remove() {
-- 
cgit v0.12