From 73e587b0f37e224e6b772a080a35f98bf275b6f6 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sun, 22 Apr 2012 13:09:39 -0500
Subject: initscripts: set LC_ALL

---
 abs/core/initscripts/PKGBUILD            |  4 ++--
 abs/core/initscripts/__changelog         |  3 +++
 abs/core/initscripts/initscripts.install |  3 +++
 abs/core/initscripts/rc.sysinit.patch    | 16 ++++++++++++----
 4 files changed, 20 insertions(+), 6 deletions(-)

diff --git a/abs/core/initscripts/PKGBUILD b/abs/core/initscripts/PKGBUILD
index 7796aa9..6034a24 100644
--- a/abs/core/initscripts/PKGBUILD
+++ b/abs/core/initscripts/PKGBUILD
@@ -5,7 +5,7 @@
 
 pkgname=initscripts
 pkgver=2011.06.4
-pkgrel=6
+pkgrel=7
 pkgdesc="System initialization/bootup scripts"
 arch=('i686' 'x86_64')
 url="http://www.archlinux.org"
@@ -33,7 +33,7 @@ package() {
 }
 md5sums=('34cbe55f3f42069c59237db935d0511b'
          '027576534885b8d5dded9be546057b12'
-         'cd80b66cfc84fac0d52a5601b2eb55af'
+         '078bd0852e993ee1fa11cc579f0dfa83'
          '73abaf06450104bddf16d409015f81ab'
          'a166ea014a1c75860b14fc98825686cc'
          '521bbd001633d14b08e5471bea584ee4')
diff --git a/abs/core/initscripts/__changelog b/abs/core/initscripts/__changelog
index 4021950..2609b7e 100644
--- a/abs/core/initscripts/__changelog
+++ b/abs/core/initscripts/__changelog
@@ -6,3 +6,6 @@ Patch init scripts (remove tty1, linhes header)
 
 
 rename wireless.conf -> wireless.conf.example
+
+change utf8 to utf-8 in rc.conf
+sed -ie "s/[u|U][t|T][[f|F]8/utf-8/g" /etc/rc.conf
diff --git a/abs/core/initscripts/initscripts.install b/abs/core/initscripts/initscripts.install
index 56f6924..a64b543 100644
--- a/abs/core/initscripts/initscripts.install
+++ b/abs/core/initscripts/initscripts.install
@@ -8,4 +8,7 @@ post_upgrade() {
     echo "Blacklisting of modules is no longer supported in rc.conf,"
     echo "please add blacklist entries to /etc/modprobe.d/ instead."
   fi
+  echo "adjusting utf8 to utf-8"
+  echo "Please reboot for the locale adjustment to take affect"
+  sed -ie "s/[u|U][t|T][[f|F]8/utf-8/g" /etc/rc.conf
 }
diff --git a/abs/core/initscripts/rc.sysinit.patch b/abs/core/initscripts/rc.sysinit.patch
index 5588313..05f636a 100644
--- a/abs/core/initscripts/rc.sysinit.patch
+++ b/abs/core/initscripts/rc.sysinit.patch
@@ -1,6 +1,6 @@
---- initscripts-2011.06.4/rc.sysinit.orig	2011-08-11 19:56:03.000000000 +0000
-+++ initscripts-2011.06.4/rc.sysinit	2011-08-11 20:00:05.000000000 +0000
-@@ -7,8 +7,11@@
+--- initscripts-2011.06.4/rc.sysinit.orig	2012-04-22 17:02:58.399566849 +0000
++++ initscripts-2011.06.4/rc.sysinit	2012-04-22 17:03:25.639565741 +0000
+@@ -7,8 +7,11 @@
  . /etc/rc.d/functions
  
  echo " "
@@ -14,7 +14,7 @@
  printsep
  
  run_hook sysinit_start
-@@ -16,6 +17,8 @@
+@@ -16,6 +19,8 @@
  # export standard PATH (will be overridden later when /etc/profile is sourced, but is useful for UDev)
  export PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
  
@@ -23,3 +23,11 @@
  # mount /proc, /sys, /run, /dev, /run/lock, /dev/pts, /dev/shm (the api filesystems)
  /bin/mountpoint -q /proc    || /bin/mount -n -t proc proc /proc -o nosuid,noexec,nodev
  /bin/mountpoint -q /sys     || /bin/mount -n -t sysfs sysfs /sys -o nosuid,noexec,nodev
+@@ -338,6 +343,7 @@
+ 	/bin/chmod 755 /etc/profile.d/locale.sh
+ 	# Set user defined locale
+ 	echo "export LANG=$LOCALE" >>/etc/profile.d/locale.sh
++	echo "export LC_ALL=$LOCALE" >>/etc/profile.d/locale.sh
+ stat_done
+ 
+ if [[ ${LOCALE,,} =~ utf ]]; then
-- 
cgit v0.12