From 2ea48e47ea995e476ded4f64d98f1e2b481a11dd Mon Sep 17 00:00:00 2001 From: Britney Fransen Date: Wed, 8 Oct 2014 20:01:44 +0000 Subject: supplemental-web: process.py: add loading indicator for all operations. --- abs/core/supplemental-web/PKGBUILD | 2 +- abs/core/supplemental-web/contents/process.py | 63 ++++++++++++++++++++------- 2 files changed, 49 insertions(+), 16 deletions(-) diff --git a/abs/core/supplemental-web/PKGBUILD b/abs/core/supplemental-web/PKGBUILD index 2a25f72..2dd59c8 100644 --- a/abs/core/supplemental-web/PKGBUILD +++ b/abs/core/supplemental-web/PKGBUILD @@ -1,7 +1,7 @@ pkgbase=supplemental-web pkgname=('supplemental-web' 'supplemental-web-slave') pkgver=8.2 -pkgrel=2 +pkgrel=3 arch=('i686' 'x86_64') license=('GPL') backup=('data/srv/httpd/cgi/extra.cfg.txt') diff --git a/abs/core/supplemental-web/contents/process.py b/abs/core/supplemental-web/contents/process.py index 7ad9af6..d624f60 100755 --- a/abs/core/supplemental-web/contents/process.py +++ b/abs/core/supplemental-web/contents/process.py @@ -266,12 +266,45 @@ def go_restart_mbe_local(): -mainpage = ''' - - - - Receiving a Form - %s''' +mainpage = '''%s''' + +loading = ''' + + + + + + + + + + LinHES + + + + +
+

+

Working. Please Wait...

+

+
+ +
+
+ +''' error = '''

Error

@@ -316,8 +349,9 @@ if __name__ == '__main__': body = result % (radio, hidden) - - + cgiprint(contentheader) # content header + cgiprint() # finish headers with blank line + print loading % body #print mainpage % body selection=radio myhost=hidden.lower() @@ -328,7 +362,6 @@ if __name__ == '__main__': mylogfile=go_backup(myhost) elif selection == "Dbackup": mylogfile=go_download_backup(dl_file) - elif selection == "Update": mylogfile=go_update(myhost,update_type) elif selection == "Shutdown": @@ -350,16 +383,15 @@ if __name__ == '__main__': elif selection == "RestartMBE": mylogfile = go_restart_mbe_local() - - cgiprint(contentheader) # content header + #cgiprint(contentheader) # content header cgiprint() # finish headers with blank line - print mainpage % body + #print mainpage % body #box='''

#
# #''' - box='''

+ box='''

''' @@ -370,7 +402,9 @@ if __name__ == '__main__': ''' javascript=''' ''' @@ -387,4 +421,3 @@ if __name__ == '__main__': # #print oldurl print javascript - -- cgit v0.12