From 13e7dfcaf9aa5d46abd43fc0bfcc8c2167e99645 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Sun, 17 Jul 2011 13:48:57 -0700
Subject: aufs:Bumped to latest

---
 abs/core/aufs2/PKGBUILD                  | 39 +++++++++++++++-----------
 abs/core/aufs2/aufs2-module-2.6.36.patch | 47 --------------------------------
 abs/core/aufs2/aufs2.install             |  2 +-
 abs/core/aufs2/create-tarball.sh         | 14 ----------
 4 files changed, 24 insertions(+), 78 deletions(-)
 delete mode 100644 abs/core/aufs2/aufs2-module-2.6.36.patch
 delete mode 100755 abs/core/aufs2/create-tarball.sh

diff --git a/abs/core/aufs2/PKGBUILD b/abs/core/aufs2/PKGBUILD
index a05c666..12203af 100644
--- a/abs/core/aufs2/PKGBUILD
+++ b/abs/core/aufs2/PKGBUILD
@@ -1,26 +1,30 @@
-# $Id: PKGBUILD 105327 2011-01-07 20:08:57Z tpowa $
-# Maintainer: Paul Mattal <pjmattal@elys.com>
+# Contributor: Paul Mattal <pjmattal@elys.com>
+# Maintainer: Calimero <calimeroteknik@free.fr>
 
 pkgname=aufs2
-pkgver=2.6.37_20110105
+pkgver=2.6.39_20110711
 pkgrel=1
 #_kernver=${pkgver%_*}-ARCH
-_kernver=2.6.37-LinHES
+
+# Set to whatever the tree of your aufs-friendly kernel is, and set the right dependency.
+#_kernver=2.6.39-ARCH
+#depends=('aufs_friendly')
+
+_kernver=2.6.39-LinHES
+depends=('kernel26>=2.6.39')
+
 pkgdesc="Another Unionfs Implementation"
 arch=('i686' 'x86_64')
 url="http://aufs.sourceforge.net/"
 license=('GPL2')
-depends=('kernel26>=2.6.37' 'kernel26<2.6.38')
-makedepends=('kernel26-headers>=2.6.37' 'kernel26-headers<2.6.38')
 replaces=('aufs')
 install=${pkgname}.install
-source=("ftp://ftp.archlinux.org/other/aufs2/${pkgname}-${pkgver}.tar.gz")
-       #aufs2-module-2.6.36.patch)
-options=('!makeflags')
+source=("http://calimeroteknik.free.fr/src/${pkgname}-${pkgver}.tar.gz")
+options=('!makeflags' '!strip')
+md5sums=('74bde9670759201f07025adf70bbaf43')
 
 build() {
   cd ${srcdir}/${pkgname}-${pkgver}
-  #patch -Np1 -i ../aufs2-module-2.6.36.patch
   sed -i 's|CONFIG_AUFS_HNOTIFY =.*|CONFIG_AUFS_HNOTIFY = y|' \
      config.mk || return 1
   sed -i 's|CONFIG_AUFS_HFSNOTIFY =.*|CONFIG_AUFS_HFSNOTIFY = y|' \
@@ -42,8 +46,10 @@ build() {
   fi
   sed -i "s|CONFIG_AUFS_INO_T_64 =.*|CONFIG_AUFS_INO_T_64 =${inot64}|" \
      config.mk 
-  # build
-  make aufs.ko KDIR=/usr/src/linux-${_kernver} 
+  # build, sed fixes are from gentoo portage build
+  sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile
+  sed -i "s:__user::g" include/linux/aufs_type.h
+  make KDIR=/usr/src/linux-${_kernver}
 }
 
 package() {
@@ -52,8 +58,9 @@ package() {
     $pkgdir/lib/modules/${_kernver}/kernel/fs/aufs/aufs.ko 
   # tweak the install script for the right kernel version
   sed -i -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
-    $startdir/$pkgname.install 
-  # install include files
-  install -D -m 644 include/linux/aufs_type.h $pkgdir/usr/src/linux-$_kernver/include/linux/aufs_type.h 
+    $startdir/$pkgname.install
+  # install include file
+  install -D -m 644 include/linux/aufs_type.h $pkgdir/usr/include/linux/aufs_type.h
+  # gzip -9 all modules to safe 100MB
+  find "$pkgdir" -name '*.ko' -exec gzip -9 {} \;
 }
-md5sums=('630c9c36bd4c0aa75a12b9bfa01ef8ee')
diff --git a/abs/core/aufs2/aufs2-module-2.6.36.patch b/abs/core/aufs2/aufs2-module-2.6.36.patch
deleted file mode 100644
index 3b43f7a..0000000
--- a/abs/core/aufs2/aufs2-module-2.6.36.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-diff --git a/ubuntu/aufs/branch.c b/ubuntu/aufs/branch.c
-index cd4463c..ff6b158 100644
---- a/fs/aufs/branch.c
-+++ b/fs/aufs/branch.c
-@@ -22,6 +22,8 @@
- 
- #include <linux/file.h>
- #include <linux/statfs.h>
-+#include <linux/lglock.h>
-+#include <linux/percpu.h>
- #include "aufs.h"
- 
- /*
-@@ -851,7 +853,8 @@ static int au_br_mod_files_ro(struct super_block *sb, aufs_bindex_t bindex)
- 		goto out;
- 
- 	/* no need file_list_lock() since sbinfo is locked? defered? */
--	list_for_each_entry(file, &sb->s_files, f_u.fu_list) {
-+        lg_global_lock(files_lglock);
-+	do_file_list_for_each_entry(sb, file) {
- 		if (special_file(file->f_dentry->d_inode->i_mode))
- 			continue;
- 
-@@ -861,6 +864,7 @@ static int au_br_mod_files_ro(struct super_block *sb, aufs_bindex_t bindex)
- 			err = -EBUSY;
- 			FiMustNoWaiters(file);
- 			fi_read_unlock(file);
-+			lg_global_unlock(files_lglock);
- 			goto out_free;
- 		}
- 
-@@ -889,10 +893,13 @@ static int au_br_mod_files_ro(struct super_block *sb, aufs_bindex_t bindex)
- 			if (p) {
- 				a = p;
- 				a[n++] = hf;
--			} else
-+			} else {
-+				lg_global_unlock(files_lglock);
- 				goto out_free;
-+			}
- 		}
--	}
-+	} while_file_list_for_each_entry;
-+	lg_global_unlock(files_lglock);
- 
- 	err = 0;
- 	if (n)
diff --git a/abs/core/aufs2/aufs2.install b/abs/core/aufs2/aufs2.install
index 1f5dd45..e0153ac 100644
--- a/abs/core/aufs2/aufs2.install
+++ b/abs/core/aufs2/aufs2.install
@@ -1,5 +1,5 @@
 post_install() {
-  KERNEL_VERSION=2.6.37-LinHES
+  KERNEL_VERSION=2.6.39-ARCH
   depmod $KERNEL_VERSION
 }
 
diff --git a/abs/core/aufs2/create-tarball.sh b/abs/core/aufs2/create-tarball.sh
deleted file mode 100755
index d4510f4..0000000
--- a/abs/core/aufs2/create-tarball.sh
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-AUFS2VERSION=""
-KERNELVERSION=2.6.37
-GITSNAPSHOT=20110105
-# aufs2 (no -xx) for the latest -rc version.
-git clone http://git.c3sl.ufpr.br/pub/scm/aufs/aufs2-standalone.git aufs2-standalone.git
-cd aufs2-standalone.git
-#git checkout origin/aufs2.1${AUFS2VERSION}
-git checkout origin/aufs2.1
-#*** apply "aufs2-base.patch" and "aufs2-standalone.patch" to your kernel source files.
-cd ..
-rm -rf aufs2-${KERNELVERSION}_${GITSNAPSHOT}
-cp -a aufs2-standalone.git aufs2-${KERNELVERSION}_${GITSNAPSHOT}
-tar -czf aufs2-${KERNELVERSION}_${GITSNAPSHOT}.tar.gz --exclude=.git aufs2-${KERNELVERSION}_${GITSNAPSHOT}
-- 
cgit v0.12