From 33c0f818a9694819fd08ae9d32263e915338a13d Mon Sep 17 00:00:00 2001
From: Cecil Hugh Watson <knoppmyth@gmail.com>
Date: Fri, 23 Jan 2009 16:09:24 -0800
Subject: When plugin is installed, .install will place it in the appropriate
 menu.  When plugin is removed, it will be removed from the menu.

---
 abs/extra-testing/mythappletrailers/PKGBUILD               |  2 +-
 .../mythappletrailers/mythappletrailers.install            | 14 ++++++++++++++
 2 files changed, 15 insertions(+), 1 deletion(-)

diff --git a/abs/extra-testing/mythappletrailers/PKGBUILD b/abs/extra-testing/mythappletrailers/PKGBUILD
index abad590..f7d4700 100644
--- a/abs/extra-testing/mythappletrailers/PKGBUILD
+++ b/abs/extra-testing/mythappletrailers/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=mythappletrailers
 pkgver=0.04.3
-pkgrel=13
+pkgrel=17
 pkgdesc="Unofficial Add-on for MythTV to get Apple.com Movie Trailers."
 arch=('i686' 'x86_64')
 license=('GPL2')
diff --git a/abs/extra-testing/mythappletrailers/mythappletrailers.install b/abs/extra-testing/mythappletrailers/mythappletrailers.install
index 133390c..d60a566 100644
--- a/abs/extra-testing/mythappletrailers/mythappletrailers.install
+++ b/abs/extra-testing/mythappletrailers/mythappletrailers.install
@@ -1,6 +1,18 @@
 # arg 1:  the new package version
 post_install() {
   ln -s /home/mythtv/appletrailer.xml /usr/share/mythtv/appletrailer.xml
+  mv /usr/share/mythtv/is.xml /tmp
+  grep -v -e /mythmenu /tmp/is.xml > /tmp/is.xml.tmp
+  echo "<!--#MythAppleTrailers-->" >> /tmp/is.xml.tmp
+  echo "   <button>" >> /tmp/is.xml.tmp
+  echo "     <type>MOVIETIMES</type>" >> /tmp/is.xml.tmp
+  echo "     <text>Apple Trailers</text>" >> /tmp/is.xml.tmp
+  echo "     <action>MENU appletrailer.xml</action>" >> /tmp/is.xml.tmp 
+  echo "   </button>" >> /tmp/is.xml.tmp
+  echo "<!--#MythAppleTrailers-->" >> /tmp/is.xml.tmp
+  echo "" >> /tmp/is.xml.tmp
+  echo "</mythmenu>" >> /tmp/is.xml.tmp
+  mv /tmp/is.xml.tmp /usr/share/mythtv/is.xml
 }
 # arg 1:  the new package version
 # arg 2:  the old package version
@@ -16,6 +28,8 @@ post_upgrade() {
 # arg 1:  the old package version
 post_remove() {
 	rm -fr /usr/share/mythtv/appletrailer.xml
+	mv /usr/share/mythtv/is.xml /tmp/is.xml.tmp
+	sed -e '/\#MythAp/,/\#MythAp/d' < /tmp/is.xml.tmp > /usr/share/mythtv/is.xml
 }
 
 op=$1
-- 
cgit v0.12