From 5bb0c04f864f2bec06fb7f570e787a4311e1e688 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 6 Aug 2012 21:42:17 -0500
Subject: imagemagick 6.7.8.7

---
 abs/core/imagemagick/PKGBUILD                      | 106 +++++++++++++--------
 abs/core/imagemagick/libpng_mmx_patch_x86_64.patch |  12 ---
 2 files changed, 64 insertions(+), 54 deletions(-)
 delete mode 100644 abs/core/imagemagick/libpng_mmx_patch_x86_64.patch

diff --git a/abs/core/imagemagick/PKGBUILD b/abs/core/imagemagick/PKGBUILD
index c02552b..e2426fc 100644
--- a/abs/core/imagemagick/PKGBUILD
+++ b/abs/core/imagemagick/PKGBUILD
@@ -1,60 +1,82 @@
-# $Id: PKGBUILD 90849 2010-09-18 00:00:00Z eric $
-# Contributor: Eric Belanger <eric@archlinux.org>
-# Maintainer: DAniel J Griffiths <ghost1227@archlinux.us>
+# $Id: PKGBUILD 163750 2012-07-19 04:55:07Z eric $
+# Maintainer: Eric BĂ©langer <eric@archlinux.org>
 
-pkgname=imagemagick
-pkgver=6.6.5.10
+pkgbase=imagemagick
+pkgname=('imagemagick' 'imagemagick-doc')
+pkgver=6.7.8.7
 pkgrel=1
-pkgdesc="An image viewing/manipulation program"
 arch=('i686' 'x86_64')
 url="http://www.imagemagick.org/"
 license=('custom')
-depends=('libtool' 'lcms' 'libxt' 'gcc-libs' 'bzip2' 'freetype2' 'fontconfig' 'libxext')
-makedepends=('ghostscript' 'openexr' 'libwmf' 'librsvg' 'libxml2' 'jasper')
-optdepends=('ghostscript: for Ghostscript support' 
-            'openexr: for OpenEXR support' 
-            'libwmf: for WMF support' 
-            'librsvg: for SVG support'
-            'libxml2: for XML support'
-            'jasper: for JPEG-2000 support')
-options=('!makeflags' '!docs' 'force')
+makedepends=('libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'ghostscript' \
+             'openexr' 'libwmf' 'librsvg' 'libxml2' 'jasper' 'liblqr')
 source=(ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz \
-        libpng_mmx_patch_x86_64.patch 
-	perlmagick.rpath.patch)
+        perlmagick.rpath.patch)
 
 build() {
-	cd "${srcdir}"/ImageMagick-${pkgver%.*}-${pkgver##*.}
+  cd "${srcdir}"/ImageMagick-${pkgver%.*}-${pkgver##*.}
 
-	if [ "${CARCH}" = 'x86_64' ]; then
-		patch -Np1 < ../libpng_mmx_patch_x86_64.patch
-	fi
+  sed '/AC_PATH_XTRA/d' -i configure.ac
+  autoreconf --install
+  patch -p0 -i ../perlmagick.rpath.patch
 
-	patch -p0 < ../perlmagick.rpath.patch
+  ./configure --prefix=/usr --sysconfdir=/etc --with-modules --disable-static \
+    --disable-openmp --with-wmf --with-openexr --with-xml --with-lcms2 --with-jp2 \
+    --with-gslib --with-gs-font-dir=/usr/share/fonts/Type1 \
+    --with-perl --with-perl-options="INSTALLDIRS=vendor" --with-lqr \
+    --without-gvc --without-djvu --without-autotrace --without-webp \
+    --without-jbig --without-fpx --without-dps --without-fftw
+  make
+}
 
-	./configure --prefix=/usr --with-modules --disable-static \
-	    --enable-openmp --with-x --with-wmf --with-openexr --with-xml \
-	    --with-gslib --with-gs-font-dir=/usr/share/fonts/Type1 \
-	    --with-perl --with-perl-options="INSTALLDIRS=vendor" \
-	    --without-gvc --without-djvu --without-autotrace --with-jp2 \
-	    --without-jbig --without-fpx --without-dps
-	make
+check() {
+  cd "${srcdir}"/ImageMagick-${pkgver%.*}-${pkgver##*.}
+  make check
 }
 
-package() {
-	cd "${srcdir}"/ImageMagick-${pkgver%.*}-${pkgver##*.}
+package_imagemagick() {
+  pkgdesc="An image viewing/manipulation program"
+  depends=('perl' 'libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'liblqr')
+  optdepends=('ghostscript: for Ghostscript support' 
+              'openexr: for OpenEXR support' 
+              'libwmf: for WMF support' 
+              'librsvg: for SVG support' 
+              'libxml2: for XML support' 
+              'jasper: for JPEG-2000 support' 
+              'libpng: for PNG support')
+  backup=('etc/ImageMagick/coder.xml'
+          'etc/ImageMagick/colors.xml'
+          'etc/ImageMagick/delegates.xml'
+          'etc/ImageMagick/log.xml'
+          'etc/ImageMagick/magic.xml'
+          'etc/ImageMagick/mime.xml'
+          'etc/ImageMagick/policy.xml'
+          'etc/ImageMagick/quantization-table.xml'
+          'etc/ImageMagick/thresholds.xml'
+          'etc/ImageMagick/type.xml'
+          'etc/ImageMagick/type-dejavu.xml'
+          'etc/ImageMagick/type-ghostscript.xml'
+          'etc/ImageMagick/type-windows.xml')
+  options=('!docs' 'libtool' '!emptydirs')
+
+  cd "${srcdir}"/ImageMagick-${pkgver%.*}-${pkgver##*.}
+  make DESTDIR="${pkgdir}" install
+  chmod 755 "${pkgdir}/usr/lib/perl5/vendor_perl/auto/Image/Magick/Magick.so" 
+  install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick/LICENSE"
+  install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick/NOTICE"
 
-	make DESTDIR="${pkgdir}" install
+#Cleaning
+  find "${pkgdir}" -name '*.bs' -delete
+  rm -f "${pkgdir}"/usr/lib/*.la
+}
 
-	install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-	install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/${pkgname}/NOTICE"
+package_imagemagick-doc() {
+  pkgdesc="The ImageMagick documentation (utilities manuals and libraries API)"
 
-	#Cleaning
-	find "${pkgdir}" -name '*.bs' -exec rm {} \;
-	rm -f "${pkgdir}"/usr/lib/*.la
+  cd "${srcdir}"/ImageMagick-${pkgver%.*}-${pkgver##*.}
+  make DESTDIR="${pkgdir}" install-data-html
+  install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick-doc/LICENSE"
+  install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick-doc/NOTICE"
 }
-md5sums=('dd8ae557c11472df1a5643c7d1e24c33'
-         '069980fc2590c02aed86420996259302'
-         'ff9974decbfe9846f8e347239d87e4eb')
-md5sums=('973d2f13d0daffa7fe2efc9d080e0b04'
-         '069980fc2590c02aed86420996259302'
+md5sums=('c12aa1fafac9ebdca42464ba872fac86'
          'ff9974decbfe9846f8e347239d87e4eb')
diff --git a/abs/core/imagemagick/libpng_mmx_patch_x86_64.patch b/abs/core/imagemagick/libpng_mmx_patch_x86_64.patch
deleted file mode 100644
index d86449a..0000000
--- a/abs/core/imagemagick/libpng_mmx_patch_x86_64.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur ImageMagick-6.2.7.orig/coders/png.c ImageMagick-6.2.7/coders/png.c
---- ImageMagick-6.2.7.orig/coders/png.c	2006-05-21 12:35:55.784852536 +0200
-+++ ImageMagick-6.2.7/coders/png.c	2006-05-21 12:36:50.698504392 +0200
-@@ -164,6 +164,8 @@
- #define PNG_MAX_UINT (png_uint_32) 0x7fffffffL
- #endif
- 
-+#undef PNG_ASSEMBLER_CODE_SUPPORTED
-+
- /*
-   Constant strings for known chunk types.  If you need to add a chunk,
-   add a string holding the name here.   To make the code more
-- 
cgit v0.12