From a2323eff147f149120eba563a4ed739a1ceae856 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Tue, 6 Nov 2012 16:17:09 -0600
Subject: ldm:  used to automount usb devices:

refs #866
---
 abs/core/ldm/PKGBUILD    | 30 ++++++++++++++++++++++++++++++
 abs/core/ldm/ldm.install |  9 +++++++++
 2 files changed, 39 insertions(+)
 create mode 100644 abs/core/ldm/PKGBUILD
 create mode 100644 abs/core/ldm/ldm.install

diff --git a/abs/core/ldm/PKGBUILD b/abs/core/ldm/PKGBUILD
new file mode 100644
index 0000000..ba91109
--- /dev/null
+++ b/abs/core/ldm/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Robin Hahling
+pkgname=ldm
+pkgver=0.3
+pkgrel=1
+pkgdesc="A lightweight device mounter"
+arch=('i686' 'x86_64')
+url="https://github.com/LemonBoy/ldm"
+license=('MIT')
+depends=('udev')
+provides=('ldm')
+conflicts=('ldm-git')
+source=(http://github.com/LemonBoy/${pkgname}/tarball/v${pkgver})
+install=ldm.install
+
+build() {
+  cd LemonBoy-${pkgname}-8417f5b
+  # needed before it is fixed in the Makefile
+  export LDFLAGS=""
+  make
+}
+
+package() {
+  cd LemonBoy-${pkgname}-8417f5b
+  make PREFIX="/usr" DESTDIR="${pkgdir}" install
+
+  install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
+md5sums=('3b8d4d7117f5b007ff3311c56c789e98')
diff --git a/abs/core/ldm/ldm.install b/abs/core/ldm/ldm.install
new file mode 100644
index 0000000..b32f1b7
--- /dev/null
+++ b/abs/core/ldm/ldm.install
@@ -0,0 +1,9 @@
+post_install() {
+	echo 'ldm expects a config file at /etc/conf.d/ldm containing your user and group id (uid and gid respectively).'
+	echo 'Just add those two lines into it:'
+	echo 'USER_GID=<output of `id -g` ran from your user>'
+	echo 'USER_UID=<output of `id -u` ran from your user>'
+}
+post_upgrade() {
+	post_install
+}
-- 
cgit v0.12