From ee1df8d21bd61872c711ee95a1b56bd261eef082 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Sat, 15 Oct 2011 18:47:42 -0500
Subject: mysql: update to 5.1.59; change settings for better performance

---
 abs/core/mysql/PKGBUILD |  6 +++---
 abs/core/mysql/my.cnf   | 39 ++++++++++++++++++++++++++-------------
 2 files changed, 29 insertions(+), 16 deletions(-)

diff --git a/abs/core/mysql/PKGBUILD b/abs/core/mysql/PKGBUILD
index 9602157..3ce1aeb 100644
--- a/abs/core/mysql/PKGBUILD
+++ b/abs/core/mysql/PKGBUILD
@@ -5,7 +5,7 @@
 
 pkgbase=mysql
 pkgname=('libmysqlclient' 'mysql-clients' 'mysql')
-pkgver=5.1.52
+pkgver=5.1.59
 pkgrel=1
 arch=('i686' 'x86_64')
 license=('GPL')
@@ -103,7 +103,7 @@ package_mysql(){
   rm -rf ${pkgdir}/usr/{mysql-test,sql-bench}
   rm -f ${pkgdir}/usr/lib/mysql/plugin/*.a
 }
-md5sums=('43c11ad3dded693393c4815d24e2b0a5'
+md5sums=('1e89816164692f44f768024db4bc05f6'
          '2234207625baa29b2ff7d7b4f088abce'
-         '175b269b665019689d786f5af0968046'
+         'd60099985e68e36b156423fca6b50924'
          'a97e574945e19de3908575b956241026')
diff --git a/abs/core/mysql/my.cnf b/abs/core/mysql/my.cnf
index 4eaeaa0..6f0a683 100644
--- a/abs/core/mysql/my.cnf
+++ b/abs/core/mysql/my.cnf
@@ -1,12 +1,17 @@
-# mysql config file for medium systems.
+# Example MySQL config file for large systems.
 #
-# This is for a system with little memory (32M - 64M) where MySQL plays
-# a important part and systems up to 128M where MySQL is used together with
-# other programs (like a web server)
+# This is for a large system with memory = 512M where the system runs mainly
+# MySQL.
 #
-# One can in this file use all long options that the program supports.
-# If you want to know which options a program support, run the program
-# with --help option.
+# You can copy this file to
+# /etc/my.cnf to set global options,
+# mysql-data-dir/my.cnf to set server-specific options (in this
+# installation this directory is /var) or
+# ~/.my.cnf to set user-specific options.
+#
+# In this file, you can use all long options that a program supports.
+# If you want to know which options a program supports, run the program
+# with the "--help" option.
 
 # The following options will be passed to all MySQL clients
 [client]
@@ -21,13 +26,21 @@ socket		= /var/run/mysqld/mysqld.sock
 port		= 3306
 socket		= /var/run/mysqld/mysqld.sock
 datadir		= /data/srv/mysql
-skip-external-locking
-key_buffer = 16M
+skip-locking
+key_buffer_size = 80M
 max_allowed_packet = 1M
-table_cache = 64
-sort_buffer_size = 512K
-net_buffer_length = 16K
-myisam_sort_buffer_size = 8M
+table_open_cache = 256
+tmp_table_size = 16M
+max_heap_table_size = 16M
+sort_buffer_size = 1M
+read_buffer_size = 1M
+read_rnd_buffer_size = 4M
+myisam_sort_buffer_size = 64M
+thread_cache_size = 8
+query_cache_size = 16M
+join_buffer_size = 128K
+# Try number of CPU's*2 for thread_concurrency
+#thread_concurrency = 8
 
 # Don't listen on a TCP/IP port at all. This can be a security enhancement,
 # if all processes that need to connect to mysqld run on the same host.
-- 
cgit v0.12