From 0fb4f371d0aa0ecd295a587cbd7dc1205f66fb24 Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Tue, 19 Jan 2016 16:35:17 +0000
Subject: elfutils: update to 0.165

---
 abs/core/elfutils/PKGBUILD | 34 +++++++++++++++++++++++-----------
 1 file changed, 23 insertions(+), 11 deletions(-)

diff --git a/abs/core/elfutils/PKGBUILD b/abs/core/elfutils/PKGBUILD
index b971e94..059bdae 100644
--- a/abs/core/elfutils/PKGBUILD
+++ b/abs/core/elfutils/PKGBUILD
@@ -1,38 +1,50 @@
 # $Id$
-# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+# Maintainer: Laurent Carlier <lordheavym@gmail.com>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
 # Contributor: Andrej Gelenberg <andrej.gelenberg@udo.edu>
 
-pkgname=elfutils
-pkgver=0.163
+pkgbase=elfutils
+pkgname=(elfutils libelf)
+pkgver=0.165
 pkgrel=1
-pkgdesc="Libraries and utilities to handle ELF object files and DWARF debugging information"
+pkgdesc="Utilities to handle ELF object files and DWARF debugging information"
 arch=('i686' 'x86_64')
 url="https://fedorahosted.org/elfutils/"
 license=('LGPL3' 'GPL' 'GPL3')
 depends=('gcc-libs' 'zlib' 'bzip2' 'xz')
-source=(https://fedorahosted.org/releases/e/l/elfutils/${pkgver}/elfutils-${pkgver}.tar.bz2{,.sig})
 options=('staticlibs')
-sha1sums=('7931b4961364a8a17c708138c70c552ae2881227'
+source=(https://fedorahosted.org/releases/e/l/elfutils/${pkgver}/elfutils-${pkgver}.tar.bz2{,.sig})
+sha1sums=('b994f2f31e6638415d7f8a3c0c7e04e6bc4ca4a9'
           'SKIP')
 validpgpkeys=('47CC0331081B8BC6D0FD4DA08370665B57816A6A')  # Mark J. Wielaard <mark@klomp.org>
 
 build() {
-  cd ${pkgname}-${pkgver}
+  cd ${pkgbase}-${pkgver}
 
   CFLAGS+=" -g"  # required for test-suite success
-  ./configure --prefix=/usr --program-prefix="eu-"
+  ./configure --prefix=/usr --program-prefix="eu-" --enable-deterministic-archives
 
   make
 }
 
 check() {
-  cd ${pkgname}-${pkgver}
+  cd ${pkgbase}-${pkgver}
 
   make check
 }
 
-package() {
-  cd ${pkgname}-${pkgver}
+package_elfutils() {
+  depends=("libelf=$pkgver-$pkgrel")
+
+  cd ${pkgbase}-${pkgver}
 
   make DESTDIR="${pkgdir}" install
+
+  mkdir "${srcdir}"/libelf
+  mv "${pkgdir}"/usr/{lib,include} "${srcdir}/libelf"
+}
+
+package_libelf() {
+  pkgdesc="Libraries to handle ELF object files and DWARF debugging information"
+  mv libelf "${pkgdir}/usr"
 }
-- 
cgit v0.12