From ece441330b8ffbcab00ca3b60787fb8b7c8106ff Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Sat, 27 Mar 2010 11:31:04 -0500
Subject: postfix:  initial include

ref #464
closes #408
---
 abs/extra-testing/postfix/PKGBUILD          |  52 +++++++++++++++++++++++++
 abs/extra-testing/postfix/__changelog       |   1 +
 abs/extra-testing/postfix/postfix           |  58 ++++++++++++++++++++++++++++
 abs/extra-testing/postfix/postfix.install   |  38 ++++++++++++++++++
 abs/extra-testing/postfix/postfix.patch.bz2 | Bin 0 -> 373 bytes
 5 files changed, 149 insertions(+)
 create mode 100644 abs/extra-testing/postfix/PKGBUILD
 create mode 100644 abs/extra-testing/postfix/__changelog
 create mode 100755 abs/extra-testing/postfix/postfix
 create mode 100644 abs/extra-testing/postfix/postfix.install
 create mode 100644 abs/extra-testing/postfix/postfix.patch.bz2

diff --git a/abs/extra-testing/postfix/PKGBUILD b/abs/extra-testing/postfix/PKGBUILD
new file mode 100644
index 0000000..1b2fa06
--- /dev/null
+++ b/abs/extra-testing/postfix/PKGBUILD
@@ -0,0 +1,52 @@
+# $Id: PKGBUILD 70372 2010-02-26 13:35:23Z paul $
+# Contributor: Jeff Brodnax <tullyarcher@bellsouth.net>
+# Maintainer: Paul Mattal <paul@archlinux.org>
+pkgname=postfix
+pkgver=2.7.0
+pkgrel=1
+pkgdesc="Secure, fast, easy to administer drop in replacement for Sendmail (MTA)"
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('pcre' 'libsasl'   'db>=4.7')
+backup=(etc/postfix/aliases etc/postfix/virtual etc/postfix/relocated \
+	etc/postfix/access etc/postfix/header_checks etc/postfix/transport \
+	etc/postfix/generic etc/postfix/canonical \
+	etc/postfix/main.cf etc/postfix/master.cf)
+install="${pkgname}.install"
+provides=('smtp-server' 'smtp-forwarder')
+replaces=('postfix-mysql' 'postfix-pgsql')
+conflicts=('postfix-mysql' 'postfix-pgsql' 'smtp-server' 'smtp-forwarder')
+url="http://www.postfix.org/"
+source=(ftp://ftp.porcupine.org/mirrors/postfix-release/official/${pkgname}-${pkgver}.tar.gz \
+        ${pkgname}.patch.bz2 \
+	${pkgname})
+md5sums=('df648f59421604e895cce56325f00bae'
+         'a3c45ff23ef036143711793fcf2478c3'
+         'c847b96f08925f08b0f610468a8e21f6')
+
+build() {
+	cd ${srcdir}/${pkgname}-${pkgver}
+	
+	make makefiles \
+	        CCARGS="-DUSE_SASL_AUTH -I/usr/include/sasl \
+			-DUSE_CYRUS_SASL \
+			-DUSE_TLS" \
+	        AUXLIBS="-lsasl2 -lssl -lcrypto  -llber -lz -lm "
+	make OPT="${CFLAGS}" || return 1
+
+	sh postfix-install -non-interactive \
+		install_root="${pkgdir}" \
+		daemon_directory="/usr/lib/${pkgname}" \
+		sample_directory="/etc/${pkgname}/sample" \
+		manpage_directory="/usr/share/man"
+
+	cd ${pkgdir}
+	cat ${srcdir}/${pkgname}.patch |patch -Np0 || return 1
+	rm -f etc/${pkgname}/main.cf~
+
+	cd ${pkgdir}
+	mkdir etc/rc.d
+	install -m 0755 ${srcdir}/${pkgname} etc/rc.d/${pkgname}
+
+	install -Dm644 ${srcdir}/${pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/abs/extra-testing/postfix/__changelog b/abs/extra-testing/postfix/__changelog
new file mode 100644
index 0000000..25ca6b4
--- /dev/null
+++ b/abs/extra-testing/postfix/__changelog
@@ -0,0 +1 @@
+remove ldap/mysql/pg support
diff --git a/abs/extra-testing/postfix/postfix b/abs/extra-testing/postfix/postfix
new file mode 100755
index 0000000..37dd6a8
--- /dev/null
+++ b/abs/extra-testing/postfix/postfix
@@ -0,0 +1,58 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pgrep -f /usr/lib/postfix/master`
+
+start() {
+  stat_busy "Starting Postfix"
+  [ -z "$PID" ] && /usr/sbin/postfix start &> /dev/null
+  if [ $? -gt 0 ]; then
+    stat_fail
+  else
+    add_daemon postfix
+    stat_done
+  fi
+}
+
+stop() {
+  stat_busy "Stopping Postfix"
+  [ ! -z "$PID" ]  && /usr/sbin/postfix stop &> /dev/null
+  if [ $? -gt 0 ]; then
+    stat_fail
+  else
+    rm_daemon postfix
+    stat_done
+  fi
+}
+
+reload() {
+  stat_busy "Reloading Postfix"
+  [ ! -z "$PID" ] && kill -HUP $PID &> /dev/null
+  if [ $? -gt 0 ]; then
+    stat_fail
+  else
+    stat_done
+  fi
+}
+
+case "$1" in
+  start)
+    start
+    ;;
+  stop)
+    stop
+    ;;
+  restart)
+    # calling 'stop' and 'start' without the $0 fails...
+    $0 stop
+    $0 start
+    ;;
+  reload)
+    reload
+    ;;
+  *)
+    echo "usage: $0 {start|stop|restart|reload}"
+esac
+exit 0
diff --git a/abs/extra-testing/postfix/postfix.install b/abs/extra-testing/postfix/postfix.install
new file mode 100644
index 0000000..bac3e1d
--- /dev/null
+++ b/abs/extra-testing/postfix/postfix.install
@@ -0,0 +1,38 @@
+# arg 1:  the new package version
+post_install() {
+    if [ -z "`grep '^postdrop::' /etc/group`" ]; then
+	groupadd -g 75 postdrop >& /dev/null
+    fi
+    if [ -z "`grep '^postfix::' /etc/group`" ]; then
+	groupadd -g 73 postfix >& /dev/null
+    fi
+    if [ -z "`grep '^postfix:' /etc/passwd`" ]; then
+	useradd -u 73 -d /var/spool/postfix -g postfix -s /bin/false postfix
+    else
+	# fix a packaging bug from before (postfix should have no shell)
+	usermod -s /bin/false postfix
+    fi
+
+    chown postfix var/spool/postfix/{active,bounce,corrupt,defer,deferred,\
+flush,hold,incoming,private,public,maildrop,trace,saved}
+    chown postfix var/lib/postfix
+    chgrp postdrop var/spool/postfix/{public,maildrop}
+    chgrp postdrop usr/sbin/postqueue
+    chgrp postdrop usr/sbin/postdrop
+    chmod g+s usr/sbin/{postqueue,postdrop}
+
+    newaliases
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+    post_install $1
+}
+
+# arg 1:  the old package version
+pre_remove() {
+    userdel postfix &> /dev/null
+    groupdel postfix &> /dev/null
+    groupdel postdrop &> /dev/null
+}
diff --git a/abs/extra-testing/postfix/postfix.patch.bz2 b/abs/extra-testing/postfix/postfix.patch.bz2
new file mode 100644
index 0000000..dbc0950
Binary files /dev/null and b/abs/extra-testing/postfix/postfix.patch.bz2 differ
-- 
cgit v0.12