From 62ae119f3120c49f8142c02a4d9def9d74b00864 Mon Sep 17 00:00:00 2001
From: Cecil <knoppmyth@gmail.com>
Date: Sun, 29 Jul 2012 23:11:09 -0700
Subject: mythtv:Bumped to compiles latest 0.25.2. Added DVD backup menu.

---
 abs/core/mythtv/stable-0.25/git_src/git_hash       |  2 +-
 abs/core/mythtv/stable-0.25/mythtv/PKGBUILD        |  2 +-
 .../stable-0.25/mythtv/menu-xml/dvd_backup.xml     | 39 ++++++++++++++++++++++
 .../stable-0.25/mythtv/menu-xml/mainmenu.xml.patch | 10 +++---
 .../mythtv/menu-xml/optical_menu.xml.patch         | 13 ++++++--
 5 files changed, 57 insertions(+), 9 deletions(-)
 create mode 100644 abs/core/mythtv/stable-0.25/mythtv/menu-xml/dvd_backup.xml

diff --git a/abs/core/mythtv/stable-0.25/git_src/git_hash b/abs/core/mythtv/stable-0.25/git_src/git_hash
index ae0574c..0891f19 100644
--- a/abs/core/mythtv/stable-0.25/git_src/git_hash
+++ b/abs/core/mythtv/stable-0.25/git_src/git_hash
@@ -1 +1 @@
-f0e2ad85dbdd6dd4041a8b1e7d8b17e7b8746b63
+a72e341a4653a1b683b7ae5ac87bcaa3092d20fa
diff --git a/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD b/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
index 0d5f979..2f0b8b7 100644
--- a/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
+++ b/abs/core/mythtv/stable-0.25/mythtv/PKGBUILD
@@ -6,7 +6,7 @@
 
 pkgname=mythtv
 pkgver=0.25
-pkgrel=9
+pkgrel=10
 commit_hash=`cat ../git_src/git_hash`
 pkgdesc="A Homebrew PVR project $commit_hash"
 arch=('i686' 'x86_64')
diff --git a/abs/core/mythtv/stable-0.25/mythtv/menu-xml/dvd_backup.xml b/abs/core/mythtv/stable-0.25/mythtv/menu-xml/dvd_backup.xml
new file mode 100644
index 0000000..2647d81
--- /dev/null
+++ b/abs/core/mythtv/stable-0.25/mythtv/menu-xml/dvd_backup.xml
@@ -0,0 +1,39 @@
+<?xml version="1.0" encoding="UTF-8" ?>
+<mythmenu name="OPTICAL_DISK">
+
+    <button>
+        <type>DVD_RIP</type>
+        <text>Mirror DVD</text>
+        <description>Creates a mirror of your DVD</description>
+	<action>EXEC /usr/LH/bin/ripD_eject.sh m &amp;</action>
+    </button>
+
+    <button>
+        <type>DVD_RIP</type>
+        <text>ISO of DVD</text>
+        <description>Creates an ISO of your DVD</description>
+	<action>EXEC /usr/LH/bin/ripD_eject.sh i &amp;</action>
+    </button>
+
+    <button>
+        <type>DVD_RIP</type>
+        <text>High Quality</text>
+        <description>Creates a high quality MPEG4 of your DVD</description>
+	<action>EXEC /usr/LH/bin/ripD_eject.sh h &amp;</action>
+    </button>
+
+    <button>
+        <type>DVD_RIP</type>
+        <text>Normal Quality</text>
+        <description>Creates a normal quality MPEG4 of your DVD</description>
+	<action>EXEC /usr/LH/bin/ripD_eject.sh n &amp;</action>
+    </button>
+
+    <button>
+        <type>DVD_RIP</type>
+        <text>Low Quality</text>
+        <description>Creates a low quality MPEG4 of your DVD</description>
+	<action>EXEC /usr/LH/bin/ripD_eject.sh l &amp;</action>
+    </button>
+
+</mythmenu>
diff --git a/abs/core/mythtv/stable-0.25/mythtv/menu-xml/mainmenu.xml.patch b/abs/core/mythtv/stable-0.25/mythtv/menu-xml/mainmenu.xml.patch
index 9b083ac..73a8940 100644
--- a/abs/core/mythtv/stable-0.25/mythtv/menu-xml/mainmenu.xml.patch
+++ b/abs/core/mythtv/stable-0.25/mythtv/menu-xml/mainmenu.xml.patch
@@ -1,5 +1,5 @@
---- themes/defaultmenu/mainmenu.xml.orig	2012-04-21 17:33:52.176349680 +0000
-+++ themes/defaultmenu/mainmenu.xml	2012-04-21 17:35:03.369680109 +0000
+--- themes/defaultmenu/mainmenu.xml.orig	2012-07-29 21:39:46.000000000 +0000
++++ themes/defaultmenu/mainmenu.xml	2012-07-29 21:41:50.000000000 +0000
 @@ -1,5 +1,11 @@
  <?xml version="1.0" encoding="UTF-8" ?>
  <mythmenu name="MAIN">
@@ -12,7 +12,7 @@
  
      <button>
          <type>MENU_MEDIA_LIBRARY</type>
-@@ -30,17 +36,10 @@
+@@ -30,18 +36,11 @@
      </button>
  
      <button>
@@ -27,9 +27,11 @@
 -        <text>Setup</text>
 -        <description>Configure MythTV and plugins</description>
 -        <action>MENU main_settings.xml</action>
+-        <password>SetupPinCode</password>
 +        <text>Service Menu</text>
 +        <description>Configure your system</description>
-+        <action>MENU linhes.xml</action>
++	<action>MENU linhes.xml</action>
++	<password>SetupPinCode</password>
      </button>
  
  </mythmenu>
diff --git a/abs/core/mythtv/stable-0.25/mythtv/menu-xml/optical_menu.xml.patch b/abs/core/mythtv/stable-0.25/mythtv/menu-xml/optical_menu.xml.patch
index 143424f..1ff2db2 100644
--- a/abs/core/mythtv/stable-0.25/mythtv/menu-xml/optical_menu.xml.patch
+++ b/abs/core/mythtv/stable-0.25/mythtv/menu-xml/optical_menu.xml.patch
@@ -1,10 +1,17 @@
---- themes/defaultmenu/optical_menu.xml.orig	2010-11-06 00:39:43.000000000 +0000
-+++ themes/defaultmenu/optical_menu.xml	2010-11-06 00:42:59.000000000 +0000
-@@ -26,6 +26,13 @@
+--- themes/defaultmenu/optical_menu.xml.orig	2012-05-02 18:41:38.000000000 +0000
++++ themes/defaultmenu/optical_menu.xml	2012-07-30 05:33:03.000000000 +0000
+@@ -17,6 +17,20 @@
      </button>
  
      <button>
 +        <type>DVD_RIP</type>
++        <text>Backup DVD</text>
++       <description>Backup your DVDs</description>
++        <action>MENU dvd_backup.xml</action>
++    </button>
++
++    <button>
++        <type>DVD_RIP</type>
 +        <text>Import video files from DVD</text>
 +       <description>Import video files from a data DVD</description>
 +        <action>EXEC /usr/LH/bin/importfiles.sh</action>
-- 
cgit v0.12