From d88db333c2653f745f23bebc7b4705ae8043d750 Mon Sep 17 00:00:00 2001
From: Michael Hanson <hansonorders@verizon.net>
Date: Fri, 19 Nov 2010 03:30:35 +0000
Subject: fbsplash: upgrade

---
 abs/core/fbsplash/PKGBUILD    | 35 ++++++++++++++++++++---------------
 abs/core/fbsplash/splash.conf |  6 +++++-
 2 files changed, 25 insertions(+), 16 deletions(-)

diff --git a/abs/core/fbsplash/PKGBUILD b/abs/core/fbsplash/PKGBUILD
index dcec71a..516ef40 100644
--- a/abs/core/fbsplash/PKGBUILD
+++ b/abs/core/fbsplash/PKGBUILD
@@ -3,16 +3,16 @@
 
 pkgname=fbsplash
 pkgver=1.5.4.3
-pkgrel=33
+pkgrel=34
 pkgdesc="A userspace implementation of a splash screen for Linux (formerly known as gensplash)"
 arch=('i686' 'x86_64')
 url="http://fbsplash.berlios.de"
 license=('GPL')
-depends=('miscsplashutils' 'freetype2' 'libjpeg' 'libpng' 'libmng' 'lcms' 'gpm' 'linhes-splash') 
+depends=('miscsplashutils' 'freetype2' 'libjpeg' 'libpng' 'libmng' 'lcms' 'gpm') 
 optdepends=('kernel26-fbcondecor: enable console background images'
             'fbsplash-extras: additional functionality like daemon icons'
             'uswsusp-fbsplash: suspend to disk with fbsplash'
-            'python: convert themes from splashy to fbsplash')
+            'python2: convert themes from splashy to fbsplash')
 conflicts=('fbsplash-scripts' 'initscripts-extras-fbsplash')
 options=('!makeflags')
 backup=('etc/conf.d/fbcondecor' 'etc/conf.d/splash')
@@ -25,20 +25,33 @@ source=(http://dev.gentoo.org/~spock/projects/gensplash/archive/splashutils-${pk
         fbsplash.initcpio_hook
         fbcondecor.daemon
         fbcondecor.conf)
+md5sums=('c722cd4148817b9c50381d9bdc1ea6ef'
+         '3a338c60ed0710c8b7e3e08929db521a'
+         'dd6d7ecad8e953754f90de683f0d5a33'
+         'e69753dac753b8ba4e2e29ef5a9c46ca'
+         'e29b3db6ee059b9950febe976a0f2881'
+         'ac2351bc918b101bb9249ce8940722be'
+         '715926469d05eecd345c052e6248ca32'
+         'b3db9d4fd902b62ac9e38589677e2d16')
 
 build() {
   cd ${srcdir}/splashutils-${pkgver}
 
   # patch for building splashutils with glibc and dynamical linking
-  patch -Np0 -i ${srcdir}/fbsplash.git.patch || return 1
+  patch -Np0 -i ${srcdir}/fbsplash.git.patch
   autoreconf
 
   # fix fbcondecor_ctl splash type
   sed -e 's,fbsplash_lib_init(fbspl_bootup),fbsplash_lib_init(fbspl_undef),' -i src/fbcon_decor_ctl.c
 
-  ./configure --prefix=/usr --sysconfdir=/etc --without-klibc --enable-fbcondecor --with-gpm --with-mng --with-png --with-ttf --with-ttf-kernel || return 1
-  make || return 1
-  make DESTDIR=${startdir}/pkg install || return 1
+  ./configure --prefix=/usr --sysconfdir=/etc --without-klibc --enable-fbcondecor --with-gpm --with-mng --with-png --with-ttf --with-ttf-kernel
+  make
+}
+
+package() {
+  cd ${srcdir}/splashutils-${pkgver}
+
+  make DESTDIR=${pkgdir} install
 
   cd ${pkgdir}
 
@@ -61,11 +74,3 @@ build() {
   install -D -m644 ${srcdir}/fbcondecor.conf etc/conf.d/fbcondecor
   install -D -m755 ${srcdir}/fbcondecor.daemon etc/rc.d/fbcondecor
 }
-md5sums=('c722cd4148817b9c50381d9bdc1ea6ef'
-         '3a338c60ed0710c8b7e3e08929db521a'
-         'a8f40c99a32d20d505aa24fbbd703008'
-         'e69753dac753b8ba4e2e29ef5a9c46ca'
-         'e29b3db6ee059b9950febe976a0f2881'
-         'ac2351bc918b101bb9249ce8940722be'
-         '715926469d05eecd345c052e6248ca32'
-         'b3db9d4fd902b62ac9e38589677e2d16')
diff --git a/abs/core/fbsplash/splash.conf b/abs/core/fbsplash/splash.conf
index 74cada9..46fd5c5 100644
--- a/abs/core/fbsplash/splash.conf
+++ b/abs/core/fbsplash/splash.conf
@@ -7,7 +7,11 @@
 ## Themes to include into initcpio
 ## For a smaller initcpio you may try theme cfg files instead of directories.
 SPLASH_THEMES=(
-    linhes
+    arch-black
+    arch-banner-icons/1024x768.cfg
+    arch-banner-icons/1280x800.cfg
+    arch-banner-noicons/1024x768.cfg
+    arch-banner-noicons/1280x800.cfg
 )
 
 ## Override the initial silent splash screen status message defaults.
-- 
cgit v0.12