From 2e6370983563263414982873fd987bd11d75a45b Mon Sep 17 00:00:00 2001
From: Britney Fransen <brfransen@gmail.com>
Date: Thu, 30 Jul 2015 14:52:54 +0000
Subject: alsa-lib, alsa-utils: update to 1.0.29; alsa-plugins: initial
 inclusion

---
 abs/core/alsa-lib/PKGBUILD     |  4 ++--
 abs/core/alsa-plugins/PKGBUILD | 39 +++++++++++++++++++++++++++++++++++++++
 abs/core/alsa-utils/PKGBUILD   |  6 +++---
 3 files changed, 44 insertions(+), 5 deletions(-)
 create mode 100644 abs/core/alsa-plugins/PKGBUILD

diff --git a/abs/core/alsa-lib/PKGBUILD b/abs/core/alsa-lib/PKGBUILD
index d502947..aecef20 100644
--- a/abs/core/alsa-lib/PKGBUILD
+++ b/abs/core/alsa-lib/PKGBUILD
@@ -2,7 +2,7 @@
 # Maintainer: judd <jvinet@zeroflux.org>
 
 pkgname=alsa-lib
-pkgver=1.0.28
+pkgver=1.0.29
 pkgrel=1
 pkgdesc="An alternative implementation of Linux sound support"
 arch=('i686' 'x86_64')
@@ -23,4 +23,4 @@ package() {
   cd "$srcdir/$pkgname-$pkgver"
   make DESTDIR="$pkgdir" install
 }
-md5sums=('c9e21b88a2b3e6e12ea7ba0f3b271fc3')
+md5sums=('de67e0eca72474d6b1121037dafe1024')
diff --git a/abs/core/alsa-plugins/PKGBUILD b/abs/core/alsa-plugins/PKGBUILD
new file mode 100644
index 0000000..42fb370
--- /dev/null
+++ b/abs/core/alsa-plugins/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id$
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Daniel Ehlers <danielehlers@mindeye.net>
+
+pkgname=alsa-plugins
+pkgver=1.0.29
+pkgrel=2
+pkgdesc="Extra alsa plugins"
+arch=(i686 x86_64)
+url="http://www.alsa-project.org"
+license=(GPL)
+depends=(alsa-lib)
+makedepends=(ffmpeg)
+optdepends=('ffmpeg: libavcodec resampling plugin, a52 plugin'
+            'libsamplerate: libsamplerate resampling plugin'
+            'speex: libspeexdsp resampling plugin')
+source=("ftp://ftp.alsa-project.org/pub/plugins/$pkgname-$pkgver.tar.bz2")
+
+prepare() {
+  cd $pkgname-$pkgver
+  sed -i 's/ && LIBAVCODEC_VERSION_MINOR >= 34//' a52/pcm_a52.c
+}
+
+build() {
+  cd $pkgname-$pkgver
+  CFLAGS+=' -DHAVE_STDINT_H' # We have issue similar to this one https://code.google.com/p/cantata/issues/detail?id=627
+  ./configure --prefix=/usr
+  make
+}
+
+package() {
+  cd $pkgname-$pkgver
+  make DESTDIR="$pkgdir" install
+
+  install -d "$pkgdir/usr/share/doc/$pkgname"
+  install -m644 doc/README* doc/*.txt "$pkgdir/usr/share/doc/$pkgname/"
+}
+md5sums=('a66797b4471e3cbe96575207bfbe252c')
diff --git a/abs/core/alsa-utils/PKGBUILD b/abs/core/alsa-utils/PKGBUILD
index 55a36a3..73fac66 100644
--- a/abs/core/alsa-utils/PKGBUILD
+++ b/abs/core/alsa-utils/PKGBUILD
@@ -3,13 +3,13 @@
 # Contributor: judd <jvinet@zeroflux.org>
 
 pkgname=alsa-utils
-pkgver=1.0.28
+pkgver=1.0.29
 pkgrel=1
 pkgdesc="An alternative implementation of Linux sound support"
 arch=('i686' 'x86_64')
 url="http://www.alsa-project.org"
 #can not use >=$pkgver due to use of letters in alsa-lib update versioning
-depends=("alsa-lib>1.0.24" 'dialog' 'pciutils' 'ncurses' 'psmisc' 'libsamplerate')
+depends=("alsa-lib>1.0.24" 'pciutils' 'ncurses' 'psmisc' 'libsamplerate')
 makedepends=('xmlto' 'docbook-xsl')
 license=('GPL')
 source=(ftp://ftp.alsa-project.org/pub/utils/$pkgname-${pkgver}.tar.bz2
@@ -38,5 +38,5 @@ package() {
   # dir where to save ALSA state
   install -d ${pkgdir}/var/lib/alsa
 }
-md5sums=('361552d5b1cacd0a1e7ba09e69990211'
+md5sums=('6b289bf874c4c9a63f4b3973093dd404'
          '529216f6a46e61a546640e08ea7a0879')
-- 
cgit v0.12