From db40f2ab304cc32d9a69ee215727c8663b757c53 Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Fri, 3 Oct 2008 21:07:38 -0700
Subject: adding tools for chroot-devel

---
 abs/chroot-devel-testing/README                    |  0
 abs/chroot-devel-testing/abs/ChangeLog             | 35 ----------------
 abs/chroot-devel-testing/abs/PKGBUILD              | 33 ---------------
 abs/chroot-devel-testing/abs/abs.install           | 15 -------
 abs/chroot-devel-testing/git/ChangeLog             | 26 ------------
 abs/chroot-devel-testing/git/PKGBUILD              | 49 ----------------------
 abs/chroot-devel/abs/ChangeLog                     | 35 ++++++++++++++++
 abs/chroot-devel/abs/PKGBUILD                      | 33 +++++++++++++++
 abs/chroot-devel/abs/abs.install                   | 15 +++++++
 abs/chroot-devel/git/ChangeLog                     | 26 ++++++++++++
 abs/chroot-devel/git/PKGBUILD                      | 49 ++++++++++++++++++++++
 abs/chroot-devel/intltool/ChangeLog                | 19 +++++++++
 abs/chroot-devel/intltool/PKGBUILD                 | 22 ++++++++++
 abs/chroot-devel/terminal/PKGBUILD                 | 25 +++++++++++
 .../terminal/terminal-dont-die-on-dbus-kill.patch  | 10 +++++
 abs/chroot-devel/terminal/terminal.install         | 11 +++++
 abs/chroot-devel/thunar/PKGBUILD                   | 31 ++++++++++++++
 abs/chroot-devel/thunar/thunar.install             | 18 ++++++++
 18 files changed, 294 insertions(+), 158 deletions(-)
 delete mode 100644 abs/chroot-devel-testing/README
 delete mode 100644 abs/chroot-devel-testing/abs/ChangeLog
 delete mode 100644 abs/chroot-devel-testing/abs/PKGBUILD
 delete mode 100644 abs/chroot-devel-testing/abs/abs.install
 delete mode 100644 abs/chroot-devel-testing/git/ChangeLog
 delete mode 100644 abs/chroot-devel-testing/git/PKGBUILD
 create mode 100644 abs/chroot-devel/abs/ChangeLog
 create mode 100644 abs/chroot-devel/abs/PKGBUILD
 create mode 100644 abs/chroot-devel/abs/abs.install
 create mode 100644 abs/chroot-devel/git/ChangeLog
 create mode 100644 abs/chroot-devel/git/PKGBUILD
 create mode 100644 abs/chroot-devel/intltool/ChangeLog
 create mode 100644 abs/chroot-devel/intltool/PKGBUILD
 create mode 100644 abs/chroot-devel/terminal/PKGBUILD
 create mode 100644 abs/chroot-devel/terminal/terminal-dont-die-on-dbus-kill.patch
 create mode 100644 abs/chroot-devel/terminal/terminal.install
 create mode 100644 abs/chroot-devel/thunar/PKGBUILD
 create mode 100644 abs/chroot-devel/thunar/thunar.install

diff --git a/abs/chroot-devel-testing/README b/abs/chroot-devel-testing/README
deleted file mode 100644
index e69de29..0000000
diff --git a/abs/chroot-devel-testing/abs/ChangeLog b/abs/chroot-devel-testing/abs/ChangeLog
deleted file mode 100644
index c33bcff..0000000
--- a/abs/chroot-devel-testing/abs/ChangeLog
+++ /dev/null
@@ -1,35 +0,0 @@
-2008-08-10 Allan McRae <allan@archlinux.org>
-
-	* 2.2-1
-	Upstream update
-	- adds ability to select which repos/packages
-	  sync on commandline
-	- additional PKGBUILD and install script prototypes
-
-2008-04-19 Travis Willard <travis@archlinux.org>
-
-	* 2.1-1
-	Upstream update - re-adds support for community
-
-2008-04-19 Travis Willard <travis@archlinux.org>
-
-	* 2.0-4
-	Added install warning about /var/abs
-
-2008-04-15 Travis Willard <travis@archlinux.org>
-
-	* 2.0-3
-	Added install message
-	Moved abs.conf to /etc instead of /etc/abs
-
-2008-04-13 Travis Willard <travis@archlinux.org>
-
-	* 2.0-2
-	Moved rsyncd.conf.abs to /usr/share/abs
-	Made rsync server configurable
-
-2008-04-10 Travis Willard <travis@archlinux.org>
-
-	* 2.0-1
-	Added ChangeLog
-	New rsync-based release
diff --git a/abs/chroot-devel-testing/abs/PKGBUILD b/abs/chroot-devel-testing/abs/PKGBUILD
deleted file mode 100644
index e38c9e9..0000000
--- a/abs/chroot-devel-testing/abs/PKGBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# $Id: PKGBUILD 8218 2008-08-09 14:48:26Z allan $
-# Maintainer: Allan McRae <allan@archlinux.org>
-
-pkgname=abs
-pkgver=2.2
-pkgrel=1
-pkgdesc="Utilities to download and work with the Arch Build System (ABS)"
-arch=('i686' 'x86_64')
-url="http://projects.archlinux.org/git/?p=abs.git"
-license=('GPL')
-depends=('bash' 'rsync')
-backup=(etc/abs.conf)
-install=abs.install
-source=(ftp://ftp.archlinux.org/other/abs/${pkgname}-${pkgver}.tar.gz)
-md5sums=('281f7def0b18d1545438290fcbf26db3')
-
-build() {
-  cd ${srcdir}/${pkgname}
-
-  make CONFDIR=/etc/ || return 1
-  make CONFDIR=/etc/ DESTDIR=${pkgdir} install || return 1
-
-  # Add readme file, and make base /var/abs path
-  install -dm0755 ${pkgdir}/var/abs/local/
-  install -Dm0644 ${srcdir}/abs/README ${pkgdir}/var/abs/README
-
-  # change ABS tags for x86_64 to correct values
-  if [ "$CARCH" = "x86_64" ]; then
-    sed -i "s|i686|x86_64|g" ${pkgdir}/etc/abs.conf
-  fi
-}
-
-# vim: set ts=2 sw=2 noet:
diff --git a/abs/chroot-devel-testing/abs/abs.install b/abs/chroot-devel-testing/abs/abs.install
deleted file mode 100644
index 1b19b4a..0000000
--- a/abs/chroot-devel-testing/abs/abs.install
+++ /dev/null
@@ -1,15 +0,0 @@
-## arg 1:  the new package version
-## arg 2:  the old package version
-pre_upgrade() {
-  if [ "$(vercmp $2 2.0-1)" -lt 0 ]; then
-    echo "==> ABS now uses rsync, instead of cvsup, to synchronize your tree."
-    echo "==> Please note the new configuration in /etc/abs.conf"
-  fi
-
-  if [ "$(vercmp $2 2.0-4)" -lt 0 ]; then
-    echo "==> Warning: abs clears out the contents of /var/abs when syncing."
-    echo "==> Keep all local PKGBUILDs in /var/abs/local, or they will disappear"
-  fi
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/abs/chroot-devel-testing/git/ChangeLog b/abs/chroot-devel-testing/git/ChangeLog
deleted file mode 100644
index 54cdeec..0000000
--- a/abs/chroot-devel-testing/git/ChangeLog
+++ /dev/null
@@ -1,26 +0,0 @@
-Simple version bumps are ommitted from the following ChangeLog.
-
-2008-09-14 Dan McGee <dan@archlinux.org>
-	Version 1.6.0.2-1
-	* Moved optional depends from install file to optdepends array 
-
-2008-06-15 Dan McGee <dan@archlinux.org>
-	Version 1.5.6-1
-	* Removed 'cpio' dependency, clone is now a builtin and no longer needs it
-
-2008-02-02 Dan McGee <dan@archlinux.org>
-	Version 1.5.4-1
-	* Upstream version 1.5.4
-	* Enable pthreads support in pack-objects. To use, set the pack.threads
-	  git config option. Read manpages of pack-objects and config for more
-	  details.
-	* Changelog added (with entries going back a bit).
-
-2008-01-28 Kevin Piche <kevin@archlinux.org>
-	Version 1.5.3.7-2
-	* Updated for new perl policy (vendor dirs)
-	* Change license to GPL2
-
-2007-11-01 Eric Belanger <eric@archlinux.org>
-	Version 1.5.3.5-2
-	* Fix Perl module location
diff --git a/abs/chroot-devel-testing/git/PKGBUILD b/abs/chroot-devel-testing/git/PKGBUILD
deleted file mode 100644
index 7863d4f..0000000
--- a/abs/chroot-devel-testing/git/PKGBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# $Id: PKGBUILD 12487 2008-09-14 16:45:00Z dan $
-# Maintainer: Dan McGee <dan@archlinux.org>
-
-pkgname=git
-pkgver=1.6.0.2
-pkgrel=2
-pkgdesc="GIT - the stupid content tracker"
-arch=(i686 x86_64)
-url="http://git.or.cz/"
-license=('GPL2')
-depends=('curl' 'expat>=2.0' 'perl-error' 'perl>=5.10.0')
-optdepends=('tk: gitk and git gui'
-            'perl-libwww: git svn'
-            'subversion: git svn'
-            'cvsps: git cvsimport')
-replaces=('git-core')
-provides=('git-core')
-source=("http://kernel.org/pub/software/scm/git/${pkgname}-${pkgver}.tar.bz2" \
-        "http://kernel.org/pub/software/scm/git/git-manpages-${pkgver}.tar.bz2")
-
-build() {
-  cd $srcdir/$pkgname-$pkgver
-  make THREADED_DELTA_SEARCH=1 \
-    prefix=/usr gitexecdir=/usr/lib/git-core || return 1
-  make THREADED_DELTA_SEARCH=1 \
-    prefix=/usr gitexecdir=/usr/lib/git-core \
-    INSTALLDIRS=vendor DESTDIR=${pkgdir} install
-  
-  # let's plop gitweb in /usr/share
-  mkdir -p $pkgdir/usr/share/ || return 1
-  cp -dR ./gitweb $pkgdir/usr/share/gitweb || return 1
-
-  #bash completion
-  mkdir -p $pkgdir/etc/bash_completion.d/ || return 1
-  install -m644 ./contrib/completion/git-completion.bash $pkgdir/etc/bash_completion.d/git || return 1
-
-  # how 'bout some manpages?
-  for mansect in man1 man5 man7; do
-    for manpage in $srcdir/$mansect/*; do
-      install -D -m644 $manpage $pkgdir/usr/share/man/$mansect/$(basename $manpage)
-    done
-  done
-
-  # remove perllocal.pod, .packlist, and empty directories.
-  rm -rf $pkgdir/usr/lib/perl5
-}
-
-md5sums=('1e4d9bfc1cb0abf165d4de93b5172324'
-         '30bd29d96b4576ef8b7b48ad791f613e')
diff --git a/abs/chroot-devel/abs/ChangeLog b/abs/chroot-devel/abs/ChangeLog
new file mode 100644
index 0000000..c33bcff
--- /dev/null
+++ b/abs/chroot-devel/abs/ChangeLog
@@ -0,0 +1,35 @@
+2008-08-10 Allan McRae <allan@archlinux.org>
+
+	* 2.2-1
+	Upstream update
+	- adds ability to select which repos/packages
+	  sync on commandline
+	- additional PKGBUILD and install script prototypes
+
+2008-04-19 Travis Willard <travis@archlinux.org>
+
+	* 2.1-1
+	Upstream update - re-adds support for community
+
+2008-04-19 Travis Willard <travis@archlinux.org>
+
+	* 2.0-4
+	Added install warning about /var/abs
+
+2008-04-15 Travis Willard <travis@archlinux.org>
+
+	* 2.0-3
+	Added install message
+	Moved abs.conf to /etc instead of /etc/abs
+
+2008-04-13 Travis Willard <travis@archlinux.org>
+
+	* 2.0-2
+	Moved rsyncd.conf.abs to /usr/share/abs
+	Made rsync server configurable
+
+2008-04-10 Travis Willard <travis@archlinux.org>
+
+	* 2.0-1
+	Added ChangeLog
+	New rsync-based release
diff --git a/abs/chroot-devel/abs/PKGBUILD b/abs/chroot-devel/abs/PKGBUILD
new file mode 100644
index 0000000..e38c9e9
--- /dev/null
+++ b/abs/chroot-devel/abs/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 8218 2008-08-09 14:48:26Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+
+pkgname=abs
+pkgver=2.2
+pkgrel=1
+pkgdesc="Utilities to download and work with the Arch Build System (ABS)"
+arch=('i686' 'x86_64')
+url="http://projects.archlinux.org/git/?p=abs.git"
+license=('GPL')
+depends=('bash' 'rsync')
+backup=(etc/abs.conf)
+install=abs.install
+source=(ftp://ftp.archlinux.org/other/abs/${pkgname}-${pkgver}.tar.gz)
+md5sums=('281f7def0b18d1545438290fcbf26db3')
+
+build() {
+  cd ${srcdir}/${pkgname}
+
+  make CONFDIR=/etc/ || return 1
+  make CONFDIR=/etc/ DESTDIR=${pkgdir} install || return 1
+
+  # Add readme file, and make base /var/abs path
+  install -dm0755 ${pkgdir}/var/abs/local/
+  install -Dm0644 ${srcdir}/abs/README ${pkgdir}/var/abs/README
+
+  # change ABS tags for x86_64 to correct values
+  if [ "$CARCH" = "x86_64" ]; then
+    sed -i "s|i686|x86_64|g" ${pkgdir}/etc/abs.conf
+  fi
+}
+
+# vim: set ts=2 sw=2 noet:
diff --git a/abs/chroot-devel/abs/abs.install b/abs/chroot-devel/abs/abs.install
new file mode 100644
index 0000000..1b19b4a
--- /dev/null
+++ b/abs/chroot-devel/abs/abs.install
@@ -0,0 +1,15 @@
+## arg 1:  the new package version
+## arg 2:  the old package version
+pre_upgrade() {
+  if [ "$(vercmp $2 2.0-1)" -lt 0 ]; then
+    echo "==> ABS now uses rsync, instead of cvsup, to synchronize your tree."
+    echo "==> Please note the new configuration in /etc/abs.conf"
+  fi
+
+  if [ "$(vercmp $2 2.0-4)" -lt 0 ]; then
+    echo "==> Warning: abs clears out the contents of /var/abs when syncing."
+    echo "==> Keep all local PKGBUILDs in /var/abs/local, or they will disappear"
+  fi
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/chroot-devel/git/ChangeLog b/abs/chroot-devel/git/ChangeLog
new file mode 100644
index 0000000..54cdeec
--- /dev/null
+++ b/abs/chroot-devel/git/ChangeLog
@@ -0,0 +1,26 @@
+Simple version bumps are ommitted from the following ChangeLog.
+
+2008-09-14 Dan McGee <dan@archlinux.org>
+	Version 1.6.0.2-1
+	* Moved optional depends from install file to optdepends array 
+
+2008-06-15 Dan McGee <dan@archlinux.org>
+	Version 1.5.6-1
+	* Removed 'cpio' dependency, clone is now a builtin and no longer needs it
+
+2008-02-02 Dan McGee <dan@archlinux.org>
+	Version 1.5.4-1
+	* Upstream version 1.5.4
+	* Enable pthreads support in pack-objects. To use, set the pack.threads
+	  git config option. Read manpages of pack-objects and config for more
+	  details.
+	* Changelog added (with entries going back a bit).
+
+2008-01-28 Kevin Piche <kevin@archlinux.org>
+	Version 1.5.3.7-2
+	* Updated for new perl policy (vendor dirs)
+	* Change license to GPL2
+
+2007-11-01 Eric Belanger <eric@archlinux.org>
+	Version 1.5.3.5-2
+	* Fix Perl module location
diff --git a/abs/chroot-devel/git/PKGBUILD b/abs/chroot-devel/git/PKGBUILD
new file mode 100644
index 0000000..7863d4f
--- /dev/null
+++ b/abs/chroot-devel/git/PKGBUILD
@@ -0,0 +1,49 @@
+# $Id: PKGBUILD 12487 2008-09-14 16:45:00Z dan $
+# Maintainer: Dan McGee <dan@archlinux.org>
+
+pkgname=git
+pkgver=1.6.0.2
+pkgrel=2
+pkgdesc="GIT - the stupid content tracker"
+arch=(i686 x86_64)
+url="http://git.or.cz/"
+license=('GPL2')
+depends=('curl' 'expat>=2.0' 'perl-error' 'perl>=5.10.0')
+optdepends=('tk: gitk and git gui'
+            'perl-libwww: git svn'
+            'subversion: git svn'
+            'cvsps: git cvsimport')
+replaces=('git-core')
+provides=('git-core')
+source=("http://kernel.org/pub/software/scm/git/${pkgname}-${pkgver}.tar.bz2" \
+        "http://kernel.org/pub/software/scm/git/git-manpages-${pkgver}.tar.bz2")
+
+build() {
+  cd $srcdir/$pkgname-$pkgver
+  make THREADED_DELTA_SEARCH=1 \
+    prefix=/usr gitexecdir=/usr/lib/git-core || return 1
+  make THREADED_DELTA_SEARCH=1 \
+    prefix=/usr gitexecdir=/usr/lib/git-core \
+    INSTALLDIRS=vendor DESTDIR=${pkgdir} install
+  
+  # let's plop gitweb in /usr/share
+  mkdir -p $pkgdir/usr/share/ || return 1
+  cp -dR ./gitweb $pkgdir/usr/share/gitweb || return 1
+
+  #bash completion
+  mkdir -p $pkgdir/etc/bash_completion.d/ || return 1
+  install -m644 ./contrib/completion/git-completion.bash $pkgdir/etc/bash_completion.d/git || return 1
+
+  # how 'bout some manpages?
+  for mansect in man1 man5 man7; do
+    for manpage in $srcdir/$mansect/*; do
+      install -D -m644 $manpage $pkgdir/usr/share/man/$mansect/$(basename $manpage)
+    done
+  done
+
+  # remove perllocal.pod, .packlist, and empty directories.
+  rm -rf $pkgdir/usr/lib/perl5
+}
+
+md5sums=('1e4d9bfc1cb0abf165d4de93b5172324'
+         '30bd29d96b4576ef8b7b48ad791f613e')
diff --git a/abs/chroot-devel/intltool/ChangeLog b/abs/chroot-devel/intltool/ChangeLog
new file mode 100644
index 0000000..f234947
--- /dev/null
+++ b/abs/chroot-devel/intltool/ChangeLog
@@ -0,0 +1,19 @@
+2008-07-28  Eric Belanger  <eric@archlinux.org>
+
+	* intltool 0.40.3-1
+	* Upstream update
+
+2008-07-23  Eric Belanger  <eric@archlinux.org>
+
+	* intltool 0.40.1-1
+	* Upstream update
+
+2008-06-08  Eric Belanger  <eric@archlinux.org>
+
+	* intltool 0.40.0-1
+	* Upstream update
+
+2008-03-01  Eric Belanger  <eric@archlinux.org>
+
+	* intltool 0.37.1-1
+	* Upstream update
diff --git a/abs/chroot-devel/intltool/PKGBUILD b/abs/chroot-devel/intltool/PKGBUILD
new file mode 100644
index 0000000..562e51e
--- /dev/null
+++ b/abs/chroot-devel/intltool/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 7286 2008-07-29 01:10:32Z eric $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=intltool
+pkgver=0.40.3
+pkgrel=1
+pkgdesc="The internationalization tool collection"
+arch=('i686' 'x86_64')
+url="http://freedesktop.org/wiki/Software/intltool"
+license=('GPL')
+depends=('perlxml')
+source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('7adee54938b22d32c63ecb5223fd4249')
+sha1sums=('888f0b91cae35ef7821919d681b69a6ce81fd525')
+
+build() {
+  cd ${srcdir}/${pkgname}-${pkgver}
+  ./configure --prefix=/usr || return 1
+  make || return 1
+  make DESTDIR=${pkgdir} install || return 1
+}
diff --git a/abs/chroot-devel/terminal/PKGBUILD b/abs/chroot-devel/terminal/PKGBUILD
new file mode 100644
index 0000000..9f17eee
--- /dev/null
+++ b/abs/chroot-devel/terminal/PKGBUILD
@@ -0,0 +1,25 @@
+
+pkgname=terminal
+pkgver=0.2.8
+pkgrel=3
+pkgdesc="A modern terminal emulator primarly for the Xfce desktop environment"
+arch=(i686 x86_64)
+license=('GPL2')
+url="http://www.xfce.org/projects/terminal/"
+groups=('xfce4')
+depends=('exo>=0.3.4' 'vte>=0.16.14' 'dbus-glib>=0.76'
+	 'hicolor-icon-theme')
+makedepends=('pkgconfig')
+options=('!libtool')
+install=terminal.install
+source=(http://www.xfce.org/archive/xfce-4.4.2/src/Terminal-${pkgver}.tar.bz2
+	terminal-dont-die-on-dbus-kill.patch)
+
+build() {
+  cd ${srcdir}/Terminal-${pkgver}
+  patch -Np0 -i ${srcdir}/terminal-dont-die-on-dbus-kill.patch || return 1
+  ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/xfce4 \
+    --localstatedir=/var --disable-static || return 1
+  make || return 1
+  make DESTDIR=${pkgdir} install || return 1
+}
diff --git a/abs/chroot-devel/terminal/terminal-dont-die-on-dbus-kill.patch b/abs/chroot-devel/terminal/terminal-dont-die-on-dbus-kill.patch
new file mode 100644
index 0000000..e20e45c
--- /dev/null
+++ b/abs/chroot-devel/terminal/terminal-dont-die-on-dbus-kill.patch
@@ -0,0 +1,10 @@
+--- terminal/terminal-dbus.c.orig	2007-01-23 22:25:12.000000000 +0000
++++ terminal/terminal-dbus.c	2007-01-23 22:25:50.000000000 +0000
+@@ -191,6 +191,7 @@ terminal_dbus_register_service (Terminal
+ 
+   /* register DBus connection with GLib main loop */
+   dbus_connection_setup_with_g_main (connection, NULL);
++  dbus_connection_set_exit_on_disconnect (connection, FALSE);
+ 
+   if (dbus_bus_request_name (connection, TERMINAL_DBUS_SERVICE, 0, &derror) < 0)
+     {
diff --git a/abs/chroot-devel/terminal/terminal.install b/abs/chroot-devel/terminal/terminal.install
new file mode 100644
index 0000000..21b79d2
--- /dev/null
+++ b/abs/chroot-devel/terminal/terminal.install
@@ -0,0 +1,11 @@
+post_install() {
+  gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+  post_install $1
+}
+
+post_remove() {
+  gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
diff --git a/abs/chroot-devel/thunar/PKGBUILD b/abs/chroot-devel/thunar/PKGBUILD
new file mode 100644
index 0000000..bc05564
--- /dev/null
+++ b/abs/chroot-devel/thunar/PKGBUILD
@@ -0,0 +1,31 @@
+
+pkgname=thunar
+pkgver=0.9.0
+pkgrel=2
+pkgdesc="new modern file manager for Xfce"
+arch=(i686 x86_64)
+license=('GPL2' 'LGPL2')
+url="http://thunar.xfce.org"
+groups=('xfce4') 
+depends=('exo>=0.3.4' 'shared-mime-info' 'pcre' \
+         'desktop-file-utils' 'libexif' 'hal'  \
+         )
+makedepends=('intltool' 'pkgconfig')
+options=('!libtool')
+install=${pkgname}.install
+source=(http://www.xfce.org/archive/xfce-4.4.2/src/Thunar-${pkgver}.tar.bz2 \
+        http://foo-projects.org/pipermail/thunar-dev/attachments/20071203/a44d5411/thunar-vfs-volume-hal_missing-audio-cds-for-volman.bin \
+		  http://bugzilla.xfce.org/attachment.cgi?id=1452
+)
+
+build() {
+  cd ${startdir}/src/Thunar-${pkgver}
+  patch -Np0 -i ../thunar-vfs-volume-hal_missing-audio-cds-for-volman.bin || return 1
+  patch -Np0 -i ../attachment.cgi?id=1452 || return 1
+  ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/xfce4 \
+    --localstatedir=/var --disable-static \
+    --disable-gnome-thumbnailers --enable-exif --enable-pcre --disable-fam
+  make || return 1
+  make DESTDIR=${startdir}/pkg install
+  sed -i 's:x-directory/gnome-default-handler;::' ${startdir}/pkg/usr/share/applications/Thunar-folder-handler.desktop
+}
diff --git a/abs/chroot-devel/thunar/thunar.install b/abs/chroot-devel/thunar/thunar.install
new file mode 100644
index 0000000..8cf0d85
--- /dev/null
+++ b/abs/chroot-devel/thunar/thunar.install
@@ -0,0 +1,18 @@
+post_install() {
+  update-desktop-database -q
+  gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+  post_install $1
+}
+
+post_remove() {
+  update-desktop-database -q
+  gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+op=$1
+shift
+
+$op $*
-- 
cgit v0.12