From fa2365c27675c5f9da21f74e25263f9c24897bec Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Mon, 20 Sep 2010 00:57:29 +0000
Subject: gpm: update

---
 abs/core-testing/gpm/ChangeLog   | 28 ++++++++++++++++++++++++++++
 abs/core-testing/gpm/PKGBUILD    | 33 +++++++++++++++++----------------
 abs/core-testing/gpm/gpm         |  5 +++--
 abs/core-testing/gpm/gpm.conf.d  |  2 +-
 abs/core-testing/gpm/gpm.install | 16 ++++++++++++++++
 abs/core-testing/gpm/gpm.sh      |  3 +++
 6 files changed, 68 insertions(+), 19 deletions(-)
 create mode 100644 abs/core-testing/gpm/gpm.install
 create mode 100755 abs/core-testing/gpm/gpm.sh

diff --git a/abs/core-testing/gpm/ChangeLog b/abs/core-testing/gpm/ChangeLog
index c6c6a14..847bb4d 100644
--- a/abs/core-testing/gpm/ChangeLog
+++ b/abs/core-testing/gpm/ChangeLog
@@ -1,3 +1,31 @@
+2009-12-05  Eric Belanger  <eric@archlinux.org>
+
+	* gpm 1.20.6-5
+	* Fixed gpm.sh such that disable-paste is only run when gpm is running
+
+2009-12-05  Eric Belanger  <eric@archlinux.org>
+
+	* gpm 1.20.6-4
+	* Added profile for extra security on multi-user-console (close	FS#17243)
+	* Removed the need of texinfo depends
+
+2009-09-20  Eric Belanger  <eric@archlinux.org>
+
+	* gpm 1.20.6-3
+	* Updated /dev/psaux to /dev/input/mice in stock config (close FS#16289)
+
+2009-09-20  Eric Belanger  <eric@archlinux.org>
+
+	* gpm 1.20.6-2
+	* Updated stock config and fixed rc.d script (close FS#16126)
+	* Removed array in install scriptlet
+
+2009-02-09  Eric Belanger  <eric@archlinux.org>
+
+	* gpm 1.20.6-1
+	* Upstream update
+	* Added info file support
+
 2008-06-16  Eric Belanger  <eric@archlinux.org>
 
 	* gpm 1.20.5-1
diff --git a/abs/core-testing/gpm/PKGBUILD b/abs/core-testing/gpm/PKGBUILD
index 7a7c571..12ecf4d 100644
--- a/abs/core-testing/gpm/PKGBUILD
+++ b/abs/core-testing/gpm/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 3002 2008-06-18 01:56:59Z eric $
+# $Id: PKGBUILD 60782 2009-12-07 00:52:55Z eric $
 # Maintainer: Eric Belanger <eric@archlinux.org>
 # Contributor: Tom Newsom <Jeepster@gmx.co.uk>
 
 pkgname=gpm
-pkgver=1.20.5
-pkgrel=1
+pkgver=1.20.6
+pkgrel=5
 pkgdesc="A mouse server for the console and xterm"
 arch=('i686' 'x86_64')
 url="http://unix.schottelius.org/gpm/"
@@ -12,24 +12,25 @@ license=('GPL')
 depends=('ncurses')
 backup=('etc/conf.d/gpm')
 options=('!makeflags')
-source=(http://unix.schottelius.org/gpm/archives/${pkgname}-${pkgver}.tar.bz2 \
-        gpm gpm.conf.d)
-md5sums=('e55473932e4052f3b74c730dfefe0d15' 'c4d42a4725503a5524cae060a959a3d3'\
-         '5f109341a7d1bb18c59d7c3a395d848a')
-sha1sums=('4a8c2109167da8e60055c25dadc383d02ba32538'
-          'c13ad1422d24af320e2abb9786c7eacef39b293c'
-          '3bcb67027f0ad7dc393388fb02c261126671f9f5')
+install=gpm.install
+source=(http://www.nico.schottelius.org/software/gpm/archives/${pkgname}-${pkgver}.tar.bz2 \
+        gpm gpm.conf.d gpm.sh)
+md5sums=('6b534da16dc1b28ba828dea89e520f6f' '945ecde0836687e05c13ea837092ea6c'\
+         '63e599950946e5f5a649432510aacf4c' 'e391fe4599ce102615f9cd449c380d41')
+sha1sums=('f3bb9272878b7934968381c8b25edab359114150' '19e1feb1493373512a77801699df012d186336ea'\
+         'e483f893b4e6b9e1221a208527d728ffefe5438e' '88fe5ff10916c68a87abc8418a56eb0073f69fa9')
 
 build() {
-  cd ${startdir}/src/${pkgname}-${pkgver}
+  cd "${srcdir}/${pkgname}-${pkgver}"
   ./configure --prefix=/usr --sysconfdir=/etc || return 1
   make || return 1
-  make DESTDIR=${startdir}/pkg install || return 1
-  install -D -m755 ../gpm ${startdir}/pkg/etc/rc.d/gpm || return 1
-  install -D -m644 ../gpm.conf.d ${startdir}/pkg/etc/conf.d/gpm || return 1
+  make DESTDIR="${pkgdir}" install || return 1
+  install -D -m755 ../gpm "${pkgdir}/etc/rc.d/gpm" || return 1
+  install -D -m644 ../gpm.conf.d "${pkgdir}/etc/conf.d/gpm" || return 1
+  install -D -m755 ../gpm.sh "${pkgdir}/etc/profile.d/gpm.sh" || return 1
 
 # library fixes
-  cd ${startdir}/pkg/usr/lib/
+  cd "${pkgdir}/usr/lib/"
   ln -s libgpm.so.2.* libgpm.so || return 1
-  chmod 755 ${startdir}/pkg/usr/lib/libgpm.so.* || return 1
+  chmod 755 "${pkgdir}"/usr/lib/libgpm.so.* || return 1
 }
diff --git a/abs/core-testing/gpm/gpm b/abs/core-testing/gpm/gpm
index 4acc908..7b5213d 100755
--- a/abs/core-testing/gpm/gpm
+++ b/abs/core-testing/gpm/gpm
@@ -7,12 +7,13 @@ GPM_ARGS=
 . /etc/rc.conf
 . /etc/rc.d/functions
 
-PID=`pidof -o %PPID /usr/sbin/gpm`
+PID=$(pidof -o %PPID /usr/sbin/gpm)
 case "$1" in
   start)
     stat_busy "Starting GPM Daemon"
     [ -z "$PID" ] && /usr/sbin/gpm ${GPM_ARGS}
-    if [ $? -gt 0 ]; then
+    PID=$(pidof -o %PPID /usr/sbin/gpm)
+    if [ -z "$PID" ]; then
       stat_fail
     else
       add_daemon gpm
diff --git a/abs/core-testing/gpm/gpm.conf.d b/abs/core-testing/gpm/gpm.conf.d
index ed84f91..9d8c981 100644
--- a/abs/core-testing/gpm/gpm.conf.d
+++ b/abs/core-testing/gpm/gpm.conf.d
@@ -1,4 +1,4 @@
 #
 # Parameters to be passed to gpm
 #
-GPM_ARGS="-m /dev/misc/psaux"
+GPM_ARGS="-m /dev/input/mice"
diff --git a/abs/core-testing/gpm/gpm.install b/abs/core-testing/gpm/gpm.install
new file mode 100644
index 0000000..2a1519a
--- /dev/null
+++ b/abs/core-testing/gpm/gpm.install
@@ -0,0 +1,16 @@
+infodir=/usr/share/info
+file=gpm.info.gz
+
+post_install() {
+  [ -x usr/bin/install-info ] || return 0
+  install-info $infodir/$file $infodir/dir 2> /dev/null
+}
+
+post_upgrade() {
+  post_install $1
+}
+
+pre_remove() {
+  [ -x usr/bin/install-info ] || return 0
+  install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+}
diff --git a/abs/core-testing/gpm/gpm.sh b/abs/core-testing/gpm/gpm.sh
new file mode 100755
index 0000000..af35a5f
--- /dev/null
+++ b/abs/core-testing/gpm/gpm.sh
@@ -0,0 +1,3 @@
+case $( /usr/bin/tty ) in
+    /dev/tty[0-9]*) [ -n "$(pgrep gpm)" ] && /usr/bin/disable-paste ;;
+esac
-- 
cgit v0.12