From 0679d85750de6e352a3c79c87ab62ee8a868116d Mon Sep 17 00:00:00 2001
From: James Meyer <james.meyer@operamail.com>
Date: Thu, 9 Aug 2012 16:58:35 -0500
Subject: linhes-system: removed .install script

---
 abs/core/LinHES-system/LinHES.install | 104 ----------------------------------
 abs/core/LinHES-system/PKGBUILD       |   4 +-
 abs/core/LinHES-system/system.install | 104 ++++++++++++++++++++++++++++++++++
 3 files changed, 106 insertions(+), 106 deletions(-)
 delete mode 100644 abs/core/LinHES-system/LinHES.install
 create mode 100644 abs/core/LinHES-system/system.install

diff --git a/abs/core/LinHES-system/LinHES.install b/abs/core/LinHES-system/LinHES.install
deleted file mode 100644
index c9950f2..0000000
--- a/abs/core/LinHES-system/LinHES.install
+++ /dev/null
@@ -1,104 +0,0 @@
-# This is a default template for a post-install scriptlet.  You can
-# remove any functions you don't need (and this header).
-
-# arg 1:  the new package version
-pre_install() {
-/bin/true
-}
-
-# arg 1:  the new package version
-post_install() {
-MVDIR=/usr/LH/bin
-#	ln -s  $MVDIR/backup_job /etc/cron.daily/backup_cron
-#	ln -s  $MVDIR/update_system  /etc/cron.daily/xupdate_system_cron
-#	ln -s  $MVDIR/repo_sync.sh  /etc/cron.daily/zrepo_sync.sh
-	if [ ! -e /etc/cron.daily/myth_mtc ]
-	then
-		ln -s  $MVDIR/myth_mtc.sh  /etc/cron.daily/myth_mtc
-	fi
-	if [  -e /etc/cron.daily/myth_mtc.sh ]
-	then
-		rm -f  /etc/cron.daily/myth_mtc.sh
-	fi
-#LINE="mythtv    ALL = NOPASSWD: /sbin/sv stop mythbackend"
-LINE="mythtv 	ALL=(ALL)       NOPASSWD: ALL"
-LINE1="%wheel 	ALL=(ALL)       NOPASSWD: ALL"
-
-
-for i in "$LINE" "$LINE1" "$LINE2" "$LINE3" "$LINE4" "$LINE5" "$LINE7" "$LINE8" "$LINE9"  "$LINE10" "$LINE11" "$LINE12" "$LINE13" "$LINE14" "$LINE15" "$LINE16"
-do
-        cp /etc/sudoers /etc/sudoers.bak
-        grep -q "$i" /etc/sudoers
-        if [ $? != 0 ]
-        then
-                echo  "$i" >> /etc/sudoers
-                visudo -cf /etc/sudoers
-                if [ ! $? = 0 ]
-                then
-                        cp /etc/sudoers.bak /etc/sudoers
-			echo $i
-                        echo "Error adding files"
-                        exit 1
-                fi
-        fi
-done
-
-REALTIME="session         required        pam_limits.so"
-grep -q "pam_limits.so" /etc/pam.d/su
-        if [ $? != 0 ]
-        then
-		echo "$REALTIME" >>  /etc/pam.d/su
-
-	fi
-
-# Update mythtv's fluxbox keys files to use the tvterm.sh script to get 
-# an xterm. Then signal fluxbox to re-read the keys file.
-
-sed -i.orig 's/^Mod1 x :.*xterm.*$/Mod1 x :ExecCommand tvterm.sh/g' \
-  ~mythtv/.fluxbox/keys
-pkill -HUP fluxbox
-
-
-
-
-}
-
-# arg 1:  the new package version
-# arg 2:  the old package version
-pre_upgrade() {
-	if [ -e  /etc/cron.daily/backup_cron ]
-	then
-		rm -f  /etc/cron.daily/backup_cron
-	fi
-	if [ -e /etc/cron.daily/xupdate_system_cron ]
-	then
-		rm -f /etc/cron.daily/xupdate_system_cron
-	fi
-
-	if [ -e /etc/cron.daily/myth_mtc.py ]
-	then
-		rm -f /etc/cron.daily/myth_mtc.py
-	fi
-
-
-}
-
-# arg 1:  the new package version
-# arg 2:  the old package version
-post_upgrade() {
-	post_install
-}
-
-# arg 1:  the old package version
-pre_remove() {
-  /bin/true
-}
-
-# arg 1:  the old package version
-post_remove() {
-  /bin/true
-}
-
-op=$1
-shift
-$op $*
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 2c605e6..0dcefd7 100644
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -4,9 +4,8 @@ pkgrel=52
 arch=('i686' 'x86_64')
 MVDIR=$startdir/pkg/usr/LH
 BINDIR=$startdir/pkg/usr/bin
-install=LinHES.install
+#install=LinHES.install
 pkgdesc="scripts and things related to having an  automated system"
-#depends=(linhes-sounds xdotool tilda keylaunch python_aosd 'linhes-scripts>=7-24' 'runit-scripts>=2.1.1-43' 'udisks' 'LinHES-config>=2.3-59')
 depends=(linhes-sounds xdotool tilda keylaunch python_aosd 'linhes-scripts>=7-24' 'udisks' 'LinHES-config>=2.3-59' 'sudo')
 backup=(etc/modprobe.d/alsa-base)
 binfiles="LinHES-start optimize_mythdb.py
@@ -26,6 +25,7 @@ binfiles="LinHES-start optimize_mythdb.py
 
 source=(LinHES-session LinHES-profile.sh $binfiles alsa-base myth_mtc.lr 
  diskspace smolt.cron cacheclean.cron)
+
 build() {
         cd $startdir/src
         install -m755 -D LinHES-session $startdir/pkg/etc/X11/Sessions/LinHES
diff --git a/abs/core/LinHES-system/system.install b/abs/core/LinHES-system/system.install
new file mode 100644
index 0000000..c9950f2
--- /dev/null
+++ b/abs/core/LinHES-system/system.install
@@ -0,0 +1,104 @@
+# This is a default template for a post-install scriptlet.  You can
+# remove any functions you don't need (and this header).
+
+# arg 1:  the new package version
+pre_install() {
+/bin/true
+}
+
+# arg 1:  the new package version
+post_install() {
+MVDIR=/usr/LH/bin
+#	ln -s  $MVDIR/backup_job /etc/cron.daily/backup_cron
+#	ln -s  $MVDIR/update_system  /etc/cron.daily/xupdate_system_cron
+#	ln -s  $MVDIR/repo_sync.sh  /etc/cron.daily/zrepo_sync.sh
+	if [ ! -e /etc/cron.daily/myth_mtc ]
+	then
+		ln -s  $MVDIR/myth_mtc.sh  /etc/cron.daily/myth_mtc
+	fi
+	if [  -e /etc/cron.daily/myth_mtc.sh ]
+	then
+		rm -f  /etc/cron.daily/myth_mtc.sh
+	fi
+#LINE="mythtv    ALL = NOPASSWD: /sbin/sv stop mythbackend"
+LINE="mythtv 	ALL=(ALL)       NOPASSWD: ALL"
+LINE1="%wheel 	ALL=(ALL)       NOPASSWD: ALL"
+
+
+for i in "$LINE" "$LINE1" "$LINE2" "$LINE3" "$LINE4" "$LINE5" "$LINE7" "$LINE8" "$LINE9"  "$LINE10" "$LINE11" "$LINE12" "$LINE13" "$LINE14" "$LINE15" "$LINE16"
+do
+        cp /etc/sudoers /etc/sudoers.bak
+        grep -q "$i" /etc/sudoers
+        if [ $? != 0 ]
+        then
+                echo  "$i" >> /etc/sudoers
+                visudo -cf /etc/sudoers
+                if [ ! $? = 0 ]
+                then
+                        cp /etc/sudoers.bak /etc/sudoers
+			echo $i
+                        echo "Error adding files"
+                        exit 1
+                fi
+        fi
+done
+
+REALTIME="session         required        pam_limits.so"
+grep -q "pam_limits.so" /etc/pam.d/su
+        if [ $? != 0 ]
+        then
+		echo "$REALTIME" >>  /etc/pam.d/su
+
+	fi
+
+# Update mythtv's fluxbox keys files to use the tvterm.sh script to get 
+# an xterm. Then signal fluxbox to re-read the keys file.
+
+sed -i.orig 's/^Mod1 x :.*xterm.*$/Mod1 x :ExecCommand tvterm.sh/g' \
+  ~mythtv/.fluxbox/keys
+pkill -HUP fluxbox
+
+
+
+
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+pre_upgrade() {
+	if [ -e  /etc/cron.daily/backup_cron ]
+	then
+		rm -f  /etc/cron.daily/backup_cron
+	fi
+	if [ -e /etc/cron.daily/xupdate_system_cron ]
+	then
+		rm -f /etc/cron.daily/xupdate_system_cron
+	fi
+
+	if [ -e /etc/cron.daily/myth_mtc.py ]
+	then
+		rm -f /etc/cron.daily/myth_mtc.py
+	fi
+
+
+}
+
+# arg 1:  the new package version
+# arg 2:  the old package version
+post_upgrade() {
+	post_install
+}
+
+# arg 1:  the old package version
+pre_remove() {
+  /bin/true
+}
+
+# arg 1:  the old package version
+post_remove() {
+  /bin/true
+}
+
+op=$1
+shift
+$op $*
-- 
cgit v0.12